aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-08-08 23:15:08 -0600
committerChristoph Junghans <ottxor@gentoo.org>2012-08-08 23:15:35 -0600
commit755887d19235cb48a38de2e17eaefff1eb9d0a95 (patch)
tree395d3c6cb8d9f42ed10b159ce2efefa34228ba02
parentcmake-utils.eclass: added ninja support (diff)
downloadsci-755887d19235cb48a38de2e17eaefff1eb9d0a95.tar.gz
sci-755887d19235cb48a38de2e17eaefff1eb9d0a95.tar.bz2
sci-755887d19235cb48a38de2e17eaefff1eb9d0a95.zip
use ninja if available
(Portage version: 2.2.0_alpha120/git/Linux i686, unsigned Manifest commit)
-rw-r--r--sci-chemistry/gromacs/ChangeLog3
-rw-r--r--sci-chemistry/gromacs/gromacs-4.6.9999.ebuild8
2 files changed, 6 insertions, 5 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index 7af763e12..e597ab8bd 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 09 Aug 2012; Christoph Junghans <ottxor@gentoo.org> gromacs-4.6.9999.ebuild:
+ use ninja if available
+
25 Jul 2012; Christoph Junghans <ottxor@gentoo.org> gromacs-4.5.9999.ebuild,
gromacs-4.6.9999.ebuild, gromacs-9999.ebuild:
added ~x86-macos
diff --git a/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild b/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
index eac62657e..f54af37be 100644
--- a/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
@@ -10,6 +10,8 @@ MANUAL_PV="4.5.4"
#to find external blas/lapack
CMAKE_MIN_VERSION="2.8.5-r2"
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
inherit bash-completion-r1 cmake-utils eutils fortran-2 multilib toolchain-funcs
SRC_URI="test? ( ftp://ftp.gromacs.org/pub/tests/gmxtest-${TEST_PV}.tgz )
@@ -192,7 +194,7 @@ src_install() {
#cmake-utils_src_install does not support args
#using cmake-utils_src_make instead
CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" \
- cmake-utils_src_make install-mdrun DESTDIR="${D}"
+ DESTDIR="${D}" cmake-utils_src_make install-mdrun
done
rm -f "${ED}"/usr/bin/GMXRC*
@@ -204,10 +206,6 @@ src_install() {
fi
rm -f "${ED}"/usr/bin/completion.*
- # Fix typos in a couple of files.
- sed -e "s:+0f:-f:" -i "${ED}"usr/share/gromacs/tutor/gmxdemo/demo \
- || die "Failed to fixup demo script."
-
cd "${S}"
dodoc AUTHORS INSTALL* README*
if use doc; then