aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2018-10-28 02:48:10 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2018-10-28 02:48:10 +0300
commit757220cb559ce9a264be428b525af9ca50f47feb (patch)
tree402abb712a4102056744c19f0fa4432fe8ffb584
parentDeprecate EAPI=6 (diff)
downloadsci-757220cb559ce9a264be428b525af9ca50f47feb.tar.gz
sci-757220cb559ce9a264be428b525af9ca50f47feb.tar.bz2
sci-757220cb559ce9a264be428b525af9ca50f47feb.zip
sci-chemistry/gamess: fix openmp support detection
tc-has-openmp checks C compiler for openmp support. While in most cases Fortran compiler with have this support as well if C one has, we need to check Fortran compiler explicitely to be absolutely sure. fortran-2 eclass has FORTRAN_NEED_OPENMP variable for such check to be performed. Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--sci-chemistry/gamess/gamess-20180930.3.ebuild5
1 files changed, 1 insertions, 4 deletions
diff --git a/sci-chemistry/gamess/gamess-20180930.3.ebuild b/sci-chemistry/gamess/gamess-20180930.3.ebuild
index fe96a626b..44e7fa323 100644
--- a/sci-chemistry/gamess/gamess-20180930.3.ebuild
+++ b/sci-chemistry/gamess/gamess-20180930.3.ebuild
@@ -78,6 +78,7 @@ get_fcomp() {
pkg_setup() {
pre_build_checks
+ use openmp && FORTRAN_NEED_OPENMP=1
fortran-2_pkg_setup
get_fcomp
# currently amd64 is only supported with gfortran
@@ -106,10 +107,6 @@ pkg_setup() {
ewarn "because deafult one will not work"
ewarn ""
fi
-
- if use openmp; then
- tc-has-openmp || die "Please use an openmp capable compiler like gcc[openmp]"
- fi
}
src_unpack() {