aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-19 08:16:08 +0200
committerJustin Lecher <jlec@gentoo.org>2012-10-19 08:16:08 +0200
commit76464e08559917f0e55c183028cb6e016ae5a61a (patch)
tree15c4e1df3e3d3d7a03bec9810539f34fecdfabdc
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
parent[sci-mathematics/scilab] revert part of commit 033255b367 (diff)
downloadsci-76464e08559917f0e55c183028cb6e016ae5a61a.tar.gz
sci-76464e08559917f0e55c183028cb6e016ae5a61a.tar.bz2
sci-76464e08559917f0e55c183028cb6e016ae5a61a.zip
Merge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci
* 'master' of git+ssh://git.overlays.gentoo.org/proj/sci: [sci-mathematics/scilab] revert part of commit 033255b367
-rw-r--r--sci-mathematics/scilab/scilab-5.3.3-r1.ebuild4
-rw-r--r--sci-mathematics/scilab/scilab-5.4.0.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/sci-mathematics/scilab/scilab-5.3.3-r1.ebuild b/sci-mathematics/scilab/scilab-5.3.3-r1.ebuild
index 912bb8154..a9883eaf8 100644
--- a/sci-mathematics/scilab/scilab-5.3.3-r1.ebuild
+++ b/sci-mathematics/scilab/scilab-5.3.3-r1.ebuild
@@ -93,6 +93,10 @@ pkg_pretend() {
pkg_setup() {
if use openmp; then
+ if [[ $(tc-getCC) == *gcc* ]] && ! tc-has-openmp; then
+ ewarn "You are using a gcc without OpenMP capabilities"
+ die "Need an OpenMP capable compiler"
+ fi
FORTRAN_NEED_OPENMP=1
fi
FORTRAN_STANDARD="77 90"
diff --git a/sci-mathematics/scilab/scilab-5.4.0.ebuild b/sci-mathematics/scilab/scilab-5.4.0.ebuild
index 0b245d6f2..f2e4e6cf8 100644
--- a/sci-mathematics/scilab/scilab-5.4.0.ebuild
+++ b/sci-mathematics/scilab/scilab-5.4.0.ebuild
@@ -96,6 +96,10 @@ pkg_pretend() {
pkg_setup() {
if use openmp; then
+ if [[ $(tc-getCC) == *gcc* ]] && ! tc-has-openmp; then
+ ewarn "You are using a gcc without OpenMP capabilities"
+ die "Need an OpenMP capable compiler"
+ fi
FORTRAN_NEED_OPENMP=1
fi
FORTRAN_STANDARD="77 90"