aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-07-01 00:02:59 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-07-01 00:02:59 +0200
commit76c8aa5fabb5f1ae43d4fdf831bcf94b7e6e09a6 (patch)
tree990f61e5b29da039ab369c2507d173b3aa0a26bc
parentsci-biology/kallisto: provide license text, version bump (diff)
downloadsci-76c8aa5fabb5f1ae43d4fdf831bcf94b7e6e09a6.tar.gz
sci-76c8aa5fabb5f1ae43d4fdf831bcf94b7e6e09a6.tar.bz2
sci-76c8aa5fabb5f1ae43d4fdf831bcf94b7e6e09a6.zip
sci-biology/abyss: version bump, update SRC_URI
Package-Manager: portage-2.2.28
-rw-r--r--sci-biology/abyss/Manifest1
-rw-r--r--sci-biology/abyss/abyss-1.9.0.ebuild52
-rw-r--r--sci-biology/abyss/files/abyss-1.9.0-ac_prog_ar.patch18
-rw-r--r--sci-biology/abyss/metadata.xml15
4 files changed, 86 insertions, 0 deletions
diff --git a/sci-biology/abyss/Manifest b/sci-biology/abyss/Manifest
new file mode 100644
index 000000000..86f6ec972
--- /dev/null
+++ b/sci-biology/abyss/Manifest
@@ -0,0 +1 @@
+DIST abyss-1.9.0.tar.gz 985480 SHA256 82e4050766a9c7fb87fd736f94724a02388efb1df847b40870a0fbf842917239 SHA512 d9da19f004bb97f9301f3be83ceb5361eb70f42139a1ef17129de99e03bda5de7680d718d76aed26d26f24c1d26c37e050801ff343acad007b76d2214955b83f WHIRLPOOL bd322afa9bf99a53aec177c79ca9618f39043cda606eb4e3d5dcfb46c26298d218fc154e2c46efadac59febb69dd625fe597101a1efbccc62ab8228b555596cc
diff --git a/sci-biology/abyss/abyss-1.9.0.ebuild b/sci-biology/abyss/abyss-1.9.0.ebuild
new file mode 100644
index 000000000..b2de141fd
--- /dev/null
+++ b/sci-biology/abyss/abyss-1.9.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
+SRC_URI="https://github.com/bcgsc/abyss/archive/1.9.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="abyss"
+SLOT="0"
+IUSE="+mpi openmp misc-haskell"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-cpp/sparsehash
+ dev-libs/boost
+ misc-haskell? ( dev-libs/gmp:0=
+ virtual/libffi:0=
+ )
+ mpi? ( virtual/mpi )
+"
+DEPEND="${RDEPEND}
+ misc-haskell? ( dev-lang/ghc
+ dev-haskell/mmap )
+"
+
+# todo: --enable-maxk=N configure option
+# todo: fix automagic mpi toggling
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ac_prog_ar.patch
+)
+
+src_prepare() {
+ default
+ tc-export AR
+ sed -i -e "s/-Werror//" configure.ac || die #365195
+ sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ # disable building haskell tool Misc/samtobreak
+ # unless request by user: bug #534412
+ use misc-haskell || export ac_cv_prog_ac_ct_GHC=
+
+ econf $(use_enable openmp)
+}
diff --git a/sci-biology/abyss/files/abyss-1.9.0-ac_prog_ar.patch b/sci-biology/abyss/files/abyss-1.9.0-ac_prog_ar.patch
new file mode 100644
index 000000000..158e9b126
--- /dev/null
+++ b/sci-biology/abyss/files/abyss-1.9.0-ac_prog_ar.patch
@@ -0,0 +1,18 @@
+ configure.ac | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 9d4bb66..aa94364 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -12,6 +12,10 @@ AC_PROG_CPP
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
++AN_MAKEVAR([AR], [AC_PROG_AR])
++AN_PROGRAM([ar], [AC_PROG_AR])
++AC_DEFUN([AC_PROG_AR], [AC_CHECK_TOOL(AR, ar, :)])
++AC_PROG_AR
+ AC_CHECK_TOOL(GHC, ghc)
+ AM_CONDITIONAL([HAVE_GHC], [test "$GHC"])
+
diff --git a/sci-biology/abyss/metadata.xml b/sci-biology/abyss/metadata.xml
new file mode 100644
index 000000000..c0c84f0ed
--- /dev/null
+++ b/sci-biology/abyss/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name='misc-haskell'>build abyss-samtobreak tool, pull in haskell toolchain</flag>
+ </use>
+</pkgmetadata>