aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-09-23 08:44:44 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-09-23 08:44:44 +0200
commit78cbe3b4245289371362ac9bb909e491ad27ca75 (patch)
treeabf4a6b8368294f3becae5203dcf100062ba79f5
parentdev-python/line_profiler: Replace symlink (diff)
downloadsci-78cbe3b4245289371362ac9bb909e491ad27ca75.tar.gz
sci-78cbe3b4245289371362ac9bb909e491ad27ca75.tar.bz2
sci-78cbe3b4245289371362ac9bb909e491ad27ca75.zip
dev-python/testpath: Replace symlink
-rw-r--r--[l---------]dev-python/testpath/testpath-0.2.ebuild55
-rw-r--r--dev-python/testpath/testpath-9999.ebuild13
2 files changed, 57 insertions, 11 deletions
diff --git a/dev-python/testpath/testpath-0.2.ebuild b/dev-python/testpath/testpath-0.2.ebuild
index 07bd68e33..df61d9545 120000..100644
--- a/dev-python/testpath/testpath-0.2.ebuild
+++ b/dev-python/testpath/testpath-0.2.ebuild
@@ -1 +1,54 @@
-testpath-9999.ebuild \ No newline at end of file
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="
+ test? (
+ dev-python/pathlib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+PATCHES=(
+ "${FILESDIR}/${P}"-setup.py.patch
+ )
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+ fi
+
+distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+ }
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
+ py.test || die
+}
diff --git a/dev-python/testpath/testpath-9999.ebuild b/dev-python/testpath/testpath-9999.ebuild
index 395bfd701..61ceb0cd4 100644
--- a/dev-python/testpath/testpath-9999.ebuild
+++ b/dev-python/testpath/testpath-9999.ebuild
@@ -5,18 +5,11 @@
EAPI=5
PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
-inherit distutils-r1
+inherit distutils-r1 git-r3
DESCRIPTION="Test utilities for code working with files and commands"
HOMEPAGE="http://jupyter.org"
-
-if [ ${PV} == "9999" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/jupyter/${PN}.git git://github.com/jupyter/${PN}.git"
-else
- SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
+EGIT_REPO_URI="https://github.com/jupyter/${PN}.git git://github.com/jupyter/${PN}.git"
LICENSE="BSD"
SLOT="0"
@@ -31,7 +24,7 @@ DEPEND="
"
PATCHES=(
- "${FILESDIR}/${P}"-setup.py.patch
+ "${FILESDIR}/${PN}"-0.2-setup.py.patch
)
python_prepare_all() {