aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2016-06-12 22:56:32 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2016-06-12 22:56:32 +0300
commit7a55cd204b410bd7cb0784a03377655e2901b672 (patch)
tree7841faf9fe92144a5d1a0bc530321f6a6e92bc55
parentsys-cluster/lustre: Fix case when patches are empty (diff)
downloadsci-7a55cd204b410bd7cb0784a03377655e2901b672.tar.gz
sci-7a55cd204b410bd7cb0784a03377655e2901b672.tar.bz2
sci-7a55cd204b410bd7cb0784a03377655e2901b672.zip
sys-cluster/lustre: More fixes
Package-Manager: portage-2.3.0_rc1
-rw-r--r--sys-cluster/lustre/lustre-2.8.0.ebuild10
-rw-r--r--sys-cluster/lustre/lustre-9999.ebuild10
2 files changed, 4 insertions, 16 deletions
diff --git a/sys-cluster/lustre/lustre-2.8.0.ebuild b/sys-cluster/lustre/lustre-2.8.0.ebuild
index fccf13a1a..3f1bc606d 100644
--- a/sys-cluster/lustre/lustre-2.8.0.ebuild
+++ b/sys-cluster/lustre/lustre-2.8.0.ebuild
@@ -50,9 +50,10 @@ pkg_setup() {
}
src_prepare() {
- if [ -z ${PATCHES[@]} ]; then
+ if [ ! -z ${PATCHES[@]} ]; then
epatch ${PATCHES[@]}
fi
+ eapply_user
# replace upstream autogen.sh by our src_prepare()
local DIRS="libcfs lnet lustre snmp"
local ACLOCAL_FLAGS
@@ -64,13 +65,6 @@ src_prepare() {
eautoheader
eautomake
eautoconf
- # now walk in configure dirs
- einfo "Reconfiguring source in libsysio"
- cd libsysio
- eaclocal
- eautomake
- eautoconf
- cd ..
}
src_configure() {
diff --git a/sys-cluster/lustre/lustre-9999.ebuild b/sys-cluster/lustre/lustre-9999.ebuild
index fccf13a1a..3f1bc606d 100644
--- a/sys-cluster/lustre/lustre-9999.ebuild
+++ b/sys-cluster/lustre/lustre-9999.ebuild
@@ -50,9 +50,10 @@ pkg_setup() {
}
src_prepare() {
- if [ -z ${PATCHES[@]} ]; then
+ if [ ! -z ${PATCHES[@]} ]; then
epatch ${PATCHES[@]}
fi
+ eapply_user
# replace upstream autogen.sh by our src_prepare()
local DIRS="libcfs lnet lustre snmp"
local ACLOCAL_FLAGS
@@ -64,13 +65,6 @@ src_prepare() {
eautoheader
eautomake
eautoconf
- # now walk in configure dirs
- einfo "Reconfiguring source in libsysio"
- cd libsysio
- eaclocal
- eautomake
- eautoconf
- cd ..
}
src_configure() {