aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-06-26 06:00:26 +0100
committerSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-06-26 06:00:26 +0100
commit809803fe6391f32629a7fd3e528924b7ee3a6fb9 (patch)
tree56f63986d48d72e9b2f271863c8388dccf13642f
parentInitial import of aplpy (diff)
downloadsci-809803fe6391f32629a7fd3e528924b7ee3a6fb9.tar.gz
sci-809803fe6391f32629a7fd3e528924b7ee3a6fb9.tar.bz2
sci-809803fe6391f32629a7fd3e528924b7ee3a6fb9.zip
Initial import pywcs
-rw-r--r--dev-python/pywcs/ChangeLog10
-rw-r--r--dev-python/pywcs/Manifest2
-rw-r--r--dev-python/pywcs/metadata.xml10
-rw-r--r--dev-python/pywcs/pywcs-1.4.2.ebuild30
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pywcs/ChangeLog b/dev-python/pywcs/ChangeLog
new file mode 100644
index 000000000..e3db6e890
--- /dev/null
+++ b/dev-python/pywcs/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pywcs
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pywcs-1.4.2 (26 Jun 2009)
+
+ 26 Jun 2009; Sébastien Fabbro <bicatali@gentoo.org> +pywcs-1.4.2.ebuild,
+ +metadata.xml:
+ Initial import
+
diff --git a/dev-python/pywcs/Manifest b/dev-python/pywcs/Manifest
new file mode 100644
index 000000000..56df2a3d7
--- /dev/null
+++ b/dev-python/pywcs/Manifest
@@ -0,0 +1,2 @@
+DIST pywcs-1.4.2-4.3.tar.gz 711321 RMD160 cde3fbbe0fac276787283ae6767388c5d0371f13 SHA1 c7e8f4c5aac1d52ad744adbaaefc4b40cfe2dd43 SHA256 1a7dc7e5957aa07f374bf9936503e67414a915bd896d7f866a9d43bc22aaa74c
+EBUILD pywcs-1.4.2.ebuild 652 RMD160 2ecaace835d0a0a1095e355b63050a5aac01bdd6 SHA1 bb913626a00a64293ea82ac66facab3469149e73 SHA256 45ee26160b5c3a161d87dccf2f8c7d45e284946366c3f520bb7aa16f0f61e6f7
diff --git a/dev-python/pywcs/metadata.xml b/dev-python/pywcs/metadata.xml
new file mode 100644
index 000000000..03c443f53
--- /dev/null
+++ b/dev-python/pywcs/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ pywcs is a set of routines for handling the FITS World Coordinate
+ System (WCS) standard. It is a thin wrapper around the high- and
+ mid-level interfaces for wcslib.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pywcs/pywcs-1.4.2.ebuild b/dev-python/pywcs/pywcs-1.4.2.ebuild
new file mode 100644
index 000000000..01b04e7ba
--- /dev/null
+++ b/dev-python/pywcs/pywcs-1.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+NEED_PYTHON=2.4
+inherit distutils
+
+WCS_V=4.3
+MYP="${P}-${WCS_V}"
+
+DESCRIPTION="Python routines for handling the FITS World Coordinate System"
+HOMEPAGE="https://www.stsci.edu/trac/ssb/astrolib/"
+SRC_URI="http://stsdas.stsci.edu/astrolib/${MYP}.tar.gz"
+
+DEPEND="dev-python/pyfits"
+# FIX: wcslib is shipped
+RDEPEND="${DEPEND}"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="AURA"
+
+S="${WORKDIR}/${MYP}"
+
+src_test() {
+ # FIX: does not work, needs fits files
+ PYTHONPATH=$(dir -d build/lib*) "${python}" test/test.py || die
+}