aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tom111@gmx.de>2009-08-19 23:31:29 +0200
committerThomas Kahle <tom111@gmx.de>2009-08-19 23:32:05 +0200
commit82ad4681615bac6cce1813829d14b0d446233556 (patch)
tree89d1ae845811c856254bd2184f89c0ad70833d2f
parentremoved hdf5 now in main tree (diff)
downloadsci-82ad4681615bac6cce1813829d14b0d446233556.tar.gz
sci-82ad4681615bac6cce1813829d14b0d446233556.tar.bz2
sci-82ad4681615bac6cce1813829d14b0d446233556.zip
Rewritten version of sci-mathematics/Macaulay2 to fix QA issues.
-rw-r--r--sci-mathematics/Macaulay2/ChangeLog4
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-1.2-r3.ebuild119
-rw-r--r--sci-mathematics/Macaulay2/Manifest3
3 files changed, 125 insertions, 1 deletions
diff --git a/sci-mathematics/Macaulay2/ChangeLog b/sci-mathematics/Macaulay2/ChangeLog
index a8dea06ef..db98603ec 100644
--- a/sci-mathematics/Macaulay2/ChangeLog
+++ b/sci-mathematics/Macaulay2/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 19 Aug 2009; Thomas Kahle <tom111@gmx.de> +Macaulay2-1.2-r3.ebuild
+
+ Rewritten ebuild for QA
+
06 May 2009; Thomas Kahle <tom111@gmx.de> -Macaulay2-1.2.ebuild
-Macaulay2-1.2-r1.ebuild +Macaulay2-1.2-r2.ebuild
diff --git a/sci-mathematics/Macaulay2/Macaulay2-1.2-r3.ebuild b/sci-mathematics/Macaulay2/Macaulay2-1.2-r3.ebuild
new file mode 100644
index 000000000..0c30ac977
--- /dev/null
+++ b/sci-mathematics/Macaulay2/Macaulay2-1.2-r3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools elisp-common eutils flag-o-matic
+
+IUSE="emacs"
+
+DESCRIPTION="research tool for commutative algebra and algebraic geometry"
+SRC_URI=" http://www.math.uiuc.edu/Macaulay2/Downloads/SourceCode/${P}-r8438-src.tar.bz2
+ ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Factory/factory-3-1-0.tar.gz \
+ ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Libfac/libfac-3-1-0.tar.gz \
+ http://www.math.uiuc.edu/Macaulay2/Extra/frobby_vmike3.tar.gz"
+# mirror://gentoo/${P}-src.tar.bz2
+
+# We should keep frobby, factory and libfac in sync!
+
+HOMEPAGE="http://www.math.uiuc.edu/Macaulay2/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+# The ntl version is a due to factory
+# If <boehm-gc-7.0 is installed M2 download and install it internally
+# sys-process/time is needed to run the checks
+DEPEND="sys-libs/gdbm
+ dev-libs/gmp
+ >=dev-libs/ntl-5.4.1[gmp]
+ >=dev-libs/boehm-gc-7.0
+ >=sci-mathematics/pari-2.3.4[gmp]
+ virtual/blas
+ virtual/lapack
+ dev-util/ctags
+ sys-libs/ncurses
+ sys-process/time
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+SITEFILE=70Macaulay2-gentoo.el
+
+S="${WORKDIR}/${P}-r8438"
+
+src_unpack() {
+ unpack "${P}-r8438-src.tar.bz2"
+ mkdir "${S}/BUILD/tarfiles"
+ # Put sourcfile in the right location:
+ cp "${DISTDIR}/frobby_vmike3.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+ cp "${DISTDIR}/factory-3-1-0.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+ cp "${DISTDIR}/libfac-3-1-0.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+}
+
+src_prepare () {
+ # Fixes an issue with Doc. Probably gone in 1.3
+ cd "${S}/Macaulay2/packages/Macaulay2Doc"
+ sed "/^ *SourceCode => applicationDirectory.*$/d" -i doc13.m2
+
+ # This might help if ntl is built with gf2x support
+ # Currently we run into --as-needed problems then.
+ cd "${S}"
+ sed 's/"-lntl"/"-lntl" "-lgf2x -lntl"/' -i "${S}/configure.ac"
+
+ eautoreconf
+}
+
+src_configure (){
+
+ # Recommended in bug #268064 Possibly unecessary since
+ # its a local problem of original reporter.
+
+ if ! use emacs; then
+ tags="ctags"
+ fi
+
+ # --as-needed should be possible:
+ append-ldflags "-L${WORKDIR}/$(get_libdir) -Wl,--no-as-needed"
+ CPPFLAGS="-I/usr/include/gc -I${WORKDIR}/include" \
+ ./configure --prefix="${D}/usr" --disable-encap \
+ || die "failed to configure Macaulay"
+}
+
+src_compile() {
+ # Parallel build ?
+ emake -j1 || die "failed to build Macaulay"
+}
+
+src_test() {
+ make check || die "tests failed"
+}
+
+src_install () {
+
+ make install || die "install failed"
+
+ # nothing useful in here, get rid of it
+ # NOTE: Macaulay installs into lib even on amd64 hence don't
+ # replace lib with $(get_libdir) below!
+ rm -fr "${D}"/usr/lib \
+ || die "failed to remove empty /usr/lib"
+
+ use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "If you want to set a hot key for Macaulay2 in Emacs add a line similar to"
+ elog "(global-set-key [ f12 ] 'M2)"
+ elog "in order to set it to F12 (or choose a different one)."
+ fi
+}
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/Macaulay2/Manifest b/sci-mathematics/Macaulay2/Manifest
index 5de3cdfbd..7bd983854 100644
--- a/sci-mathematics/Macaulay2/Manifest
+++ b/sci-mathematics/Macaulay2/Manifest
@@ -5,5 +5,6 @@ DIST factory-3-1-0.tar.gz 565374 RMD160 059ed1697f282d309e89d1cc2e0ce8bd94a8b4b3
DIST frobby_vmike3.tar.gz 235794 RMD160 d9bf705895f4ccb8a1db9fd3909d4ae53fb05b08 SHA1 e478c0d0ac66f4d315ab246a1b2e0cb563991367 SHA256 98c58c0bb99f81344d1a647840f32e062923f2a45bf4cbafbf03ad1160e0a673
DIST libfac-3-1-0.tar.gz 91544 RMD160 2500d402328ad532756c677015c1d01f8594e394 SHA1 d005ddd58a180b8a91fe5728b96bde515c5d9cc5 SHA256 fc3dda08f7ec039635f8d7f1629546f4ac7620a69cf9332ca39e29dd822aee7d
EBUILD Macaulay2-1.2-r2.ebuild 3140 RMD160 4228497ba8c22038b496744c494c6ab0c808d90b SHA1 33ef56c4cbfe449e119d5b7fb1a2801421c5f30a SHA256 bfb59f0a752f4dd90ed87ade901010dc26d2fa6b5c70872638f898399072bb5c
-MISC ChangeLog 582 RMD160 729915412ed83e2f1370884c27c0793d8d89b6f8 SHA1 36915300ffdb1fab2aa4ec5307712d79c144289b SHA256 a974054d4c9598d11d6b86dcc5c5c21b0cad9d4312c9474dd43bf2bdc3222c68
+EBUILD Macaulay2-1.2-r3.ebuild 3162 RMD160 ae79cc28703ad478d35f9a51b73fc0b845eb9ed2 SHA1 7331a7098c331fd1d8cecc27745ec112c00d30dc SHA256 fbd46bf3ae1c222e0cdf7b421f0116c84aaba49cf776fa722eca84b21ece3e5c
+MISC ChangeLog 679 RMD160 0f1fd2adf96dd03a784a5ed047e0e753c324f6db SHA1 bf45ce8e662b2ec7126710180aac5076638dd97c SHA256 7f289dbf1457658b89650a115ecaa458d953d2c45946bd0c098419fcf3e4b652
MISC metadata.xml 361 RMD160 273db3a009b85938f85e60ea0d34d6fc625f9477 SHA1 7f6e903d81af55b08c7dbb9feb4f7ad39852a23e SHA256 71a0f19b08b1e752e754bbc5faf15880601d00c5b9df2bc5ca5a3b8e93e83b7f