aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-04 13:03:47 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-04 13:03:47 +0100
commit82e6bf6bd0f7df08909b1f1bb5031907b13428cc (patch)
treed0a60fb63157f07d4fa44e8bbdca2ea079ac6d96
parentsci-mathematics/why3: drop old (diff)
downloadsci-82e6bf6bd0f7df08909b1f1bb5031907b13428cc.tar.gz
sci-82e6bf6bd0f7df08909b1f1bb5031907b13428cc.tar.bz2
sci-82e6bf6bd0f7df08909b1f1bb5031907b13428cc.zip
sci-mathematics/gappa: version bump 1.3.5, EAPI bump
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-mathematics/gappa/Manifest1
-rw-r--r--sci-mathematics/gappa/gappa-1.3.5.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sci-mathematics/gappa/Manifest b/sci-mathematics/gappa/Manifest
index 416caf81e..81e77afa9 100644
--- a/sci-mathematics/gappa/Manifest
+++ b/sci-mathematics/gappa/Manifest
@@ -1 +1,2 @@
DIST gappa-1.1.1.tar.gz 399606 BLAKE2B 761439b96885434f42f57c253313b4cf8130bff6cc313a62480984d31bc3688c690da6ec688dcb97cb9f2d62533bccaa646d4df67222d8237cf06bdc314ba321 SHA512 95b01733554585729d73078522720f0c318f6e86eec02b869717e591bd1477a663c8f71d6c9362f8d5ec83d0a856be5771a27add426d8ac0eca429c4ded01a0e
+DIST gappa-1.3.5.tar.gz 412527 BLAKE2B cf3dc69e9ef538cda7eee42c81dfa5cdfb765967745f68dabd5937cb00ea075f6c6b1614afefe10e7dfe69377ec5ba7f5fed5e4d45b45efd4362090a0bb136cb SHA512 60b5719e3a321df43e33045fa8f4511fc02a4218d1ae7e476e7c6ebcf90ae208832881f6eea5b99a3296dfcc3a18c7e1f4ea9dbea446fc502e14306b6975f6e6
diff --git a/sci-mathematics/gappa/gappa-1.3.5.ebuild b/sci-mathematics/gappa/gappa-1.3.5.ebuild
new file mode 100644
index 000000000..26461a439
--- /dev/null
+++ b/sci-mathematics/gappa/gappa-1.3.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Verifying and proving properties on floating-point or fixed-point arithmetic"
+HOMEPAGE="http://gappa.gforge.inria.fr/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/38044/${P}.tar.gz"
+
+LICENSE="|| ( CeCILL-2 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ dev-libs/boost
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+ sed -i Remakefile.in \
+ -e "s:mkdir -p @bindir@:mkdir -p \${DESTDIR}@bindir@:g" \
+ -e "s:cp src/gappa @bindir@:cp src/gappa \${DESTDIR}@bindir@:g"
+}
+
+src_compile() {
+ ./remake -d ${MAKEOPTS} || die "emake failed"
+ if use doc; then
+ ./remake doc/html/index.html
+ fi
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install
+ einstalldocs
+ use doc && dodoc -r doc/html/*
+}