aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2013-02-24 17:20:19 -0800
committerSébastien Fabbro <bicatali@gentoo.org>2013-02-24 17:20:19 -0800
commit8337995fc5902ea8741689831d77d27030be083a (patch)
tree879e30cf40b591e4afa7f5e85c6c83d661bc0f8b
parentMerge branch 'master' of git://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-8337995fc5902ea8741689831d77d27030be083a.tar.gz
sci-8337995fc5902ea8741689831d77d27030be083a.tar.bz2
sci-8337995fc5902ea8741689831d77d27030be083a.zip
sci-libs/atlas: Switched threads libraries to Libs.private in pkg-config files
Package-Manager: portage-2.2.01.21688-prefix
-rw-r--r--sci-libs/atlas/ChangeLog3
-rw-r--r--sci-libs/atlas/atlas-3.10.1-r1.ebuild10
2 files changed, 8 insertions, 5 deletions
diff --git a/sci-libs/atlas/ChangeLog b/sci-libs/atlas/ChangeLog
index 2f32db053..c010571b7 100644
--- a/sci-libs/atlas/ChangeLog
+++ b/sci-libs/atlas/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 25 Feb 2013; Sébastien Fabbro <bicatali@gentoo.org> atlas-3.10.1-r1.ebuild:
+ sci-libs/atlas: Switched threads libraries to Libs.private in pkg-config files
+
*atlas-3.10.1-r1 (20 Feb 2013)
20 Feb 2013; Sébastien Fabbro <bicatali@gentoo.org> +atlas-3.10.1-r1.ebuild:
diff --git a/sci-libs/atlas/atlas-3.10.1-r1.ebuild b/sci-libs/atlas/atlas-3.10.1-r1.ebuild
index b84a60b1e..52d3f3ff1 100644
--- a/sci-libs/atlas/atlas-3.10.1-r1.ebuild
+++ b/sci-libs/atlas/atlas-3.10.1-r1.ebuild
@@ -180,7 +180,7 @@ atlas_install_pc() {
Version: ${PV}
URL: ${HOMEPAGE}
Libs: -L\${libdir} -l${libname} $@
- Libs.private: -L\${libdir} -latlas -lm
+ Libs.private: -L\${libdir} -latlas -lm ${PTLIBS}
Cflags: -I\${includedir}/${PN}
${PCREQ}
EOF
@@ -214,7 +214,7 @@ src_install() {
# cblas threaded
if [[ -e libptcblas.a ]]; then
atlas_install_libs libptcblas.a -lm -L. -latlas ${PTLIBS}
- atlas_install_pc ptcblas atlas-cblas-threads ${PTLIBS}
+ atlas_install_pc ptcblas atlas-cblas-threads
alternatives_for cblas atlas-threads 0 \
/usr/$(get_libdir)/pkgconfig/cblas.pc atlas-cblas-threads.pc \
/usr/include/cblas.h atlas/cblas.h
@@ -229,7 +229,7 @@ src_install() {
# clapack threaded
if [[ -e libptclapack.a ]]; then
atlas_install_libs libptclapack.a -lm -L. -latlas -lptcblas ${PTLIBS}
- atlas_install_pc ptclapack atlas-clapack-threads ${PTLIBS}
+ atlas_install_pc ptclapack atlas-clapack-threads
fi
fi
@@ -245,7 +245,7 @@ src_install() {
# blas threaded
if [[ -e libptf77blas.a ]]; then
atlas_install_libs libptf77blas.a -lm -L. -latlas ${PTLIBS}
- atlas_install_pc ptf77blas atlas-blas-threads ${PTLIBS}
+ atlas_install_pc ptf77blas atlas-blas-threads
alternatives_for blas atlas-threads 0 \
/usr/$(get_libdir)/pkgconfig/blas.pc atlas-blas-threads.pc
fi
@@ -262,7 +262,7 @@ src_install() {
if [[ -e libptlapack.a ]]; then
atlas_install_libs libptlapack.a \
-lm -L. -latlas -lptcblas -lptf77blas ${PTLIBS}
- atlas_install_pc ptlapack atlas-lapack-threads ${PTLIBS}
+ atlas_install_pc ptlapack atlas-lapack-threads
alternatives_for lapack atlas-threads 0 \
/usr/$(get_libdir)/pkgconfig/lapack.pc atlas-lapack-threads.pc
fi