aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-06 17:00:49 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-06 17:00:49 +0100
commit895437263b1776a28bc8cac3b2cc03b08759f028 (patch)
tree0cf4051a9a587933dd4c4d40334b2e4ffbfa94f8
parentpackage.mask: mask trowel for removal (diff)
downloadsci-895437263b1776a28bc8cac3b2cc03b08759f028.tar.gz
sci-895437263b1776a28bc8cac3b2cc03b08759f028.tar.bz2
sci-895437263b1776a28bc8cac3b2cc03b08759f028.zip
sci-biology/vcflib: EAPI bump, version bump
still missing dep tabixpp so no keywords yet Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-biology/vcflib/Manifest1
-rw-r--r--sci-biology/vcflib/vcflib-1.0.2.ebuild (renamed from sci-biology/vcflib/vcflib-9999.ebuild)39
2 files changed, 23 insertions, 17 deletions
diff --git a/sci-biology/vcflib/Manifest b/sci-biology/vcflib/Manifest
new file mode 100644
index 000000000..57b3d1f2b
--- /dev/null
+++ b/sci-biology/vcflib/Manifest
@@ -0,0 +1 @@
+DIST vcflib-1.0.2-src.tar.gz 20881031 BLAKE2B 67e8fd60db3171fa05cac36306852134cc8c37a3e4715d141547773c3252569a01363298297978d89c015b1120ad0f0d05eb2b67b5ee7d01728f27f0049bc748 SHA512 7dadd2398d4054a1d7e7b520f192243f63c98a4fa184f7c6750dce9296356f4b45bdbb50f7de270a6c4c3aa76deec45980c363e19b22bea64590de711fdb7d71
diff --git a/sci-biology/vcflib/vcflib-9999.ebuild b/sci-biology/vcflib/vcflib-1.0.2.ebuild
index 91a14eca3..e8da0c6ab 100644
--- a/sci-biology/vcflib/vcflib-9999.ebuild
+++ b/sci-biology/vcflib/vcflib-1.0.2.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit git-r3 toolchain-funcs
+inherit cmake toolchain-funcs
DESCRIPTION="VCF/BED utils, Genotype Phenotype Association Toolkit (GPAT++)"
HOMEPAGE="https://github.com/vcflib/vcflib"
-EGIT_REPO_URI="https://github.com/vcflib/vcflib.git"
+SRC_URI="https://github.com/vcflib/vcflib/releases/download/v${PV}/${P}-src.tar.gz"
# vcflib is incorporated into several projects, such as freebayes
@@ -16,13 +16,18 @@ SLOT="0"
KEYWORDS=""
IUSE="openmp"
-DEPEND=""
+DEPEND="
+ sys-libs/zlib
+ sci-libs/htslib
+"
RDEPEND="${DEPEND}"
# contains bundled sci-biology/htslib ?
# see also ./include for possible traces of other bundled sw
+S="${WORKDIR}/${PN}"
+
src_prepare(){
- default
+ cmake_src_prepare
sed -e "s/^CXX = g++/CXX = $(tc-getCXX)/" -i Makefile || die
sed -e "s/^CXXFLAGS = -O3/CXXFLAGS = ${CXXFLAGS}/" -i Makefile || die
# openmp detection stolen from velvet-1.2.10.ebuild
@@ -39,15 +44,15 @@ src_prepare(){
}
src_compile(){
- if use openmp ; then
- emake openmp
- else
- emake
- fi
-}
-
-src_install(){
- dobin bin/*
- dolib lib/* # install libvcflib.a
- dodoc README.md
+ mycmakeargs=(
+ -DOPENMP="$(use_enable openmp)"
+ -DHTSLIB_LOCAL=NO
+ )
+ cmake_src_compile
}
+#
+# src_install(){
+# dobin bin/*
+# dolib lib/* # install libvcflib.a
+# dodoc README.md
+# }