aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-08-15 11:25:57 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-08-15 11:25:57 +0200
commit8caa2bbcc6b9e0360bec9177f3c373e041b78081 (patch)
tree9bf626c1966b5713b2d7c574f28d7427c8401afe
parentccp4 USE db renamed to balbesdb as suggested by Donnie and Afrever (diff)
downloadsci-8caa2bbcc6b9e0360bec9177f3c373e041b78081.tar.gz
sci-8caa2bbcc6b9e0360bec9177f3c373e041b78081.tar.bz2
sci-8caa2bbcc6b9e0360bec9177f3c373e041b78081.zip
sci-chemistry/imosflm rewritten compile phase
-rw-r--r--sci-chemistry/imosflm/ChangeLog4
-rw-r--r--sci-chemistry/imosflm/Manifest4
-rw-r--r--sci-chemistry/imosflm/imosflm-1.0.3.ebuild18
3 files changed, 17 insertions, 9 deletions
diff --git a/sci-chemistry/imosflm/ChangeLog b/sci-chemistry/imosflm/ChangeLog
index 9bd1d2599..7e7cddc31 100644
--- a/sci-chemistry/imosflm/ChangeLog
+++ b/sci-chemistry/imosflm/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 15 Aug 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ imosflm-1.0.3.ebuild:
+ rewritten compile phase
+
*imosflm-1.0.3 (14 Aug 2009)
14 Aug 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
diff --git a/sci-chemistry/imosflm/Manifest b/sci-chemistry/imosflm/Manifest
index e37c962f0..1472c2fc1 100644
--- a/sci-chemistry/imosflm/Manifest
+++ b/sci-chemistry/imosflm/Manifest
@@ -2,6 +2,6 @@ AUX 1.0.3-tk.patch 1797 RMD160 232a7191c914754a4f863af90f5d557f305245b8 SHA1 e67
DIST imosflm-1.0.0.tar.gz 1061762 RMD160 5e943c1f9dc48aad55eb6f7bb7f6dd7b09088509 SHA1 6ed3c6d7f05fcfcc0e254ced66133fc19b34394e SHA256 142eeb1771c477fb5ec121edd36f6acc95791fcb402d5233c315b1bf141a4dd4
DIST imosflm-1.0.3.zip 977024 RMD160 6ea9d2c38c778b8ef4cc939a2eedce553c0471d5 SHA1 9b9d19a171d26680d116729a5f2b0b5644848b21 SHA256 a1e8fa4f7c5b199a0c72d3431f71cc4f54dc26bb775ae7b7c9199e82df422c12
EBUILD imosflm-1.0.0.ebuild 995 RMD160 e895028c1bfc9c1e62b1e9e1fb23e2d474406720 SHA1 74dbe516a17667285365b579115f0ad362744e86 SHA256 5320759b2cb3b273ce2b3105476e8f97ea4cdf432e41ff4ea734770d834ce4f1
-EBUILD imosflm-1.0.3.ebuild 1686 RMD160 a053ea2f285ce0539b8ba40660da943e1b78a150 SHA1 15e870ede63a873f53d072353d662219b2b5c777 SHA256 306a6b080a1138e3ac027624dba3ecd101701b48ec645e69ae6fb66cb81f2014
-MISC ChangeLog 649 RMD160 7664aeca674cd8ff3b0b56f64956331fa46f8d8a SHA1 beefe12237a789cc72b6b74be2090ebd162313a9 SHA256 7a52c509deabe1d0e068242e1ad77b936cb6690e9b6d8fa95b11bfa65cd5b661
+EBUILD imosflm-1.0.3.ebuild 1516 RMD160 2d801e5d861f08eab6d78af69e0c4e306a28b22a SHA1 2862aadcff0c74c2c24357c5591783bcf818fe0e SHA256 321759ed402e87cd07a79e5c2e61d231446eb11e640faef50824aa602ec276b3
+MISC ChangeLog 757 RMD160 0bd325ee6aadebc2eccea0d93c00780f13fd2e39 SHA1 e7d4a803cccc8f1935b4de2084f44910d3115992 SHA256 8092d844bb58039164696f008b2f33bd3f9eab9c99ed38f1a51992e435cdfc6a
MISC metadata.xml 215 RMD160 bc9c07aa91f2f175542244e4e4522a73558210a1 SHA1 facb283386de1c0b6b938cdcd4dde04d1694298b SHA256 13f32353652adbd3d934d41381cfc2cacc9e1127c508cebc73806cc1026ee80c
diff --git a/sci-chemistry/imosflm/imosflm-1.0.3.ebuild b/sci-chemistry/imosflm/imosflm-1.0.3.ebuild
index 0c87c6aa8..a92def129 100644
--- a/sci-chemistry/imosflm/imosflm-1.0.3.ebuild
+++ b/sci-chemistry/imosflm/imosflm-1.0.3.ebuild
@@ -37,18 +37,22 @@ PATCHES=(
src_compile() {
cd c
- einfo "$(tc-getCC) ${CFLAGS} -DUSE_TCL_STUBS -DTK_USE_STUBS tkImageLoadDLL.c -o -c tkImageLoad.c"
- $(tc-getCC) -c ${CFLAGS} -fPIC -DUSE_TCL_STUBS -DTK_USE_STUBS tkImageLoad.c -o tkImageLoad.o || die
+ objs="tkImageLoadDLL.o tkImageLoad.o"
+ libs="-ltclstub -ltkstub"
+ config="-fPIC -DUSE_TCL_STUBS -DTK_USE_STUBS"
+ ldextra="-shared"
- einfo "$(tc-getCC) -c ${CFLAGS} -DUSE_TCL_STUBS -DTK_USE_STUBS tkImageLoadDLL.c -o tkImageLoadDLL.o"
- $(tc-getCC) -c ${CFLAGS} -fPIC -DUSE_TCL_STUBS -DTK_USE_STUBS tkImageLoadDLL.c -o tkImageLoadDLL.o || die
+ for file in ${objs}; do
+ einfo "$(tc-getCC) -c ${CFLAGS} ${config} ${file/.o/.c} -o ${file}"
+ $(tc-getCC) -c ${CFLAGS} ${config} ${file/.o/.c} -o ${file}
+ done
- einfo "$(tc-getCC) ${LDFLAGS} -o tkImageLoad.so tkImageLoad.o -ltclstub -ltkstub -ltk -ltcl"
- $(tc-getCC) ${LDFLAGS} -shared -o tkImageLoad.so tkImageLoad.o tkImageLoadDLL.o -ltclstub -ltkstub || die
+ einfo "$(tc-getCC) ${LDFLAGS} ${ldextra} ${objs} -o tkImageLoad.so ${libs}"
+ $(tc-getCC) ${LDFLAGS} ${ldextra} ${objs} -o tkImageLoad.so ${libs}
}
src_install(){
- rm -rvf lib/{*.so,anigif,combobox}
+ rm -rf lib/{*.so,anigif,combobox}
insinto /usr/$(get_libdir)/${PN}
doins -r "${S}"/{src,bitmaps,lib}