aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2018-05-31 17:50:44 -0600
committerChristoph Junghans <junghans@gentoo.org>2018-05-31 17:50:44 -0600
commit8f3e47f7bc2a994b063581be0ce06745c591d801 (patch)
tree1cf2b815d20f3532b3a05b590997cfc116f40092
parentsci-libs/dealii: remove superfluous configuration options (diff)
downloadsci-8f3e47f7bc2a994b063581be0ce06745c591d801.tar.gz
sci-8f3e47f7bc2a994b063581be0ce06745c591d801.tar.bz2
sci-8f3e47f7bc2a994b063581be0ce06745c591d801.zip
sci-libs/lmfit: version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--sci-libs/lmfit/Manifest1
-rw-r--r--sci-libs/lmfit/lmfit-6.4.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/sci-libs/lmfit/Manifest b/sci-libs/lmfit/Manifest
index d8736b8c4..632a6fe61 100644
--- a/sci-libs/lmfit/Manifest
+++ b/sci-libs/lmfit/Manifest
@@ -1 +1,2 @@
DIST lmfit-5.1.tgz 345077 SHA256 4e35bdec551a4985cf6d96f26a808b56c171433edf4a413c2ed50ab3d85a3965 SHA512 1df6ed51d7f2137529793948f6c57ef3658932c9198776925a9f6e1d586352651c93aa053a064db7a201dbb848a7108f284223feff45171d142087539d834b29 WHIRLPOOL 275ccd5b20cafc1df28c87e4ee2afc58561dde03c670e6dc03eda95043a8eb7edd765962840ad5e9cac332ea5ba5045aca4a6e3d192e8dd8bdbcfd45a7bd4d9f
+DIST lmfit-6.4.tgz 388809 BLAKE2B 48aa619642ac3fd009ec6a8f8b44ee4c800fc3f33e2603b557218cdf37c789159dc3947a648d560b9e2dd7fef08a6644fd25ac61505859dc3b1d151eeea58c27 SHA512 2bd0f24dd4638345b8b1ce6803ddcf45ca3ef888eb285e99f9f158c2e30b0f96016d9d84a112cdbf28f2ba98470e54fe773416179a65264426043c9a5186757d
diff --git a/sci-libs/lmfit/lmfit-6.4.ebuild b/sci-libs/lmfit/lmfit-6.4.ebuild
new file mode 100644
index 000000000..5cc8fa8bd
--- /dev/null
+++ b/sci-libs/lmfit/lmfit-6.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="library for Levenberg-Marquardt least-squares minimization and curve fitting"
+HOMEPAGE="http://apps.jcns.fz-juelich.de/doku/sc/lmfit"
+SRC_URI="http://apps.jcns.fz-juelich.de/src/lmfit/old/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}