aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin <jlec@j-schmitz.net>2013-01-26 10:48:27 -0800
committerJustin <jlec@j-schmitz.net>2013-01-26 10:48:27 -0800
commit8f7ab4c7ecdb53af9d472c518765c916cdb40411 (patch)
tree790cce66c641ef33d3ccbc4cf29969fa6ce00133
parentsync with gx86 (diff)
parentInherited gnome2-utils and called cache update from pkg_postrm as well (diff)
downloadsci-8f7ab4c7ecdb53af9d472c518765c916cdb40411.tar.gz
sci-8f7ab4c7ecdb53af9d472c518765c916cdb40411.tar.bz2
sci-8f7ab4c7ecdb53af9d472c518765c916cdb40411.zip
Merge pull request #43 from TheChymera/master
Run permissions for the packages GUI script
-rw-r--r--sci-biology/psychopy/psychopy-1.75.01.ebuild24
-rw-r--r--sci-biology/psychopy/psychopy-9999.ebuild41
2 files changed, 46 insertions, 19 deletions
diff --git a/sci-biology/psychopy/psychopy-1.75.01.ebuild b/sci-biology/psychopy/psychopy-1.75.01.ebuild
index 6b341f50b..9d6b51dee 100644
--- a/sci-biology/psychopy/psychopy-1.75.01.ebuild
+++ b/sci-biology/psychopy/psychopy-1.75.01.ebuild
@@ -2,14 +2,15 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
DISTUTILS_SRC_TEST="py.test"
-inherit distutils
+inherit distutils-r1 gnome2-utils eutils
MY_P="PsychoPy-${PV}"
@@ -24,11 +25,11 @@ IUSE="test"
RDEPEND="dev-python/numpy[lapack]
sci-libs/scipy
dev-python/matplotlib
- dev-python/pyopengl
+ dev-python/pyopengl[${PYTHON_USEDEP}]
dev-python/imaging
dev-python/wxpython
- dev-python/setuptools
- dev-python/lxml
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
app-admin/eselect
dev-python/pyglet
dev-python/pygame"
@@ -40,3 +41,16 @@ DEPEND="app-arch/unzip
RESTRICT="test" # interactive, opens lots of windows
S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doicon psychopy/monitors/psychopy.ico
+ make_desktop_entry psychopyapp.py PsychoPy psychopy "Science;Biology"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/sci-biology/psychopy/psychopy-9999.ebuild b/sci-biology/psychopy/psychopy-9999.ebuild
index 9165bb54f..88b339356 100644
--- a/sci-biology/psychopy/psychopy-9999.ebuild
+++ b/sci-biology/psychopy/psychopy-9999.ebuild
@@ -1,29 +1,42 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
-inherit eutils distutils git-2
+inherit eutils gnome2-eutils distutils-r1 git-2
DESCRIPTION="Python experiemntal psychology toolkit"
HOMEPAGE="http://www.psychopy.org/"
-EGIT_REPO_URI="https://github.com/psychopy/psychopy"
+EGIT_REPO_URI="https://github.com/psychopy/psychopy.git"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="dev-python/numpy[lapack]
- sci-libs/scipy
- dev-python/matplotlib
- dev-python/pyopengl
- dev-python/imaging
- dev-python/wxpython
- dev-python/setuptools
- dev-python/lxml"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
app-admin/eselect
- dev-python/pyglet
+ dev-python/imaging
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/matplotlib
+ dev-python/numpy[lapack]
dev-python/pygame
- "
+ dev-python/pyglet
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/wxpython
+ sci-libs/scipy"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newicon -s scalable psychopy/monitors/psychopy-icon.svg psychopy.svg
+ make_desktop_entry psychopyApp.py PsychoPy psychopy "Science;Biology"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}