aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlammie Pirinen <flammie@gentoo.org>2011-05-09 19:39:54 +0300
committerFlammie Pirinen <flammie@gentoo.org>2011-05-09 19:39:54 +0300
commit9155f92d59b603acf3c3b3c03b65dc9327381f7e (patch)
tree9cef789a0d6082b010a9d1aa3d3c012a43cbe616
parentRemove old ebuilds since the sources have disappeared (diff)
downloadsci-9155f92d59b603acf3c3b3c03b65dc9327381f7e.tar.gz
sci-9155f92d59b603acf3c3b3c03b65dc9327381f7e.tar.bz2
sci-9155f92d59b603acf3c3b3c03b65dc9327381f7e.zip
Version bump
-rw-r--r--sci-misc/openfst/Manifest2
-rw-r--r--sci-misc/openfst/openfst-1.2.7.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/sci-misc/openfst/Manifest b/sci-misc/openfst/Manifest
index 5b6dc7c02..6874f56d5 100644
--- a/sci-misc/openfst/Manifest
+++ b/sci-misc/openfst/Manifest
@@ -1,3 +1,5 @@
MISC ChangeLog 739 RMD160 6be6fed5ff79ddee9a8872f4884da075300d29e7 SHA1 4a4c12d31bea9f11e6ebc80099b0a5a409bb49e5 SHA256 15b110959e4cf87ab976d40f7cf0060e1eaf65e1b420d88675c563838b40aafc
AUX openfst-20080422_beta-gcc-4.3.patch 2918 RMD160 0aeceeb049614182f2e83fa3a149ba5aa54cffaa SHA1 64bb951888f83a3ba9f780b4ec4dec46d9d20303 SHA256 8aab92d28f806074916d76245de4c46b15c9ac302a8417e4cb168aa8d755cb12
MISC metadata.xml 223 RMD160 754bf1189c9d51090f3e0439f6e7d6f603b93df0 SHA1 54348ca01c174e03ff3318b2a9da50d970db6695 SHA256 5c57a999484660ea4a3e55f9c526bb38097d5c1cb2356353133ec4d7e89f1f88
+EBUILD openfst-1.2.7.ebuild 715 RMD160 81f44c1e6407f9c04c7e744b577ac593d2096b47 SHA1 11c8797f15469653b7051b70f1c2b31b9c688fa5 SHA256 7487360f5df0d0705daa65d9cec6cd2f85da757094e7cbd064d697066be6b4e4
+DIST openfst-1.2.7.tar.gz 668134 RMD160 a24279f4deb85f79875b237c548f0b600c3a6af8 SHA1 75aa24fe050c295e16aaeb31a216c1d97952c84e SHA256 a38b10a7a1b6c054fb15035f3197f566ac6b23bc2acd5958052165ae7ce5c11c
diff --git a/sci-misc/openfst/openfst-1.2.7.ebuild b/sci-misc/openfst/openfst-1.2.7.ebuild
new file mode 100644
index 000000000..4ccb69f2c
--- /dev/null
+++ b/sci-misc/openfst/openfst-1.2.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils multilib flag-o-matic
+
+DESCRIPTION="Finite State Transducer tools by Google et al."
+HOMEPAGE="http://www.openfst.org"
+SRC_URI="http://www.openfst.org/twiki/pub/FST/FstDownload/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ filter-ldflags -Wl,--as-needed --as-needed
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS README || die "docs missing"
+}
+
+src_test() {
+ einfo "make test can take a few hours on moderately modern systems"
+ make test || die "check failed"
+}