aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-15 15:16:49 +0200
committerJustin Lecher <jlec@gentoo.org>2013-10-15 15:16:49 +0200
commit919ba8b8520e126335bea049ac88ab9d191d1e47 (patch)
tree20cf25e4c95b573e45d7c66bf7df548b92056282
parentsys-cluster/charm-6.5.1-r2: Updated static library patch with upstream patch. (diff)
downloadsci-919ba8b8520e126335bea049ac88ab9d191d1e47.tar.gz
sci-919ba8b8520e126335bea049ac88ab9d191d1e47.tar.bz2
sci-919ba8b8520e126335bea049ac88ab9d191d1e47.zip
sci-geosciences/qgis: Bump to python r1 eclasses
Package-Manager: portage-2.2.7
-rw-r--r--sci-geosciences/qgis/ChangeLog3
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild18
2 files changed, 13 insertions, 8 deletions
diff --git a/sci-geosciences/qgis/ChangeLog b/sci-geosciences/qgis/ChangeLog
index f0698c442..aaa266818 100644
--- a/sci-geosciences/qgis/ChangeLog
+++ b/sci-geosciences/qgis/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 15 Oct 2013; Justin Lecher <jlec@gentoo.org> qgis-9999.ebuild:
+ Bump to python r1 eclasses
+
03 Mar 2013; Justin Lecher <jlec@gentoo.org> qgis-9999.ebuild, metadata.xml:
Update to new qt deps names
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index fbf9b01ee..11436db30 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -2,12 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI=5
-PYTHON_USE_WITH="sqlite"
-PYTHON_DEPEND="python? 2"
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="sqlite"
-inherit cmake-utils python subversion eutils
+inherit cmake-utils python-single-r1 subversion eutils
DESCRIPTION="User friendly Geographic Information System"
HOMEPAGE="http://www.qgis.org/"
@@ -19,7 +19,10 @@ SLOT="0"
KEYWORDS=""
IUSE="examples gps grass gsl postgres python sqlite"
-RDEPEND=">=sci-libs/gdal-1.6.1[geos,postgres?,python?,sqlite?]
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=sci-libs/gdal-1.6.1[geos,postgres?,python?,sqlite?]
dev-qt/qtcore:4[qt3support]
dev-qt/qtgui:4
dev-qt/qtsvg:4
@@ -39,7 +42,7 @@ RDEPEND=">=sci-libs/gdal-1.6.1[geos,postgres?,python?,sqlite?]
>=dev-db/postgresql-server-8.4
)
)
- python? ( dev-python/PyQt4[sql,svg] )
+ python? ( ${PYTHON_DEPS} dev-python/PyQt4[sql,svg] )
sqlite? ( dev-db/sqlite:3 )"
DEPEND="${RDEPEND}
@@ -47,8 +50,7 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
+ python-single-r1_pkg_setup
}
src_configure() {