aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tom111@gmx.de>2009-05-05 15:20:55 +0200
committerThomas Kahle <tom111@gmx.de>2009-05-05 15:20:55 +0200
commit96f2cbbb35427dea0c664039c26e8ad51bf91cb8 (patch)
tree22d5fe75d53927d1e083fd341385d85f74769943
parentupdated digest. sorry. (diff)
downloadsci-96f2cbbb35427dea0c664039c26e8ad51bf91cb8.tar.gz
sci-96f2cbbb35427dea0c664039c26e8ad51bf91cb8.tar.bz2
sci-96f2cbbb35427dea0c664039c26e8ad51bf91cb8.zip
Fixes an issue with docs
improved ebuild
-rw-r--r--sci-mathematics/Macaulay2/ChangeLog4
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-1.2-r1.ebuild109
-rw-r--r--sci-mathematics/Macaulay2/Manifest3
3 files changed, 115 insertions, 1 deletions
diff --git a/sci-mathematics/Macaulay2/ChangeLog b/sci-mathematics/Macaulay2/ChangeLog
index 2ad15ea46..9f8ba6fdf 100644
--- a/sci-mathematics/Macaulay2/ChangeLog
+++ b/sci-mathematics/Macaulay2/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 05 May 2009; Thomas Kahle <tom111@gmx.de> +Macaulay2-1.2-r1.ebuild
+
+ Fixes an issue with the documentation
+
25 Apr 2009; Thomas Kahle <tom111@gmx.de> +Macaulay2-1.2.ebuild +metadata.xml +files/70Macaulay2-gentoo.el +files/patch-3.1.0b
Intial import (Bug #246095)
diff --git a/sci-mathematics/Macaulay2/Macaulay2-1.2-r1.ebuild b/sci-mathematics/Macaulay2/Macaulay2-1.2-r1.ebuild
new file mode 100644
index 000000000..2f1e6da3d
--- /dev/null
+++ b/sci-mathematics/Macaulay2/Macaulay2-1.2-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit elisp-common eutils flag-o-matic
+
+IUSE="emacs"
+
+DESCRIPTION="research tool for commutative algebra and algebraic geometry"
+SRC_URI=" http://www.math.uiuc.edu/Macaulay2/Downloads/SourceCode/${P}-r8438-src.tar.bz2
+ ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Factory/factory-3-1-0.tar.gz \
+ ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Libfac/libfac-3-1-0.tar.gz \
+ http://www.math.uiuc.edu/Macaulay2/Extra/frobby_vmike3.tar.gz"
+# mirror://gentoo/${P}-src.tar.bz2
+
+# We should keep frobby, factory and libfac in sync, and if possible make
+# separate ebuilds later
+
+HOMEPAGE="http://www.math.uiuc.edu/Macaulay2/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+# The ntl version is a due to factory
+# If <boehm-gc-7.0 is installed M2 download and install it internally
+# sys-process/time is needed to run the checks
+DEPEND="sys-libs/gdbm
+ dev-libs/gmp
+ >=dev-libs/ntl-5.4.1
+ >=dev-libs/boehm-gc-7.0
+ >=sci-mathematics/pari-2.3.4[gmp]
+ virtual/blas
+ virtual/lapack
+ dev-util/ctags
+ sys-libs/ncurses
+ sys-process/time
+ emacs? ( virtual/emacs )"
+
+SITEFILE=70Macaulay2-gentoo.el
+
+S="${WORKDIR}/${P}-r8438"
+
+src_compile() {
+ cd "${WORKDIR}/factory"
+ epatch "${FILESDIR}"/patch-3.1.0b
+ econf --enable-NTL --prefix="${WORKDIR}" || \
+ die "failed to configure factory"
+ # -j1 is still necessary
+ emake -j1 || die "failed to build factory"
+ make install || die "failed to install factory"
+
+ cd "${WORKDIR}/libfac"
+ CPPFLAGS="-I${WORKDIR}/include" econf --with-NOSTREAMIO \
+ --prefix="${WORKDIR}" || die "failed to configure libfac"
+ emake || die "failed to build libfac"
+ make install || die "failed to install libfac"
+
+ # Put sourcfile in the right location:
+ mkdir "${S}/BUILD/tarfiles"
+ cp "${DISTDIR}/frobby_vmike3.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+
+ # Workaround for a problem with the doc.
+ # Upstream will fix this in 1.3
+ cd "${S}/Macaulay2/packages/Macaulay2Doc"
+ sed "/^ *SourceCode => applicationDirectory.*$/d" -i doc13.m2
+ cd "${S}"
+
+ CXXFLAGS="${CXXFLAGS} -Wno-deprecated"
+ append-ldflags "-L${WORKDIR}/$(get_libdir)"
+ emake -j1 && CPPFLAGS="-I/usr/include/gc -I${WORKDIR}/include" \
+ ./configure --prefix="${D}/usr" --disable-encap \
+ || die "failed to configure Macaulay"
+
+ emake -j1 || die "failed to build Macaulay"
+}
+
+src_test() {
+ cd "${S}"
+ make check || die "tests failed"
+}
+
+src_install () {
+
+ make install || die "install failed"
+
+ # nothing useful in here, get rid of it
+ # NOTE: Macaulay installs into lib even on amd64 hence don't
+ # replace lib with $(get_libdir) below!
+ rm -fr "${D}"/usr/lib \
+ || die "failed to remove empty /usr/lib"
+
+ use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "If you want to set a hot key for Macaulay2 in Emacs add a line similar to"
+ elog "(global-set-key [ f12 ] 'M2)"
+ elog "in order to set it to F12 (or choose a different one)."
+ fi
+}
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/Macaulay2/Manifest b/sci-mathematics/Macaulay2/Manifest
index 7551f3b11..ff2299311 100644
--- a/sci-mathematics/Macaulay2/Manifest
+++ b/sci-mathematics/Macaulay2/Manifest
@@ -4,6 +4,7 @@ DIST Macaulay2-1.2-r8438-src.tar.bz2 3198159 RMD160 bfd5fc5498e0ca7507277e9b2997
DIST factory-3-1-0.tar.gz 565374 RMD160 059ed1697f282d309e89d1cc2e0ce8bd94a8b4b3 SHA1 c41ab3cdc6ea51332169645e35c35c3fd6c4d94b SHA256 cb1768ccaaa71557ace880be0e88100bcfd420d3094ffac59d229cd852edc0ff
DIST frobby_vmike3.tar.gz 235794 RMD160 d9bf705895f4ccb8a1db9fd3909d4ae53fb05b08 SHA1 e478c0d0ac66f4d315ab246a1b2e0cb563991367 SHA256 98c58c0bb99f81344d1a647840f32e062923f2a45bf4cbafbf03ad1160e0a673
DIST libfac-3-1-0.tar.gz 91544 RMD160 2500d402328ad532756c677015c1d01f8594e394 SHA1 d005ddd58a180b8a91fe5728b96bde515c5d9cc5 SHA256 fc3dda08f7ec039635f8d7f1629546f4ac7620a69cf9332ca39e29dd822aee7d
+EBUILD Macaulay2-1.2-r1.ebuild 3094 RMD160 878ed67534f882e66e88662a70a1d96151c489f1 SHA1 f2a06530ccb0e7db5eee5d3e788e08eb852855eb SHA256 58c56a9315665516d62e9313580ee1b2f08af5ec74e9d0f25c3a6ac449962adf
EBUILD Macaulay2-1.2.ebuild 3274 RMD160 54523c2361c3cbfde6848258901bdc53e5301d0c SHA1 93a740fca6e3c04d86a86a24d459b4e284dabb11 SHA256 bc3d3a8621e1c367715740e745839f4994cf58c95c249ec4fba4798fbe3f8435
-MISC ChangeLog 288 RMD160 40e4cef06738e0cc5808ba1b62b73def4a76cd86 SHA1 5ac2cdab9276eac29fb9934d9e6fdadbe21b3e33 SHA256 bb4b77d717c80e0b96096c05b9a5f294be0d926ddb7683d1bcad132131f5407e
+MISC ChangeLog 399 RMD160 c73ae3c42f8e97777f534b50e27607a44b68ed7f SHA1 f7a7c7e372f114fe1c5c5a004bc47912bb11dc2f SHA256 87841b76c19f6bc120c4b15023859735859df2f33418ae2292bfa6180b7cd6e5
MISC metadata.xml 361 RMD160 273db3a009b85938f85e60ea0d34d6fc625f9477 SHA1 7f6e903d81af55b08c7dbb9feb4f7ad39852a23e SHA256 71a0f19b08b1e752e754bbc5faf15880601d00c5b9df2bc5ca5a3b8e93e83b7f