aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-16 17:02:36 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-16 17:02:36 +0200
commit9757e5d545af0aa563e1538e1c1ab0f824439adc (patch)
tree8134665d84631efb452a4f5a1265d79814bf4446
parentbroken (diff)
downloadsci-9757e5d545af0aa563e1538e1c1ab0f824439adc.tar.gz
sci-9757e5d545af0aa563e1538e1c1ab0f824439adc.tar.bz2
sci-9757e5d545af0aa563e1538e1c1ab0f824439adc.zip
sci-chemistry/pymol-apbs-plugin: Bump to EAPI=5 and bump to python-r1.eclass
Package-Manager: portage-2.2.0_alpha180
-rw-r--r--sci-chemistry/pymol-apbs-plugin/ChangeLog6
-rw-r--r--sci-chemistry/pymol-apbs-plugin/metadata.xml8
-rw-r--r--sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-9999.ebuild53
3 files changed, 28 insertions, 39 deletions
diff --git a/sci-chemistry/pymol-apbs-plugin/ChangeLog b/sci-chemistry/pymol-apbs-plugin/ChangeLog
index deaec995f..a0ef0cd5e 100644
--- a/sci-chemistry/pymol-apbs-plugin/ChangeLog
+++ b/sci-chemistry/pymol-apbs-plugin/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-chemistry/pymol-apbs-plugin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 16 Jun 2013; Justin Lecher <jlec@gentoo.org> pymol-apbs-plugin-9999.ebuild,
+ metadata.xml:
+ Bump to EAPI=5 and bump to python-r1.eclass
+
29 Jun 2010; Justin Lecher <jlec@gentoo.org>
pymol-apbs-plugin-9999.ebuild:
Python ABI fixes
diff --git a/sci-chemistry/pymol-apbs-plugin/metadata.xml b/sci-chemistry/pymol-apbs-plugin/metadata.xml
index 0fbe927f0..d410f1573 100644
--- a/sci-chemistry/pymol-apbs-plugin/metadata.xml
+++ b/sci-chemistry/pymol-apbs-plugin/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<maintainer>
- <email>sci@gentoo.org</email>
-</maintainer>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>sci@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-9999.ebuild b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-9999.ebuild
index 48a055c8a..cac671396 100644
--- a/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-9999.ebuild
+++ b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-9999.ebuild
@@ -1,56 +1,41 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="3"
+EAPI=5
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
+PYTHON_COMPAT=( python2_7 )
-inherit python subversion
+inherit python-single-r1 subversion
MY_PV="${PV##*_p}"
DESCRIPTION="APBS plugin for pymol"
HOMEPAGE="http://sourceforge.net/projects/pymolapbsplugin/"
+SRC_URI=""
ESVN_REPO_URI="https://pymolapbsplugin.svn.sourceforge.net/svnroot/pymolapbsplugin/trunk/"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
LICENSE="pymol"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
-RDEPEND="
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
sci-chemistry/apbs
sci-chemistry/pdb2pqr
- !<sci-chemistry/pymol-1.2.2-r1"
+ >sci-chemistry/pymol-1.5"
DEPEND="${RDEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
-
-src_unpack() {
- subversion_src_unpack
- python_copy_sources
-}
src_install() {
- installation() {
- sed \
- -e "s:^APBS_BINARY_LOCATION.*:APBS_BINARY_LOCATION = \"${EPREFIX}/usr/bin/apbs\":g" \
- -e "s:^APBS_PSIZE_LOCATION.*:APBS_PSIZE_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/src/\":g" \
- -e "s:^APBS_PDB2PQR_LOCATION.*:APBS_PDB2PQR_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/\":g" \
- -e "s:^TEMPORARY_FILE_DIR.*:TEMPORARY_FILE_DIR = \"./\":g" \
- -i src/apbsplugin.py
-
- insinto $(python_get_sitedir)/pmg_tk/startup/
- newins src/apbsplugin.py apbs_tools.py || die
- }
- python_execute_function -s installation
-}
-
-pkg_postinst() {
- python_mod_optimize pmg_tk/startup/apbs_tools.py
-}
-
-pkg_postrm() {
- python_mod_cleanup pmg_tk/startup/apbs_tools.py
+ sed \
+ -e "s:^APBS_BINARY_LOCATION.*:APBS_BINARY_LOCATION = \"${EPREFIX}/usr/bin/apbs\":g" \
+ -e "s:^APBS_PSIZE_LOCATION.*:APBS_PSIZE_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/src/\":g" \
+ -e "s:^APBS_PDB2PQR_LOCATION.*:APBS_PDB2PQR_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/\":g" \
+ -e "s:^TEMPORARY_FILE_DIR.*:TEMPORARY_FILE_DIR = \"./\":g" \
+ -i src/apbsplugin.py > apbs_tools.py || die
+ python_moduleinto pmg_tk/startup/
+ python_domodule apbs_tools.py
+ python_optimize
}