aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-03 06:40:53 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-03 06:40:53 +0100
commit9c2dcdf491c442611763b878fba0c3240daf1d42 (patch)
tree8a9a3160757d517a98bedebba9824379903e56e8
parentsci-biology/pileup: EAPI bump (diff)
downloadsci-9c2dcdf491c442611763b878fba0c3240daf1d42.tar.gz
sci-9c2dcdf491c442611763b878fba0c3240daf1d42.tar.bz2
sci-9c2dcdf491c442611763b878fba0c3240daf1d42.zip
sci-biology/polyphen: EAPI bump, fix configure, compile and install
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-biology/polyphen/Manifest2
-rw-r--r--sci-biology/polyphen/polyphen-2.2.2.ebuild38
2 files changed, 38 insertions, 2 deletions
diff --git a/sci-biology/polyphen/Manifest b/sci-biology/polyphen/Manifest
index b74939c54..6b1d95704 100644
--- a/sci-biology/polyphen/Manifest
+++ b/sci-biology/polyphen/Manifest
@@ -1 +1,3 @@
+DIST mafft-7.221-without-extensions-src.tgz 376075 BLAKE2B effe24080d453bad8ff4cd424e8ea592e64e254233cbaa245cc71edbeba293edb24d039f9bde3f54c000a1b1f5d966317020a546d8fc78f63494066b207624a9 SHA512 f5a79621a784ef8b054e93be70aa0ada8a366951349b4e4f9e6a42c287502ba60ec0722c199da2874098c6b5c6b9449dfb5071914770a8364007b779a6a601a2
DIST polyphen-2.2.2r405d.tar.gz 2205380 BLAKE2B 5cb863b8b1626bfa2da264bfebfe5fea3932d13eac5f74fd76932c310fa20cbdd33905d8faa7bb82739d3d0b2bdbaea94c1470a4f28c8df1fd5accee23faef26 SHA512 e2418b0e18aeb1ebeaa31a743901e89b8b5cd670357ed8d78d7d22f414b8f5e98e80124bbea9d7ebf2fdc7a6ef33f050b67683740c1e4a4d01ac7a75d33dbaac
+DIST weka-3-6-12.zip 24335916 BLAKE2B fe9b9406fce1f8ad5b4338e7cf18d8a6cf1fbc19e335f5fd66197c1aa45fdaf25859a191a0d99d32e06e6f84a6d9f900817a9d574fe447a2be1a818855787f10 SHA512 4301e1c2a751e26ff8d860e24e54e71511276f8cb90020c935595aaaab547f8614381ca8087b83a670d13ef0ff3fa13084f4984b9249e16042703ef9f43c0bd1
diff --git a/sci-biology/polyphen/polyphen-2.2.2.ebuild b/sci-biology/polyphen/polyphen-2.2.2.ebuild
index 0995356fd..da07819a5 100644
--- a/sci-biology/polyphen/polyphen-2.2.2.ebuild
+++ b/sci-biology/polyphen/polyphen-2.2.2.ebuild
@@ -5,11 +5,21 @@ EAPI=7
DESCRIPTION="Predict effect of aminoacid substitution on human protein function"
HOMEPAGE="http://genetics.bwh.harvard.edu/pph2/dokuwiki/start"
-SRC_URI="http://genetics.bwh.harvard.edu/pph2/dokuwiki/_media/polyphen-${PV}r405d.tar.gz"
+SRC_URI="
+ http://genetics.bwh.harvard.edu/pph2/dokuwiki/_media/polyphen-${PV}r405d.tar.gz
+ http://mafft.cbrc.jp/alignment/software/mafft-7.221-without-extensions-src.tgz
+ http://prdownloads.sourceforge.net/weka/weka-3-6-12.zip
+"
LICENSE="polyphen" # for non-commercial use only
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-perl/CGI
+ sci-biology/ncbi-blast+
+"
+RDEPEND="${DEPEND}"
# 3.7GB
# ftp://genetics.bwh.harvard.edu/pph2/bundled/polyphen-2.2.2-databases-2011_12.tar.bz2
@@ -19,3 +29,27 @@ KEYWORDS=""
# 895MB
# ftp://genetics.bwh.harvard.edu/pph2/bundled/polyphen-2.2.2-alignments-multiz-2009_10.tar.bz2
+
+src_unpack() {
+ unpack "polyphen-${PV}r405d.tar.gz"
+ cp "${DISTDIR}/mafft-7.221-without-extensions-src.tgz" "${S}/src" || die
+ cp "${DISTDIR}/weka-3-6-12.zip" "${S}/src" || die
+}
+
+src_configure() {
+ # non-standard configure script
+ ./configure
+}
+
+src_compile() {
+ pushd src
+ emake -j1
+ popd
+}
+
+src_install() {
+ pushd src
+ default
+ popd
+ einstalldocs
+}