aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-01-03 10:12:54 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2017-01-03 10:12:54 +0100
commit9e222a2f6941fe86c70eba205579707757bc48c9 (patch)
treebe75e584e3e35578ad27c13c0f07a52805475932
parentsci-libs/arrayfire: Drop old (diff)
downloadsci-9e222a2f6941fe86c70eba205579707757bc48c9.tar.gz
sci-9e222a2f6941fe86c70eba205579707757bc48c9.tar.bz2
sci-9e222a2f6941fe86c70eba205579707757bc48c9.zip
dev-python/matplotlib2tikz: Version bump to 0.5.16
Package-Manager: portage-2.3.0
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.5.16.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
index c858020fd..87145939d 100644
--- a/dev-python/matplotlib2tikz/Manifest
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -1,2 +1,3 @@
DIST matplotlib2tikz-0.5.14.tar.gz 24290 SHA256 4759a4af7fcce23e0ea1aaa875d1c2b31f26f4412513603c1f6524a9fe48964f SHA512 8924e20663a740f19c8264da52284965cd23c41f01fb0118e06618edf8d3c1976942191d4e0a43a4c5be3b4c015c9392fd524ffb13af19c9d3a69b3b7f775327 WHIRLPOOL 42ada6d0e947d20fe8c1ca047ae13065f877d067536f7a6377f784bef73adbf83ec812b5f24b29573f1120dca6616e375fb18b2c0b3b833c3913c767f297108f
+DIST matplotlib2tikz-0.5.16.tar.gz 25296 SHA256 4f640fe0fe67bebc0a63f2061f4c74f13caddb4200c6fc65f006c1ae7d76325d SHA512 6155c92f3014beac1a30bb64e0adb4946a239f805a6236871a863c357afec402bfe6c9431d92867a2088a1406b23d17261a2877a39481b9130f9fe11e157de06 WHIRLPOOL f6ffdfdc147e52b7cdb5ac7a4e01d87ea869c95e4248d8cd2605ff23a503aaab3fb5e80432e48ec6b3d455f5585b2b94885a5168d0a98b773be01433fb1066c3
DIST matplotlib2tikz-0.5.7.tar.gz 22830 SHA256 67586786b83c92266e1796f7dbbb458301c38ea8320fcb6c05f906c82713403d SHA512 18f7c945e83a3f04edc38a76becdfa4c1c6293e8ec869b18723981f7cab201a6998ce63d2b36c32415f9c7f740c8d43c534881def1b3b469aa4976b7e1ef6f27 WHIRLPOOL 7a64a29e8052f4caa3c132cf2bc4e72cf7f8813f5ceae0ed1dc5fbdd6bfa93dab7b050826213e40a3a07279991c27c83021f2aa0ed079e6e2eab5b6a4976d51d
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.16.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.16.ebuild
new file mode 100644
index 000000000..2c29ff934
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert matplotlib figures into native Pgfplots (TikZ) figures"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pillow-3.0.0[${PYTHON_USEDEP}]
+ dev-texlive/texlive-pictures"
+DEPEND="${RDEPEND}"
+ #test? ( dev-python/pytest[${PYTHON_USEDEP}] )"