aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-06-09 12:22:32 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-06-09 12:22:32 +0200
commit9e3dc1d39ddeb3791dd2f71f9eb6087bf0ba61c4 (patch)
tree0a3b1373a4ab89cbf88d1ac16bf5a54e9a56d0b1
parentFix Manifests (diff)
downloadsci-9e3dc1d39ddeb3791dd2f71f9eb6087bf0ba61c4.tar.gz
sci-9e3dc1d39ddeb3791dd2f71f9eb6087bf0ba61c4.tar.bz2
sci-9e3dc1d39ddeb3791dd2f71f9eb6087bf0ba61c4.zip
sci-biology/artemis-bin: ebuild cleanup
Package-Manager: portage-2.2.18
-rw-r--r--sci-biology/artemis-bin/Manifest2
-rw-r--r--sci-biology/artemis-bin/artemis-bin-16.0.11.ebuild29
2 files changed, 23 insertions, 8 deletions
diff --git a/sci-biology/artemis-bin/Manifest b/sci-biology/artemis-bin/Manifest
index d9651ab45..3bd261d96 100644
--- a/sci-biology/artemis-bin/Manifest
+++ b/sci-biology/artemis-bin/Manifest
@@ -1,2 +1,4 @@
DIST artemis.pdf 1149449 SHA256 ab573b4ea7b895cb7d2a97e4d42a71938f1feda44e2da22fe5b079583ad87ba6 SHA512 1c3056dab7239c3a68b2e76491d77612f22ac8f83eaf32e0ab0a3901e03d3c65d5ac02f5758d2d7728d94dd44c29517a498fa94a947d5d319ded43ddec4ba5fb WHIRLPOOL a75266ae72075ea7547560a9046c1e0f813956b94a5c3d9af3cd08a579ed60af842c6ece94e6b1dfa5db1820094069edb7d88b4ee6256410ebced4310739d79f
DIST artemis_compiled_v16.0.11.tar.gz 10722613 SHA256 0413c3f0deab4d813bc4f3af7aef8cca09ad2111b3497a0696c18a31857ffd4b SHA512 a0fb9f64b0fb869bde9fe2d1788ed938a16ea0bd75315abd93e65af89772fe9d4589b7e7813286c9b1d90f1f3133c16d9bc35ce78d1740c5631ca0e32633e421 WHIRLPOOL 0682bdfead9f95a17180816ed445226c128a804f8db3549c78627b510330694b60fd7ab0e419766bf08295f3a266eefd0dfd85c0d1244c80009b5aba0c29052a
+DIST artemis_v16.0.11.jar 11292419 SHA256 f368714105646cfc31460cfcfb72b8b33490c7684ee5323d7dd181060039c80f SHA512 2fbd7c5ab12c2ca710906324eb5ee861d4821eaf923f630a800ce2b2de4e43c3971cf6c470140aa2654741ab79440a2039e8b9a17502ca955432d9ef311e9f84 WHIRLPOOL fc605625b536853ee7657b09bca93f04b9f1da67a093875bcfac0d4948f7daf020c26f0624b551aba36f21e87a7ee8b933e0e26c45a715ea2fe6cb9211d0f78f
+DIST sartemis_v16.0.11.jar 11832144 SHA256 834ad0464405843904b173f38220f47867ec8eb779cb2c37d6de7ba585ef133c SHA512 6fd63ac81eed727816fe633cde3e9fab9eaf71a61c74aef4f82c8c4dc24efe93ce86494ebdf3fcb3d82e50aed5c277f383f67c1b7b68ae81cf872f2982bc1850 WHIRLPOOL 874ab57f11b011a222efd4b91278614941b096756faf0259b844453dfb082d99bae503faa2ffaeb6c4d56b4317b3bcc00a49f8b5b16d6c7cc02968b4911c503a
diff --git a/sci-biology/artemis-bin/artemis-bin-16.0.11.ebuild b/sci-biology/artemis-bin/artemis-bin-16.0.11.ebuild
index d089c7fc0..3c0415906 100644
--- a/sci-biology/artemis-bin/artemis-bin-16.0.11.ebuild
+++ b/sci-biology/artemis-bin/artemis-bin-16.0.11.ebuild
@@ -10,22 +10,35 @@ MY_V="16"
DESCRIPTION="DNA sequence viewer, annotation (Artemis) and comparison (ACT) tool"
HOMEPAGE="http://www.sanger.ac.uk/resources/software/artemis"
-SRC_URI="ftp://ftp.sanger.ac.uk/pub4/resources/software/artemis/v"${MY_V}"/v"${PV}"/artemis_compiled_v"${PV}".tar.gz
+SRC_URI="ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v"${MY_V}"/v"${PV}"/artemis_compiled_v"${PV}".tar.gz
+ ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v"${MY_V}"/v"${PV}"/artemis_v"${PV}".jar
+ ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v"${MY_V}"/v"${PV}"/sartemis_v"${PV}".jar
ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/artemis.pdf"
-
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64"
IUSE=""
-DEPEND="sci-biology/samtools
- sci-biology/BamView"
+S="${WORKDIR}"/artemis
+
+DEPEND="
+ !sci-biology/artemis
+ sci-biology/samtools"
RDEPEND="${DEPEND}
>=virtual/jre-1.6"
src_install(){
- dodoc artemis.pdf
+ cp -p "${DISTDIR}"/artemis_v"${PV}".jar artemis.jar || die
+ java-pkg_dojar artemis.jar
+ cp -p "${DISTDIR}"/sartemis_v"${PV}".jar sartemis.jar || die
+ java-pkg_dojar sartemis.jar
+ dodoc "${DISTDIR}"/artemis.pdf README
}
-# do not know what is the diffeerence between artemis_compiled_v16.0.6.tar.gz, artemis_v16.0.6.jar and sartemis_v16.0.6.jar
-# ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v16/v16.0.6/
+# artemis_compiled_v16.0.11.tar.gz contains compiled binaries but also java *.class files
+# artemis_v16.0.11.jar and sartemis_v16.0.11.jar
+# ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v16/v16.0.11/
+
+pkg_postinst(){
+ einfo "For BAM file support please install sci-biology/BamView"
+}