aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-09-04 15:18:20 +0200
committerJustin Lecher <jlec@gentoo.org>2011-09-04 15:18:20 +0200
commit9f749f2381868a79ea143f571fee7facbcabd644 (patch)
treeffbe37fe062a37f7b60c62f010f3881735051099
parent[sys-infiniband/librxe] Add sw driver for roce (diff)
downloadsci-9f749f2381868a79ea143f571fee7facbcabd644.tar.gz
sci-9f749f2381868a79ea143f571fee7facbcabd644.tar.bz2
sci-9f749f2381868a79ea143f571fee7facbcabd644.zip
Initial commit
(Portage version: 2.2.0_alpha53/git/Linux x86_64, signed Manifest commit with key 70EB7916)
-rw-r--r--sci-chemistry/usf-tools/ChangeLog11
-rw-r--r--sci-chemistry/usf-tools/Manifest17
-rw-r--r--sci-chemistry/usf-tools/files/Makefile18
-rw-r--r--sci-chemistry/usf-tools/files/Makefile_gklib24
-rw-r--r--sci-chemistry/usf-tools/files/usf-tools-1-build.patch28
-rw-r--r--sci-chemistry/usf-tools/metadata.xml8
-rw-r--r--sci-chemistry/usf-tools/usf-tools-1.ebuild66
7 files changed, 172 insertions, 0 deletions
diff --git a/sci-chemistry/usf-tools/ChangeLog b/sci-chemistry/usf-tools/ChangeLog
new file mode 100644
index 000000000..920b31786
--- /dev/null
+++ b/sci-chemistry/usf-tools/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-chemistry/usf-tools
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*usf-tools-1 (04 Sep 2011)
+
+ 04 Sep 2011; Justin Lecher <jlec@gentoo.org> +usf-tools-1.ebuild,
+ +files/usf-tools-1-build.patch, +files/Makefile, +files/Makefile_gklib,
+ +metadata.xml:
+ Initial commit
+
diff --git a/sci-chemistry/usf-tools/Manifest b/sci-chemistry/usf-tools/Manifest
new file mode 100644
index 000000000..abdca33e2
--- /dev/null
+++ b/sci-chemistry/usf-tools/Manifest
@@ -0,0 +1,17 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+AUX Makefile 581 RMD160 61520248fc9f0f8065348a2be3bdebe036f1dd68 SHA1 480ca3ef1e1257b86f017adb994dfaf97f591017 SHA256 8f964cd8ba5b00f5c2e23828101a57e434b5c59655cf6fee7f57e9cc488c5c47
+AUX Makefile_gklib 475 RMD160 aa187eb1525581a8a79743f2bf8592e9a6d5928f SHA1 5f34342ef27c77971a65d70d9fcbb5191d733dbf SHA256 a7233bd248d544ca216a7d9aabb611cb48eefdb7f4dddaf14b32444f2152f87d
+AUX usf-tools-1-build.patch 888 RMD160 ba463c7c100c9e4f53f4b4c157876fa791f23202 SHA1 b96b72f5cf7942719a7b80912a4b16406183a4e8 SHA256 f83af7fc5d78a8e259c304de7b3419b02cd114ff9adaeadd97866995992c1484
+DIST usf-tools-1.tar.gz 108530172 RMD160 b48c3b624ad384a1d30938a94253a4329297f0ef SHA1 091895516eb11c2c701a2c13846cbd8aacf5e3c3 SHA256 dd59640fb154d4157b814554dff68d6515cb1a417ed16794dc4f310dc92e95d4
+EBUILD usf-tools-1.ebuild 1515 RMD160 f761fe0f0f2c6fe9a559f09799fe7d82b4935191 SHA1 da0491558080e7b0dc3e39ff2225d0527e69bb0a SHA256 1eb1241fa37c28fa7d09ca0e80a07f4f19f4d93aeddef06c69a197404a86d68a
+MISC ChangeLog 329 RMD160 68445a550e40a57665c71d23f604b9931aa2f4fd SHA1 3e6200b4522c0eaf08167a614a9ff06bb57c8e12 SHA256 7f01730fc07ab0cd1afaee47c64e510fdf7049ebe05409bf065d533794a2cafc
+MISC metadata.xml 219 RMD160 e9da2d4271f89b9dbac478d145a519318f0f3314 SHA1 6d4a101013d6a40cd61cb2d8c6b517c443013bc7 SHA256 0be94b46df4c9a73494034f33b1371769951f52890e5c857ebe1dc9bc729d0a8
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iEYEAREKAAYFAk5jepwACgkQgAnW8HDreRaPOQCfY6PM175htFQWpC/W3l+/14ph
+7lYAn27ZW8wu/OxgCjgufI9P0+TRn74z
+=o02c
+-----END PGP SIGNATURE-----
diff --git a/sci-chemistry/usf-tools/files/Makefile b/sci-chemistry/usf-tools/files/Makefile
new file mode 100644
index 000000000..655056000
--- /dev/null
+++ b/sci-chemistry/usf-tools/files/Makefile
@@ -0,0 +1,18 @@
+SUBDIRS = aconio ave cello coma comap comdem crave dataman essens \
+findncs flood imp lsqman mama mapfix mapman mappage mave moleman \
+moleman2 ncs6d o2d odbman oops oops2 prof seaman site2rt sod solex \
+spancsi ssencs voidoo xpand xplo2d
+
+SUBDIRS_MAKERULE = \
+ @+for d in $(SUBDIRS) ""; do \
+ if test -d "$$d" -a ! -z "$$d"; then \
+ echo === $$d ===; \
+ $(MAKE) -C $$d || exit $$?; \
+ fi; \
+ done
+
+all: gklib/libkley.so $(SUBDIRS)
+ $(SUBDIRS_MAKERULE)
+
+gklib/libkley.so:
+ $(MAKE) -C gklib
diff --git a/sci-chemistry/usf-tools/files/Makefile_gklib b/sci-chemistry/usf-tools/files/Makefile_gklib
new file mode 100644
index 000000000..4e9e9aa59
--- /dev/null
+++ b/sci-chemistry/usf-tools/files/Makefile_gklib
@@ -0,0 +1,24 @@
+EXTRA_FFLAGS = -DLINUX -u -std=legacy -ffixed-line-length-132
+LIBS = -lccp4f -lccp4c
+
+all: libkley.so.0.0.1
+
+OBJ = $(patsubst %.f,%.o,$(wildcard *.f))
+
+echo :
+ echo $(OBJ)
+
+%.o: %.f
+ $(FC) $(FFLAGS) $(EXTRA_FFLAGS) -fPIC -c $<
+
+fmalloc:
+ $(CC) $(CFLAGS) -DLINUX -fPIC -c $@.c
+
+libkley.a: OBJ fmalloc
+ ar rsv $@ *.o
+ ranlib $@
+
+libkley.so.0.0.1: $(OBJ) fmalloc
+ $(FC) $(LDFLAGS) -shared -Wl,-soname,libkley.so.0 -o $@ *.o $(LIBS)
+ ln -sf $@ libkley.so.0
+ ln -sf $@ libkley.so
diff --git a/sci-chemistry/usf-tools/files/usf-tools-1-build.patch b/sci-chemistry/usf-tools/files/usf-tools-1-build.patch
new file mode 100644
index 000000000..554a1e9ee
--- /dev/null
+++ b/sci-chemistry/usf-tools/files/usf-tools-1-build.patch
@@ -0,0 +1,28 @@
+ Makefile_linux_template | 8 +++++---
+ 1 files changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile_linux_template b/Makefile_linux_template
+index 3535cab..5ed4719 100755
+--- a/Makefile_linux_template
++++ b/Makefile_linux_template
+@@ -1,7 +1,8 @@
+ #
+-OBJ= PROGRAMNAME.o ../gklib/linux_kleylib ../ccp4libs_latest_m32_linux/libccp4f.a ../ccp4libs_latest_m32_linux/libccp4c.a
++OBJ= PROGRAMNAME.o
++LIBS= -L../gklib -lkley -lccp4f -lccp4c
+ EXEC = PROGRAMNAME
+-INCL= Makefile_linux
++INCL= Makefile
+ SUBS =
+ STATIC =
+ ##SUBS## SUBS = PROGRAMNAME_subs.o
+@@ -14,7 +15,8 @@ opt= -O -u -ffixed-line-length-132 -I..
+ link= -O
+
+ $(EXEC): $(OBJ) $(SUBS)
+- $(fc) $(link) -o $(EXEC) $(SUBS) $(OBJ) $(STATIC) ; strip $(EXEC)
++ $(fc) $(link) -o $(EXEC) $(SUBS) $(OBJ) $(STATIC) $(LIBS)
++ cp -fv $(EXEC) ../bin/
+
+ PROGRAMNAME.o: PROGRAMNAME.fpp $(INCL)
+ $(fc) $(opt) -c PROGRAMNAME.fpp
diff --git a/sci-chemistry/usf-tools/metadata.xml b/sci-chemistry/usf-tools/metadata.xml
new file mode 100644
index 000000000..210ad0db0
--- /dev/null
+++ b/sci-chemistry/usf-tools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/usf-tools/usf-tools-1.ebuild b/sci-chemistry/usf-tools/usf-tools-1.ebuild
new file mode 100644
index 000000000..73a2fb65c
--- /dev/null
+++ b/sci-chemistry/usf-tools/usf-tools-1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils fortran-2 multilib toolchain-funcs
+
+DESCRIPTION="The USF program suite"
+HOMEPAGE="http://xray.bmc.uu.se/markh/usf"
+SRC_URI="http://xray.bmc.uu.se/markh/usf/usf_distribution_kit.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="as-is"
+IUSE=""
+
+RDEPEND="
+ sci-libs/ccp4-libs
+ sci-libs/mmdb"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/usf_export
+
+src_prepare() {
+ local i j suffix
+ epatch "${FILESDIR}"/${P}-build.patch
+ ebegin "Fixing buildsystem"
+
+ find ccp4libs* lib usf_osx_bin -delete
+ for i in *; do
+ if [[ -d ${i} && ${i} != gklib && ${i} != bin ]]; then
+ pushd ${i} > /dev/null
+ sed \
+ -e 's:maxdim.incl:../maxdim.incl:g' \
+ -e 's:../../maxdim.incl:../maxdim.incl:g' \
+ -i * || die
+ sed \
+ -e "s:PROGRAMNAME:${i}:g" \
+ -e "/^fc/s:^.*$:fc = ${FC} -DLINUX:g" \
+ -e "/^opt/s:^.*$:opt = ${FFLAGS} -u -ffixed-line-length-132 -I..:g" \
+ -e "/^link/s:^.*$:link = ${LDFLAGS}:g" \
+ ../Makefile_linux_template > Makefile || die
+
+# for suffix in subs gen; do
+ for suffix in subs; do
+ if [[ -f ${i}_${suffix}.f ]]; then
+ sed "/^SUBS/s:$: ${i}_${suffix}.o:g " -i Makefile || die
+ fi
+ done
+ popd > /dev/null
+ fi
+ done
+
+ tc-export CC
+
+ cp "${FILESDIR}"/Makefile_gklib gklib/Makefile || die
+ cp "${FILESDIR}"/Makefile . || die
+
+ eend
+}
+
+src_install() {
+ dobin bin/*
+ dolib.so gklib/*so*
+}