aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-07 10:44:55 +0200
committerJustin Lecher <jlec@gentoo.org>2012-06-07 10:44:55 +0200
commita23219acf6633e7826c5928733e2240f647f86ec (patch)
treebd52e0e3cacc65620b621339a92cbb84ae3b755e
parentMask old dssp and make sci overlay user to tester (diff)
parentsci-chemistry/mgltools-qslimlib: Fix for gcc-4.7 (diff)
downloadsci-a23219acf6633e7826c5928733e2240f647f86ec.tar.gz
sci-a23219acf6633e7826c5928733e2240f647f86ec.tar.bz2
sci-a23219acf6633e7826c5928733e2240f647f86ec.zip
Merge branch 'master' of github.com:gentoo-science/sci
* 'master' of github.com:gentoo-science/sci: sci-chemistry/mgltools-qslimlib: Fix for gcc-4.7 fixed info install sci-chemistry/mgltools-pmv: Fix for bytecompiling app-admin/eselect: Fix eaclocal call
-rw-r--r--app-admin/eselect/ChangeLog4
-rw-r--r--app-admin/eselect/eselect-1.3.1-r1.ebuild2
-rw-r--r--app-admin/eselect/metadata.xml6
-rw-r--r--sci-chemistry/mgltools-pmv/ChangeLog4
-rw-r--r--sci-chemistry/mgltools-pmv/files/mgltools-pmv-1.5.6_rc2-code-fix.patch66
-rw-r--r--sci-chemistry/mgltools-pmv/mgltools-pmv-1.5.6_rc2.ebuild2
-rw-r--r--sci-chemistry/mgltools-qslimlib/ChangeLog4
-rw-r--r--sci-chemistry/mgltools-qslimlib/files/1.5.4-gcc4.7.patch30
-rw-r--r--sci-chemistry/mgltools-qslimlib/mgltools-qslimlib-1.5.6_rc2.ebuild4
-rw-r--r--sci-visualization/gnuplot/ChangeLog3
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild5
11 files changed, 123 insertions, 7 deletions
diff --git a/app-admin/eselect/ChangeLog b/app-admin/eselect/ChangeLog
index bb06deb76..99f036ee5 100644
--- a/app-admin/eselect/ChangeLog
+++ b/app-admin/eselect/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect/ChangeLog,v 1.179 2011/01/22 21:38:52 ulm Exp $
+ 04 Jun 2012; Justin Lecher <jlec@gentoo.org> eselect-1.3.1-r1.ebuild,
+ metadata.xml:
+ Fix eaclocal call
+
15 Mar 2012; François Bissey <francois.bissey@canterbury.ac.nz>
eselect-1.3.1-r1.ebuild:
add a band aid for prefix
diff --git a/app-admin/eselect/eselect-1.3.1-r1.ebuild b/app-admin/eselect/eselect-1.3.1-r1.ebuild
index d9f45fcb7..1bbfdb5a5 100644
--- a/app-admin/eselect/eselect-1.3.1-r1.ebuild
+++ b/app-admin/eselect/eselect-1.3.1-r1.ebuild
@@ -35,7 +35,7 @@ RDEPEND="!app-admin/eselect-news
src_prepare() {
epatch "${FILESDIR}"/${PN}-alternatives.patch
- eautoreconf
+ AT_M4DIR="." eautoreconf
}
src_compile() {
diff --git a/app-admin/eselect/metadata.xml b/app-admin/eselect/metadata.xml
index d9f09c811..8a4390ffe 100644
--- a/app-admin/eselect/metadata.xml
+++ b/app-admin/eselect/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>bicatali@gentoo.org</email>
-</maintainer>
+ <maintainer>
+ <email>bicatali@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/sci-chemistry/mgltools-pmv/ChangeLog b/sci-chemistry/mgltools-pmv/ChangeLog
index c6905e291..ba0327f60 100644
--- a/sci-chemistry/mgltools-pmv/ChangeLog
+++ b/sci-chemistry/mgltools-pmv/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 04 Jun 2012; Justin Lecher <jlec@gentoo.org> mgltools-pmv-1.5.6_rc2.ebuild,
+ +files/mgltools-pmv-1.5.6_rc2-code-fix.patch:
+ Fix for bytecompiling
+
27 Apr 2012; Justin Lecher <jlec@gentoo.org> mgltools-pmv-1.5.4-r1.ebuild,
mgltools-pmv-1.5.6_rc2.ebuild:
Add 2.7-pypy-* to RESTRICT_PYTHON_ABIS
diff --git a/sci-chemistry/mgltools-pmv/files/mgltools-pmv-1.5.6_rc2-code-fix.patch b/sci-chemistry/mgltools-pmv/files/mgltools-pmv-1.5.6_rc2-code-fix.patch
new file mode 100644
index 000000000..10e2d3b96
--- /dev/null
+++ b/sci-chemistry/mgltools-pmv/files/mgltools-pmv-1.5.6_rc2-code-fix.patch
@@ -0,0 +1,66 @@
+ .../blender/plugin/blenderPmvClientGUI.py | 2 +-
+ .../cinema4d/plugin/epmv_c4d_plugin.py | 2 +-
+ Pmv/hostappInterface/cinema4d/test/energy_test.py | 4 ++--
+ Pmv/styles/sessionToStyle.py | 3 +--
+ 4 files changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/Pmv/hostappInterface/blender/plugin/blenderPmvClientGUI.py b/Pmv/hostappInterface/blender/plugin/blenderPmvClientGUI.py
+index 68e09c0..d52b17d 100644
+--- a/Pmv/hostappInterface/blender/plugin/blenderPmvClientGUI.py
++++ b/Pmv/hostappInterface/blender/plugin/blenderPmvClientGUI.py
+@@ -46,7 +46,7 @@ interface...
+ import math
+ import sys
+
+-MGL_ROOT= #'/Library/MGLTools/1.5.6.csv'
++MGL_ROOT= "" #'/Library/MGLTools/1.5.6.csv'
+ sys.path[0]=(MGL_ROOT+'/lib/python2.5/site-packages')
+ sys.path.append(MGL_ROOT+'/lib/python2.5/site-packages/PIL')
+ sys.path.append(MGL_ROOT+'/MGLToolsPckgs')
+diff --git a/Pmv/hostappInterface/cinema4d/plugin/epmv_c4d_plugin.py b/Pmv/hostappInterface/cinema4d/plugin/epmv_c4d_plugin.py
+index 42617e3..6087cd0 100644
+--- a/Pmv/hostappInterface/cinema4d/plugin/epmv_c4d_plugin.py
++++ b/Pmv/hostappInterface/cinema4d/plugin/epmv_c4d_plugin.py
+@@ -38,7 +38,7 @@ __version__="v0.1.1a"
+ # ***** END GPL LICENCE BLOCK *****
+ # --------------------------------------------------------------------------
+
+-MGL_ROOT=
++MGL_ROOT= ""
+
+ #TODO:
+ #make the pyrosetta extension
+diff --git a/Pmv/hostappInterface/cinema4d/test/energy_test.py b/Pmv/hostappInterface/cinema4d/test/energy_test.py
+index 9393e25..c5f83c9 100644
+--- a/Pmv/hostappInterface/cinema4d/test/energy_test.py
++++ b/Pmv/hostappInterface/cinema4d/test/energy_test.py
+@@ -56,7 +56,7 @@ c = self.md_Amber94
+ #call md_Amber94 command
+ #c('mdtest5', 349, callback=1, filename='0', log=0, callback_freq=10)
+ import thread
+-thread.start_new(c,('mdtest5', 349, callback=1, filename='0', log=0, callback_freq=10))
++thread.start_new_thread(c,'mdtest5', 349, callback=1, filename='0', log=0, callback_freq=10)
+ thr = MyThread()#c,'mdtest5', 349, callback=1, filename='0', log=0, callback_freq=10)
+ thr.start(back=True)
+ #do some other operations here
+@@ -101,4 +101,4 @@ for mode in modes:
+
+
+ # Show animation of the first non-trivial mode
+-view(modes[6])
+\ No newline at end of file
++view(modes[6])
+diff --git a/Pmv/styles/sessionToStyle.py b/Pmv/styles/sessionToStyle.py
+index 013bae1..4b0db48 100644
+--- a/Pmv/styles/sessionToStyle.py
++++ b/Pmv/styles/sessionToStyle.py
+@@ -14,8 +14,7 @@ name, ext = os.path.splitext(filename)
+ f = open(name+'_style.py', 'w')
+ f.write("numberOfMolecules = 1\n\n")
+
+-f.write("__doc__ = """Style_01: Applies to X molecules. It displays ..
+-"""\n")
++f.write('__doc__ = """Style_01: Applies to X molecules. It displays .."""\n')
+
+ f.write("def applyStyle(mv, molName):\n")
+ f.write(" mode='both'\n")
diff --git a/sci-chemistry/mgltools-pmv/mgltools-pmv-1.5.6_rc2.ebuild b/sci-chemistry/mgltools-pmv/mgltools-pmv-1.5.6_rc2.ebuild
index ecdb305db..7364c56fb 100644
--- a/sci-chemistry/mgltools-pmv/mgltools-pmv-1.5.6_rc2.ebuild
+++ b/sci-chemistry/mgltools-pmv/mgltools-pmv-1.5.6_rc2.ebuild
@@ -46,5 +46,7 @@ src_prepare() {
-e 's:^.*CVS:#&1:g' \
-e 's:^.*LICENSE:#&1:g' \
-i "${S}"/MANIFEST.in || die
+
+ epatch "${FILESDIR}"/${P}-code-fix.patch
distutils_src_prepare
}
diff --git a/sci-chemistry/mgltools-qslimlib/ChangeLog b/sci-chemistry/mgltools-qslimlib/ChangeLog
index 6e6a045e2..76cb23c40 100644
--- a/sci-chemistry/mgltools-qslimlib/ChangeLog
+++ b/sci-chemistry/mgltools-qslimlib/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 05 Jun 2012; Justin Lecher <jlec@gentoo.org> +files/1.5.4-gcc4.7.patch,
+ mgltools-qslimlib-1.5.6_rc2.ebuild:
+ Fix for gcc-4.7
+
27 Apr 2012; Justin Lecher <jlec@gentoo.org>
mgltools-qslimlib-1.5.4-r1.ebuild, mgltools-qslimlib-1.5.6_rc2.ebuild:
Add 2.7-pypy-* to RESTRICT_PYTHON_ABIS
diff --git a/sci-chemistry/mgltools-qslimlib/files/1.5.4-gcc4.7.patch b/sci-chemistry/mgltools-qslimlib/files/1.5.4-gcc4.7.patch
new file mode 100644
index 000000000..5e94b74d1
--- /dev/null
+++ b/sci-chemistry/mgltools-qslimlib/files/1.5.4-gcc4.7.patch
@@ -0,0 +1,30 @@
+ src/mixkit/MxDynBlock.h | 2 +-
+ src/mixkit/MxStack.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/mixkit/MxDynBlock.h b/src/mixkit/MxDynBlock.h
+index 51cc89b..4e313d2 100644
+--- a/src/mixkit/MxDynBlock.h
++++ b/src/mixkit/MxDynBlock.h
+@@ -41,7 +41,7 @@ public:
+
+ T& add()
+ {
+- if( length()==total_space() ) resize(total_space() * 2);
++ if( length()==total_space() ) this->resize(total_space() * 2);
+ fill++;
+ return last();
+ }
+diff --git a/src/mixkit/MxStack.h b/src/mixkit/MxStack.h
+index 9ed9a05..1275ddd 100644
+--- a/src/mixkit/MxStack.h
++++ b/src/mixkit/MxStack.h
+@@ -33,7 +33,7 @@ public:
+
+ T& pop() { return this->drop(); }
+
+- void push(const T& val) { add(val); }
++ void push(const T& val) { this->add(val); }
+ //
+ // NOTE: In this code, it is *crucial* that we do the add() and
+ // assignment in separate steps. The obvious alternative
diff --git a/sci-chemistry/mgltools-qslimlib/mgltools-qslimlib-1.5.6_rc2.ebuild b/sci-chemistry/mgltools-qslimlib/mgltools-qslimlib-1.5.6_rc2.ebuild
index 37ecc7e49..c45470833 100644
--- a/sci-chemistry/mgltools-qslimlib/mgltools-qslimlib-1.5.6_rc2.ebuild
+++ b/sci-chemistry/mgltools-qslimlib/mgltools-qslimlib-1.5.6_rc2.ebuild
@@ -45,6 +45,8 @@ src_prepare() {
-e 's:^.*LICENSE:#&1:g' \
-i "${S}"/MANIFEST.in || die
- epatch "${FILESDIR}"/1.5.4-gcc4.3.patch
+ epatch \
+ "${FILESDIR}"/1.5.4-gcc4.3.patch \
+ "${FILESDIR}"/1.5.4-gcc4.7.patch
distutils_src_prepare
}
diff --git a/sci-visualization/gnuplot/ChangeLog b/sci-visualization/gnuplot/ChangeLog
index fe614ead5..5a9c9e1c6 100644
--- a/sci-visualization/gnuplot/ChangeLog
+++ b/sci-visualization/gnuplot/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 07 Jun 2012; Christoph Junghans <ottxor@gentoo.org> gnuplot-4.7.9999.ebuild:
+ fixed info install
+
14 Mar 2012; Christoph Junghans <ottxor@gentoo.org> -gnuplot-4.4.9999.ebuild,
gnuplot-4.6.9999.ebuild, gnuplot-4.7.9999.ebuild, metadata.xml:
sci-visualization/gnuplot: clean up
diff --git a/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild b/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild
index 5a5541edc..afaa4248f 100644
--- a/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild
@@ -102,7 +102,7 @@ src_configure() {
fi
local myconf
- myconf="${myconf} --without-lisp-files"
+ myconf="${myconf} --with-lisp-files" #need to build info file
myconf="${myconf} --without-pdf"
myconf="${myconf} --enable-stats" #extra command save to be enabled
myconf="${myconf} --with-texdir=${TEXMF}/tex/latex/${PN}"
@@ -184,7 +184,8 @@ src_compile() {
}
src_install () {
- emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" install install-info
+ rm -rf "${D}"/usr/share/emacs #handled by use {,x}emacs below
if use xemacs; then
cd "${S}/lisp-xemacs"