aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-29 12:39:55 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-29 12:39:55 +0100
commita26637ce3fd8098a5c4b842d1eeb250129aefb59 (patch)
treed017d69005853b58e1a43d3b57ab82130d67b440
parentsci-mathematics/giac: fix SRC_URI (diff)
downloadsci-a26637ce3fd8098a5c4b842d1eeb250129aefb59.tar.gz
sci-a26637ce3fd8098a5c4b842d1eeb250129aefb59.tar.bz2
sci-a26637ce3fd8098a5c4b842d1eeb250129aefb59.zip
sci-chemistry/chimera-bin: add version 1.15
also fix the symlink to freetype and add dependency on python2_7 Closes: https://github.com/gentoo/sci/issues/1046 Closes: https://github.com/gentoo/sci/issues/1045 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-chemistry/chimera-bin/Manifest1
-rw-r--r--sci-chemistry/chimera-bin/chimera-bin-1.14.ebuild22
-rw-r--r--sci-chemistry/chimera-bin/chimera-bin-1.15.ebuild99
3 files changed, 115 insertions, 7 deletions
diff --git a/sci-chemistry/chimera-bin/Manifest b/sci-chemistry/chimera-bin/Manifest
index 349f45f29..4be9629b9 100644
--- a/sci-chemistry/chimera-bin/Manifest
+++ b/sci-chemistry/chimera-bin/Manifest
@@ -1,2 +1,3 @@
DIST chimera-1.11.2-linux_x86_64.bin 121918350 BLAKE2B 087f4e518676daa7a77a163719e2a423558a118af11240718fd00c8e2b20ee37f482fb995258bb50de797024c5c4c9845b6534508fb7f436dbe3baeda7022471 SHA512 30881c0d516ae519751361eb59815c8623996e662906a01a4c0d9bfd96da4467acaf46fd95515f40176620f676a60f04a1e1c4d14ae3e5e360d2ad7b0caa2111
DIST chimera-1.14-linux_x86_64.bin 157644313 BLAKE2B 75dba07faa5cbd76b472318a50f8dc9dbedfccd9f2ff59769cb5517639d4381f025ecfc206a6c61bd1bfe49928d3bf9076e5506db2a7b700923663399657ac46 SHA512 2309305cff892e28b89d8281231c1546212143cc347885f83544a85f776733329ba6adc7dc748cb4453e31a6eb535b57487ecd34b1c1800ff222950e92109e85
+DIST chimera-1.15-linux_x86_64.bin 154069682 BLAKE2B 802f9e1b0182bf8b6ae38057145c25f2abfd2e71a3e4b7651a73130c8e11c9aee5e7eba230c2558821a95f33c6a4619897be355ee7ce3be0d319ded88a71b63f SHA512 7c4be169f22ab9557ac89087938a52b5c3d41d0971ff52e6ecf9c7dce41126f88a2c6f626e8b5c8876fe52fe36c94c55a61b515da7e7bdde17046546e75f4b97
diff --git a/sci-chemistry/chimera-bin/chimera-bin-1.14.ebuild b/sci-chemistry/chimera-bin/chimera-bin-1.14.ebuild
index 7b00f46d5..4b277862d 100644
--- a/sci-chemistry/chimera-bin/chimera-bin-1.14.ebuild
+++ b/sci-chemistry/chimera-bin/chimera-bin-1.14.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop xdg python-any-r1
DESCRIPTION="An extensible Molecular Modelling System"
-HOMEPAGE="http://www.cgl.ucsf.edu/chimera"
+HOMEPAGE="https://www.cgl.ucsf.edu/chimera/"
SRC_URI="chimera-${PV}-linux_x86_64.bin"
SLOT="0"
@@ -42,19 +44,21 @@ RDEPEND="
x11-libs/libXrender
x11-libs/libSM
x11-libs/libXt
- x11-libs/libGLw"
+ x11-libs/libGLw
+ ${PYTHON_DEPS}
+"
S="${WORKDIR}"
-RESTRICT="fetch strip"
+RESTRICT="fetch mirror strip"
QA_PREBUILT="opt/.*"
pkg_nofetch() {
elog "Please visit"
- elog "http://www.cgl.ucsf.edu/chimera/download.html"
+ elog "https://www.cgl.ucsf.edu/chimera/download.html"
elog "or"
- elog "http://www.cgl.ucsf.edu/chimera/olddownload.html"
+ elog "https://www.cgl.ucsf.edu/chimera/olddownload.html"
elog "and download ${A} into your DISTDIR"
}
@@ -80,6 +84,10 @@ src_install() {
exeinto /opt/bin/
doexe "${T}"/chimera
+ # point the symlink to the correct location
+ rm "${ED}/opt/chimera-bin/include/ft2build.h"
+ dosym ../../../usr/include/freetype2/ft2build.h opt/chimera-bin/include/ft2build.h
+
make_desktop_entry "${EPREFIX}/opt/bin/chimera" Chimera chimeraIcon
if use prefix; then
diff --git a/sci-chemistry/chimera-bin/chimera-bin-1.15.ebuild b/sci-chemistry/chimera-bin/chimera-bin-1.15.ebuild
new file mode 100644
index 000000000..4b277862d
--- /dev/null
+++ b/sci-chemistry/chimera-bin/chimera-bin-1.15.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop xdg python-any-r1
+
+DESCRIPTION="An extensible Molecular Modelling System"
+HOMEPAGE="https://www.cgl.ucsf.edu/chimera/"
+SRC_URI="chimera-${PV}-linux_x86_64.bin"
+
+SLOT="0"
+LICENSE="chimera"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="prefix? ( dev-util/patchelf )"
+RDEPEND="
+ dev-lang/tcl
+ dev-lang/tk
+ dev-libs/expat
+ dev-libs/libotf
+ dev-libs/openssl:0
+ dev-libs/libpcre
+ sys-libs/zlib
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/ftgl
+ media-libs/libpng
+ media-libs/tiff
+ sci-libs/hdf5
+ sci-libs/xdrfile
+ sys-devel/gcc[openmp,fortran]
+ virtual/jpeg
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXrender
+ x11-libs/libSM
+ x11-libs/libXt
+ x11-libs/libGLw
+ ${PYTHON_DEPS}
+"
+
+S="${WORKDIR}"
+
+RESTRICT="fetch mirror strip"
+
+QA_PREBUILT="opt/.*"
+
+pkg_nofetch() {
+ elog "Please visit"
+ elog "https://www.cgl.ucsf.edu/chimera/download.html"
+ elog "or"
+ elog "https://www.cgl.ucsf.edu/chimera/olddownload.html"
+ elog "and download ${A} into your DISTDIR"
+}
+
+src_unpack() {
+ cp "${DISTDIR}"/${A} ${A}.zip
+ unzip ${A}.zip || die
+}
+
+src_install() {
+ chmod +x ./chimera.bin
+ dodir /opt/
+ ./chimera.bin -d foo || die
+ doicon foo/chimeraIcon.png
+ mv foo "${ED}/opt/${PN}" || die
+
+ cat >> "${T}"/chimera <<- EOF
+ #!${EPREFX}/bin/bash
+
+ export PATH="${EPREFIX}/opt/${PN}/bin:\${PATH}"
+ "${EPREFIX}/opt/${PN}/bin/chimera" \$@
+ EOF
+
+ exeinto /opt/bin/
+ doexe "${T}"/chimera
+
+ # point the symlink to the correct location
+ rm "${ED}/opt/chimera-bin/include/ft2build.h"
+ dosym ../../../usr/include/freetype2/ft2build.h opt/chimera-bin/include/ft2build.h
+
+ make_desktop_entry "${EPREFIX}/opt/bin/chimera" Chimera chimeraIcon
+
+ if use prefix; then
+ local i
+ for i in "${ED}"/opt/${PN}/bin/{tiffcp,povray,al2co} "${ED}"/opt/${PN}/lib/*.so; do
+ patchelf --set-rpath "${EPREFIX}/usr/lib:${EPREFIX}/opt/${PN}/lib" "${i}" || die
+ done
+ fi
+}