aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2010-07-05 19:36:12 +0200
committerKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2010-07-05 19:36:12 +0200
commita28f58427788070c6b7e14b11c535d4920a64972 (patch)
treeb5685b55ea2ad3f59694e43c7068fb9e71242f2d
parentnew package: sci-libs/omalloc (diff)
downloadsci-a28f58427788070c6b7e14b11c535d4920a64972.tar.gz
sci-a28f58427788070c6b7e14b11c535d4920a64972.tar.bz2
sci-a28f58427788070c6b7e14b11c535d4920a64972.zip
[sci-libs/omalloc]: Cleanup
-rw-r--r--sci-libs/omalloc/Manifest2
-rw-r--r--sci-libs/omalloc/omalloc-0.9.6.ebuild26
2 files changed, 9 insertions, 19 deletions
diff --git a/sci-libs/omalloc/Manifest b/sci-libs/omalloc/Manifest
index 4a5a6b13c..3638af7aa 100644
--- a/sci-libs/omalloc/Manifest
+++ b/sci-libs/omalloc/Manifest
@@ -1,5 +1,5 @@
AUX parallel-build.patch 900 RMD160 1236c0c03b5209d782edf33bde30e10cefb71636 SHA1 f8aef60f60b890a63680d0276bce03b7070ba19d SHA256 f48cf0af887189c4a427e1b65d4b13962e11987b57d6b82eee06e85f85828f3e
DIST Singular-3-1-1-2.tar.gz 19397418 RMD160 205671f1ea2e2f22c025defc3d85c762362c7e3f SHA1 217af7a4e9b36b769a145bf81fb27c49d64333f6 SHA256 4e5929b324f952c69de1dedddbeca1c51a3733a0f63e026d3e7b61a7e469d5a7
-EBUILD omalloc-0.9.6.ebuild 1105 RMD160 a078b3ad2bcebd92bea032fe55ad93b813544d95 SHA1 eb2a19cbc8e5196de02b68a81d2b7fb5f0e8e16a SHA256 e950d6ce700be8eb5e1eaed99b07ad19bf0e39e035e3ac1d729f2586a1352a79
+EBUILD omalloc-0.9.6.ebuild 944 RMD160 9c2a7cdd8a5bd2699853f0153558973e092bca9f SHA1 920ad2f3cc5a136ddbae8913fb8273810d5baa7e SHA256 67ab37b20855a082564357ba996747418aa5838b1ef31fe84d2ed925beff3ea7
MISC ChangeLog 338 RMD160 d6d79c71e8600dc48e6b8313a15ab0c024cd3664 SHA1 0b926d5660b30c7565e7a96f85a68fcb542b87a6 SHA256 2c437a9acae1947ae11c9ecec0103c96a29f3382e67b6eb242fb99e618e438d5
MISC metadata.xml 330 RMD160 c8055f309c938468c7c0af9279c734fe40c7ac0d SHA1 2f4244a2e40645277e94692be694f5feac2c2c6c SHA256 802e41cbccd2d4b549736141e341590687775e678bf3ace3524027ff5beed136
diff --git a/sci-libs/omalloc/omalloc-0.9.6.ebuild b/sci-libs/omalloc/omalloc-0.9.6.ebuild
index 103e92aac..a25d7c14d 100644
--- a/sci-libs/omalloc/omalloc-0.9.6.ebuild
+++ b/sci-libs/omalloc/omalloc-0.9.6.ebuild
@@ -4,7 +4,7 @@
EAPI="2"
-inherit eutils elisp-common autotools versionator
+inherit eutils versionator toolchain-funcs
Sing_PV=$(replace_all_version_separators -)
Sing_DIR=$(get_version_component_range 1-3 ${MY_PV})
@@ -20,32 +20,22 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND=""
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}"/Singular-3-1-1/omalloc
+S=${WORKDIR}/Singular-3-1-1/omalloc
# Until tarballs are mirrored:
RESTRICT="mirror"
-src_prepare (){
- epatch "${FILESDIR}"/parallel-build.patch
+pkg_setup() {
+ tc-export CC CXX
}
-src_configure() {
- # Taking care of ${CC} and friends.
- tc-export CC CPP CXX
- econf --prefix="${D}"/usr
-}
-
-src_compile () {
- emake || die "make failed"
+src_prepare (){
+ epatch "${FILESDIR}"/parallel-build.patch
}
src_install () {
- emake DESTDIR="$D" install || die "install failed"
+ emake DESTDIR="${D}" install || die "install failed"
# dolib.a *.a
# insinto /usr/include
# doins omalloc.h omalloc.c mylimits.h
- }
+}