aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2010-08-03 13:32:34 +0200
committerKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2010-08-03 13:32:34 +0200
commita547aafe956d9c6e7c001eee7938a755aca95b76 (patch)
tree8ff325c894bee258e692ef621c1d55f8ce0b2814
parent[sci-chemistry/gromacs] Version bump + new manual (diff)
downloadsci-a547aafe956d9c6e7c001eee7938a755aca95b76.tar.gz
sci-a547aafe956d9c6e7c001eee7938a755aca95b76.tar.bz2
sci-a547aafe956d9c6e7c001eee7938a755aca95b76.zip
[dev-python/cosmolopy] Initial import
-rw-r--r--dev-python/cosmolopy/ChangeLog11
-rw-r--r--dev-python/cosmolopy/Manifest5
-rw-r--r--dev-python/cosmolopy/cosmolopy-0.1.001.ebuild48
-rw-r--r--dev-python/cosmolopy/files/cosmolopy-0.1.001-qa.patch10
-rw-r--r--dev-python/cosmolopy/metadata.xml9
5 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/cosmolopy/ChangeLog b/dev-python/cosmolopy/ChangeLog
new file mode 100644
index 000000000..b9d206e34
--- /dev/null
+++ b/dev-python/cosmolopy/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/cosmolopy
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*cosmolopy-0.1.001 (03 Aug 2010)
+
+ 03 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +cosmolopy-0.1.001.ebuild, +files/cosmolopy-0.1.001-qa.patch,
+ +metadata.xml:
+ Initial import
+
diff --git a/dev-python/cosmolopy/Manifest b/dev-python/cosmolopy/Manifest
new file mode 100644
index 000000000..513a51781
--- /dev/null
+++ b/dev-python/cosmolopy/Manifest
@@ -0,0 +1,5 @@
+AUX cosmolopy-0.1.001-qa.patch 214 RMD160 eef9db724ec5d8acfb2037851cf58dffc995c791 SHA1 fdf03ae8e89e8ed7b8777ec99dc447e0fe6fe2d6 SHA256 3206823e126d25460d218786ce0fece09933d4a61bd7a27b0cec959754562b0c
+DIST CosmoloPy-0.1.001.tar.gz 833125 RMD160 9b40f118d17c448a554f29d1a2d2e04dddcc63df SHA1 4dabf64a5b21aae85faaa2772ae23ab8d4755afa SHA256 fa403d10ac18fb5b6766fb2f29373a5901aa3fcf2a028218e96a812ad6672b90
+EBUILD cosmolopy-0.1.001.ebuild 984 RMD160 22720d40bdbf6329e30a7b0961e36d77b6b3d5a4 SHA1 5cbf8c411f04eeae6cdf531c7e7728840136346e SHA256 b07bbcff585baaf878dea937432fdaee3b69080865de611ca8094a475a317290
+MISC ChangeLog 308 RMD160 8506ebbcbbc4c22ca32237559d403af5271e9946 SHA1 be75ad2c02d4925f08dabf20b38bde61f3be6b90 SHA256 076beb1b08e8bad12cafa33b7f4f2205812668ea43f8e4d240f0b4ca62b4f640
+MISC metadata.xml 291 RMD160 e19cf9719dd6cf55b8e98a1d2864741b4a9c6750 SHA1 f45485ec8094bf322f111d06aa7e3691eeb0ed18 SHA256 8b76631f33b4c4c91f51dc677621fe27b872f35975508fb97211a92fe7996240
diff --git a/dev-python/cosmolopy/cosmolopy-0.1.001.ebuild b/dev-python/cosmolopy/cosmolopy-0.1.001.ebuild
new file mode 100644
index 000000000..2a0132a88
--- /dev/null
+++ b/dev-python/cosmolopy/cosmolopy-0.1.001.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+MY_PN=CosmoloPy
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Cosmology routines built on NumPy/SciPy"
+HOMEPAGE="http://roban.github.com/CosmoloPy/ http://pypi.python.org/pypi/CosmoloPy"
+SRC_URI="http://github.com/roban/${MY_PN}/tarball/${PV} -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+#IUSE="test"
+
+DEPEND="dev-python/nose
+ dev-lang/swig"
+# Mostly plots in matplotlib
+# test? (
+# sci-libs/scipy
+# dev-python/matplotlib
+# )"
+RDEPEND="sci-libs/scipy"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+# http://github.com/roban/CosmoloPy/issues#issue/2
+S=${WORKDIR}/roban-${MY_PN}-b9c582f
+
+src_prepare() {
+ # http://github.com/roban/CosmoloPy/issues#issue/1
+ epatch "${FILESDIR}"/${P}-qa.patch
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r www/*
+}
diff --git a/dev-python/cosmolopy/files/cosmolopy-0.1.001-qa.patch b/dev-python/cosmolopy/files/cosmolopy-0.1.001-qa.patch
new file mode 100644
index 000000000..68935c475
--- /dev/null
+++ b/dev-python/cosmolopy/files/cosmolopy-0.1.001-qa.patch
@@ -0,0 +1,10 @@
+--- cosmolopy/EH/power.c
++++ cosmolopy/EH/power.c
+@@ -43,6 +43,7 @@
+
+ #include <math.h>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ /* Convenience from Numerical Recipes in C, 2nd edition */
+ static float sqrarg;
diff --git a/dev-python/cosmolopy/metadata.xml b/dev-python/cosmolopy/metadata.xml
new file mode 100644
index 000000000..3530ee915
--- /dev/null
+++ b/dev-python/cosmolopy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<herd>sci</herd>
+<longdescription lang="en">
+ CosmoloPy is a package of cosmology routines built on NumPy/SciPy.
+</longdescription>
+</pkgmetadata>