aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-04 16:06:45 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-04 16:06:45 +0100
commita61033300fd8848a1a2d0acd711408fd8daa0bb3 (patch)
tree52c7fd3f5fa0420747eb207b1b50b9ef0d933d98
parentpackage.mask: mask libcgnsoo for removal (diff)
downloadsci-a61033300fd8848a1a2d0acd711408fd8daa0bb3.tar.gz
sci-a61033300fd8848a1a2d0acd711408fd8daa0bb3.tar.bz2
sci-a61033300fd8848a1a2d0acd711408fd8daa0bb3.zip
sci-libs/libStatGen: version bump 1.0.15
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-libs/libStatGen/Manifest1
-rw-r--r--sci-libs/libStatGen/libStatGen-1.0.15.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-libs/libStatGen/Manifest b/sci-libs/libStatGen/Manifest
index 8f3385c86..aac41869d 100644
--- a/sci-libs/libStatGen/Manifest
+++ b/sci-libs/libStatGen/Manifest
@@ -1,2 +1,3 @@
DIST libStatGen-1.0.13.tar.gz 558682 BLAKE2B 8e9308c698110e2e3a735e14171954c2bf1e7ac7f05d6c86072389aa697246d69033a0844f4bfccce1dc74623e847c551e388e19b00469274d5ef945e080811c SHA512 bcce3dd2f343e5941857d5bca0f2960d69b3e1083da6312e018a96bb92fb8dbc91ac511e062b024720c45508aa805d3f4f6511f60201438176a898ab789e746f
DIST libStatGen-1.0.14.tar.gz 558924 BLAKE2B 0216caaf114574c35fd4458795e21a53f25e9f24905320d5cc161b226575bd8a6d80b1ced765ea9f03205bdd0d0740a3dd398185440775a07ee9cbf0690428a6 SHA512 c7a1d4d56803b7ca741961a77dc8419277f01e8c683c8f5d494f3af242a2b5075462179b14601a41842a1624017c812a754f912a622dc1af3f5e4b1dc4722508
+DIST libStatGen-1.0.15.tar.gz 560812 BLAKE2B 332581c45fc45f915d8b63156e10504d4146b1b8bc009eab4a781046ca72f5cea718be634060ab5796904470902dcb525f5509042d7f2b872b2d6590e8f13a64 SHA512 1f28c9c1f2ce09ea924ec4d784192cf7588554773fbf5b365bb9fa775c73cda316883dc3165b7e116adc1c630366b6c38a090db4d2410035dad075fa05b89d3a
diff --git a/sci-libs/libStatGen/libStatGen-1.0.15.ebuild b/sci-libs/libStatGen/libStatGen-1.0.15.ebuild
new file mode 100644
index 000000000..fba3dde57
--- /dev/null
+++ b/sci-libs/libStatGen/libStatGen-1.0.15.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="media-gfx/graphviz"
+
+inherit docs
+
+DESCRIPTION="Set of classes for creating statistical genetic programs"
+HOMEPAGE="https://github.com/statgen/libStatGen"
+SRC_URI="https://github.com/statgen/libStatGen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/openssl:0="
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install(){
+ default
+ dolib.a libStatGen.a # package only makes a static library
+}