aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-03-31 23:50:48 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-03-31 23:50:48 +0200
commitabdbf833db72c259f2585a30c592815575d4bd21 (patch)
treef9ca49053b06558a61867cee6a6a58e659d677c0
parentsci-biology/plinkseq: we cannot zap bundled mongoose so easily (diff)
downloadsci-abdbf833db72c259f2585a30c592815575d4bd21.tar.gz
sci-abdbf833db72c259f2585a30c592815575d4bd21.tar.bz2
sci-abdbf833db72c259f2585a30c592815575d4bd21.zip
sci-libs/lib2bit: improve ebuild to respect into /usr
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--sci-libs/lib2bit/files/lib2bit-0.2.1_respect_DESTDIR.patch2
-rw-r--r--sci-libs/lib2bit/lib2bit-0.2.1.ebuild13
2 files changed, 11 insertions, 4 deletions
diff --git a/sci-libs/lib2bit/files/lib2bit-0.2.1_respect_DESTDIR.patch b/sci-libs/lib2bit/files/lib2bit-0.2.1_respect_DESTDIR.patch
index cc0cbd536..0f64b325f 100644
--- a/sci-libs/lib2bit/files/lib2bit-0.2.1_respect_DESTDIR.patch
+++ b/sci-libs/lib2bit/files/lib2bit-0.2.1_respect_DESTDIR.patch
@@ -5,7 +5,7 @@
INCLUDES =
-prefix = /usr/local
-+prefix = ${DESTDIR}/usr/local
++prefix = $(DESTDIR)/usr/local
includedir = $(prefix)/include
libdir = $(exec_prefix)/lib
diff --git a/sci-libs/lib2bit/lib2bit-0.2.1.ebuild b/sci-libs/lib2bit/lib2bit-0.2.1.ebuild
index a2029767d..c547dcca9 100644
--- a/sci-libs/lib2bit/lib2bit-0.2.1.ebuild
+++ b/sci-libs/lib2bit/lib2bit-0.2.1.ebuild
@@ -1,6 +1,5 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
EAPI=6
@@ -13,12 +12,20 @@ SRC_URI="https://github.com/dpryan79/lib2bit/archive/0.2.1.tar.gz -> ${P}.tar.gz
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="static"
DEPEND=""
RDEPEND="${DEPEND}"
src_prepare(){
- epatch "${FILESDIR}"/${P}_respect_DESTDIR.patch
default
+ epatch "${FILESDIR}"/${P}_respect_DESTDIR.patch
+ sed -e 's#/usr/local#/usr#' -i Makefile || die
+}
+
+src_install(){
+ emake DESTDIR="${ED}" install
+ if not use static; then
+ rm "${ED}"/usr/lib/lib2bit.a || die
+ fi
}