aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gmail.com>2009-01-21 13:56:52 -0500
committerJustin Bronder <jsbronder@gmail.com>2009-01-21 13:56:52 -0500
commitad80624ccc8989f9bd91128c5184ad84be8d8121 (patch)
treee2db4018c964622698dcaa31597e20bfbbe37463
parentsys-cluster/mpich-1.0.8 bugfixes, no revbump. Fix some doc file locations (#... (diff)
parentfix typo (diff)
downloadsci-ad80624ccc8989f9bd91128c5184ad84be8d8121.tar.gz
sci-ad80624ccc8989f9bd91128c5184ad84be8d8121.tar.bz2
sci-ad80624ccc8989f9bd91128c5184ad84be8d8121.zip
Merge branch 'master' of git+ssh://git@git.overlays.gentoo.org/proj/sci
-rw-r--r--eclass/openib.eclass31
-rw-r--r--profiles/package.mask32
-rw-r--r--sci-misc/boinc-bin/ChangeLog15
-rw-r--r--sci-misc/boinc-bin/Manifest10
-rw-r--r--sci-misc/boinc-bin/boinc-bin-6.4.5.ebuild129
-rw-r--r--sci-misc/boinc-bin/boinc-bin-6.5.0.ebuild129
-rw-r--r--sci-misc/boinc-bin/files/boinc.conf28
-rw-r--r--sci-misc/boinc-bin/files/boinc.init98
-rw-r--r--sci-misc/boinc-bin/metadata.xml9
-rw-r--r--sys-cluster/openmpi/Manifest2
-rw-r--r--sys-cluster/openmpi/openmpi-1.3.ebuild3
11 files changed, 483 insertions, 3 deletions
diff --git a/eclass/openib.eclass b/eclass/openib.eclass
new file mode 100644
index 000000000..714874c24
--- /dev/null
+++ b/eclass/openib.eclass
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+#
+# Original Author: Alexey Shvetsov <alexxy@gentoo.org>
+# Purpose: Simplify working with OFED packages
+#
+
+HOMEPAGE="http://www.openfabrics.org/"
+LICENSE="|| ( GPL-2 BSD-2 )"
+SLOT="0"
+
+inherit rpm eutils
+
+case ${OFED_VER} in
+ 1.4*)
+ SRC_URI="http://www.openfabrics.org/downloads/OFED/ofed-1.4/OFED-1.4.tgz"
+ ;;
+esac
+
+EXPORT_FUNCTIONS src_unpack
+
+# @FUNCTION: openib_src_unpack
+# @DESCRIPTION:
+# This function will unpack OFED packages
+openib_src_unpack() {
+ unpack ${A}
+ rpm_unpack "OFED-${OFED_VER}/SRPMS/${P}-${ofs}.rpm"
+ unpack ./${P}.tar.gz
+}
diff --git a/profiles/package.mask b/profiles/package.mask
new file mode 100644
index 000000000..56b672d8d
--- /dev/null
+++ b/profiles/package.mask
@@ -0,0 +1,32 @@
+####################################################################
+#
+# When you add an entry to the top of this file, add your name, the date, and
+# an explanation of why something is getting masked. Please be extremely
+# careful not to commit atoms that are not valid, as it can cause large-scale
+# breakage, especially if it ends up in the daily snapshot.
+#
+## Example:
+##
+## # Dev E. Loper <developer@gentoo.org> (28 Jun 2012)
+## # Masking these versions until we can get the
+## # v4l stuff to work properly again
+## =media-video/mplayer-0.90_pre5
+## =media-video/mplayer-0.90_pre5-r1
+#
+# - Best last rites (removal) practices -
+# Include the following info:
+# a) reason for masking
+# b) bug # for the removal (and yes you should have one)
+# c) date of removal (either the date or "in x days")
+# d) the word "removal"
+#
+## Example:
+##
+## Dev E. Loper <developer@gentoo.org> (25 Jan 2012)
+## Masked for removal in 30 days. Doesn't work
+## with new libfoo. Upstream dead, gtk-1, smells
+## funny. (bug #987654)
+## app-misc/some-package
+
+#--- END OF EXAMPLES ---
+
diff --git a/sci-misc/boinc-bin/ChangeLog b/sci-misc/boinc-bin/ChangeLog
new file mode 100644
index 000000000..6d1ca4290
--- /dev/null
+++ b/sci-misc/boinc-bin/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for sci-misc/boinc-bin
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*boinc-bin-6.4.5 (21 Jan 2009)
+
+ 21 Jan 2009; Tomas Chvatal <scarabeus@gentoo.org> +boinc-bin-6.5.0.ebuild:
+ Add normal binary release
+
+*boinc-bin-6.5.0 (21 Jan 2009)
+
+ 21 Jan 2009; Tomas Chvatal <scarabeus@gentoo.org> +files/boinc.conf,
+ +files/boinc.init, +metadata.xml, +boinc-bin-6.5.0.ebuild:
+ Add binary prerelease.
+
diff --git a/sci-misc/boinc-bin/Manifest b/sci-misc/boinc-bin/Manifest
new file mode 100644
index 000000000..e63d3bd14
--- /dev/null
+++ b/sci-misc/boinc-bin/Manifest
@@ -0,0 +1,10 @@
+AUX boinc.conf 711 RMD160 b6bb25b9d10cbefd3de5d653e701e056e2de4587 SHA1 570929cb4ed50d4fc4408624c4d0d330e208609c SHA256 032f07145ee230f069ffdc93befe90c047fba4314aedfc8024bdb44c06798e9e
+AUX boinc.init 2374 RMD160 34f304516481edc256c75d2404cb3d40d5cd9149 SHA1 3df001527051fab45b052dc62973f2ccb5606dd9 SHA256 f4952e273fee1416cbad8ec49503725df9ce80d59192e3c919e645b1d76b75f8
+DIST boinc_6.4.5_i686-pc-linux-gnu.sh 4371490 RMD160 cb7687c806f8eb2d2ed974908048be1a057524ec SHA1 32eab0dfd0abcad56d2a4bbbf6a53ac8673a7e8d SHA256 b45884ee6b1f7c1299345f3db06dd368264d0af18d0361d6925eda6688e60778
+DIST boinc_6.4.5_x86_64-pc-linux-gnu.sh 4575051 RMD160 992df581e95d847a36f50bf2595862f53fb712ad SHA1 8ba3ae6e62485f61d0bdeae9aa161d2c1c827b79 SHA256 3471710ff8c25f2c1788f18bbdab057c8a762847862058962bb809b7cdf2fd7d
+DIST boinc_6.5.0_i686-pc-linux-gnu.sh 4316989 RMD160 6cc83e70f8c4e93aa172fa0c466ac57a40e8a8ca SHA1 0be2d32a894f92f9103f2d2137b3b08c077f1d27 SHA256 baf6aa638d7043f030b7779a73865465476fa7f85ee38b6118371b13522d2aa4
+DIST boinc_6.5.0_x86_64-pc-linux-gnu.sh 4508531 RMD160 51105fa10b9bd0902e43059567ebe74ad9f3e457 SHA1 25c17f60c399c45e3f09333f640c9900f6621af6 SHA256 18a0dc70bb561f8dbfd1b79fb8aa5b5352a04d8428db1d4e539a94ebf1fac7f3
+EBUILD boinc-bin-6.4.5.ebuild 3589 RMD160 d1a65bbb30a454f4ec4139e3491f3ef6201a8ff1 SHA1 2b4e87530938a5be6ededb076270ca968dcce2f0 SHA256 663180661db307023c647b85e1837cb315f3395facfd128ca17f35059095b578
+EBUILD boinc-bin-6.5.0.ebuild 3589 RMD160 d1a65bbb30a454f4ec4139e3491f3ef6201a8ff1 SHA1 2b4e87530938a5be6ededb076270ca968dcce2f0 SHA256 663180661db307023c647b85e1837cb315f3395facfd128ca17f35059095b578
+MISC ChangeLog 447 RMD160 900aad404fa8e1b4b35c004101b9c88f4f00d7a1 SHA1 f46c2b2ba4b9a5c97eac1a5d6021e011d144bb9f SHA256 aa6cd5ad442ac76abec472965099cafb1d3be361688854b51cfff7948762082f
+MISC metadata.xml 250 RMD160 5bf897b41e46e6c42952eebb58c4857207ea43b2 SHA1 09fb670253158d6b85c1dd75da137c02c814cbc4 SHA256 58a285ae4d3dcbc187c68a22ce84ca0b8e23ea78616f5a11cfebf4d928773977
diff --git a/sci-misc/boinc-bin/boinc-bin-6.4.5.ebuild b/sci-misc/boinc-bin/boinc-bin-6.4.5.ebuild
new file mode 100644
index 000000000..163e165a6
--- /dev/null
+++ b/sci-misc/boinc-bin/boinc-bin-6.4.5.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+#
+# Don't forget to keep things in files dir in sync with normal boinc package!
+#
+
+EAPI="2"
+
+inherit eutils
+
+MY_PN="${PN//-bin/}"
+MY_PV="${PV//./_}"
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="
+ amd64? ( http://${MY_PN}dl.ssl.berkeley.edu/dl/${MY_PN}_${PV}_x86_64-pc-linux-gnu.sh )
+ x86? ( http://${MY_PN}dl.ssl.berkeley.edu/dl/${MY_PN}_${PV}_i686-pc-linux-gnu.sh )
+ "
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ !sci-misc/boinc
+ >=dev-libs/openssl-0.9.7
+ >=net-misc/curl-7.15.5
+ sys-apps/util-linux
+ sys-libs/zlib
+ X? ( x11-libs/wxGTK:2.8 )
+ "
+DEPEND="${RDEPEND}
+ app-misc/ca-certificates
+ X? (
+ media-libs/freeglut
+ media-libs/jpeg
+ media-libs/mesa
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-proto/xproto
+ )
+ "
+
+S="${WORKDIR}"/BOINC
+
+LANGS="ar be bg ca cs da de el en_US es eu fi fr hr hu it ja lt lv nb nl pl pt
+pt_BR ro ru sk sl sv_SE tr uk zh_CN zh_TW"
+for LNG in ${LANGS}; do
+ IUSE="${IUSE} linguas_${LNG}"
+done
+
+src_unpack() {
+ local target
+ use x86 && target="i686" || target="x86_64"
+ cp "${DISTDIR}"/${MY_PN}_${PV}_${target}-pc-linux-gnu.sh "${WORKDIR}"
+ cd "${WORKDIR}"
+ sh ${MY_PN}_${PV}_${target}-pc-linux-gnu.sh
+ # patch up certificates
+ mkdir "${S}"/curl/
+ ln -s /etc/ssl/certs/ca-certificates.crt "${S}"/curl/ca-bundle.crt
+}
+
+src_install() {
+ dodir /var/lib/${MY_PN}
+ newinitd "${FILESDIR}"/${MY_PN}.init ${MY_PN}
+ newconfd "${FILESDIR}"/${MY_PN}.conf ${MY_PN}
+ # fix ${PN}.conf file for binary package
+ sed -i \
+ -e "s:/usr/bin/${MY_PN}_client:/opt/${MY_PN}/${MY_PN}:g" \
+ "${D}"/etc/conf.d/${MY_PN} || die "sed failed"
+ if use X; then
+ # icon
+ newicon "${S}"/${MY_PN}mgr.48x48.png ${MY_PN}.png
+ # desktop
+ make_desktop_entry /opt/${MY_PN}/run_manager "${MY_PN}" ${MY_PN} "Education;Science" /var/lib/${MY_PN}
+ fi
+ # use correct path in scripts
+ sed -i \
+ -e "s:${S}:/var/lib/${MY_PN}:g" \
+ -e "s:./${MY_PN}:/opt/${MY_PN}/${MY_PN}:g" \
+ run_client || die "sed run_client failed"
+ sed -i \
+ -e "s:${S}:/var/lib/${MY_PN}:g" \
+ -e "s:./${MY_PN}mgr:/opt/${MY_PN}/${MY_PN}mgr:g" \
+ run_manager || die "sed run_manager failed"
+ # install binaries
+ exeopts -m0755
+ exeinto /opt/${MY_PN}
+
+ doexe "${S}"/{${MY_PN},${MY_PN}cmd,${MY_PN}mgr,run_client,run_manager}
+ fowners 0:${MY_PN} /opt/${MY_PN}/{${MY_PN},${MY_PN}cmd,${MY_PN}mgr,run_client,run_manager}
+ # locale
+ mkdir -p "${D}"/opt/${MY_PN}/locale
+ insopts -m0644
+ insinto /opt/${MY_PN}/locale
+ cd "${S}"/locale/
+ for LNG in ${LINGUAS}; do
+ doins -r "${LNG}"
+ done
+ dosym /opt/${MY_PN}/locale /var/lib/${MY_PN}/locale
+ cd "${S}"
+ dosym /etc/ssl/certs/ca-certificates.crt /var/lib/${MY_PN}/ca-bundle.crt
+}
+
+pkg_preinst() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "You are using the binary distributed version."
+ elog "The manager can be found at /opt/${MY_PN}/run_manager"
+ echo
+ elog "You need to attach to a project to do anything useful with ${MY_PN}."
+ elog "You can do this by running /etc/init.d/${MY_PN} attach"
+ elog "${MY_PN} The howto for configuration is located at:"
+ elog "http://${MY_PN}.berkeley.edu/anonymous_platform.php"
+ echo
+ # Add warning about the new password for the client, bug 121896.
+ elog "If you need to use the graphical client the password is in"
+ elog "/var/lib/${MY_PN}/gui_rpc_auth.cfg"
+ elog "You should change this to something more memorable (can be blank)."
+ echo
+}
diff --git a/sci-misc/boinc-bin/boinc-bin-6.5.0.ebuild b/sci-misc/boinc-bin/boinc-bin-6.5.0.ebuild
new file mode 100644
index 000000000..163e165a6
--- /dev/null
+++ b/sci-misc/boinc-bin/boinc-bin-6.5.0.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+#
+# Don't forget to keep things in files dir in sync with normal boinc package!
+#
+
+EAPI="2"
+
+inherit eutils
+
+MY_PN="${PN//-bin/}"
+MY_PV="${PV//./_}"
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="
+ amd64? ( http://${MY_PN}dl.ssl.berkeley.edu/dl/${MY_PN}_${PV}_x86_64-pc-linux-gnu.sh )
+ x86? ( http://${MY_PN}dl.ssl.berkeley.edu/dl/${MY_PN}_${PV}_i686-pc-linux-gnu.sh )
+ "
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ !sci-misc/boinc
+ >=dev-libs/openssl-0.9.7
+ >=net-misc/curl-7.15.5
+ sys-apps/util-linux
+ sys-libs/zlib
+ X? ( x11-libs/wxGTK:2.8 )
+ "
+DEPEND="${RDEPEND}
+ app-misc/ca-certificates
+ X? (
+ media-libs/freeglut
+ media-libs/jpeg
+ media-libs/mesa
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-proto/xproto
+ )
+ "
+
+S="${WORKDIR}"/BOINC
+
+LANGS="ar be bg ca cs da de el en_US es eu fi fr hr hu it ja lt lv nb nl pl pt
+pt_BR ro ru sk sl sv_SE tr uk zh_CN zh_TW"
+for LNG in ${LANGS}; do
+ IUSE="${IUSE} linguas_${LNG}"
+done
+
+src_unpack() {
+ local target
+ use x86 && target="i686" || target="x86_64"
+ cp "${DISTDIR}"/${MY_PN}_${PV}_${target}-pc-linux-gnu.sh "${WORKDIR}"
+ cd "${WORKDIR}"
+ sh ${MY_PN}_${PV}_${target}-pc-linux-gnu.sh
+ # patch up certificates
+ mkdir "${S}"/curl/
+ ln -s /etc/ssl/certs/ca-certificates.crt "${S}"/curl/ca-bundle.crt
+}
+
+src_install() {
+ dodir /var/lib/${MY_PN}
+ newinitd "${FILESDIR}"/${MY_PN}.init ${MY_PN}
+ newconfd "${FILESDIR}"/${MY_PN}.conf ${MY_PN}
+ # fix ${PN}.conf file for binary package
+ sed -i \
+ -e "s:/usr/bin/${MY_PN}_client:/opt/${MY_PN}/${MY_PN}:g" \
+ "${D}"/etc/conf.d/${MY_PN} || die "sed failed"
+ if use X; then
+ # icon
+ newicon "${S}"/${MY_PN}mgr.48x48.png ${MY_PN}.png
+ # desktop
+ make_desktop_entry /opt/${MY_PN}/run_manager "${MY_PN}" ${MY_PN} "Education;Science" /var/lib/${MY_PN}
+ fi
+ # use correct path in scripts
+ sed -i \
+ -e "s:${S}:/var/lib/${MY_PN}:g" \
+ -e "s:./${MY_PN}:/opt/${MY_PN}/${MY_PN}:g" \
+ run_client || die "sed run_client failed"
+ sed -i \
+ -e "s:${S}:/var/lib/${MY_PN}:g" \
+ -e "s:./${MY_PN}mgr:/opt/${MY_PN}/${MY_PN}mgr:g" \
+ run_manager || die "sed run_manager failed"
+ # install binaries
+ exeopts -m0755
+ exeinto /opt/${MY_PN}
+
+ doexe "${S}"/{${MY_PN},${MY_PN}cmd,${MY_PN}mgr,run_client,run_manager}
+ fowners 0:${MY_PN} /opt/${MY_PN}/{${MY_PN},${MY_PN}cmd,${MY_PN}mgr,run_client,run_manager}
+ # locale
+ mkdir -p "${D}"/opt/${MY_PN}/locale
+ insopts -m0644
+ insinto /opt/${MY_PN}/locale
+ cd "${S}"/locale/
+ for LNG in ${LINGUAS}; do
+ doins -r "${LNG}"
+ done
+ dosym /opt/${MY_PN}/locale /var/lib/${MY_PN}/locale
+ cd "${S}"
+ dosym /etc/ssl/certs/ca-certificates.crt /var/lib/${MY_PN}/ca-bundle.crt
+}
+
+pkg_preinst() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "You are using the binary distributed version."
+ elog "The manager can be found at /opt/${MY_PN}/run_manager"
+ echo
+ elog "You need to attach to a project to do anything useful with ${MY_PN}."
+ elog "You can do this by running /etc/init.d/${MY_PN} attach"
+ elog "${MY_PN} The howto for configuration is located at:"
+ elog "http://${MY_PN}.berkeley.edu/anonymous_platform.php"
+ echo
+ # Add warning about the new password for the client, bug 121896.
+ elog "If you need to use the graphical client the password is in"
+ elog "/var/lib/${MY_PN}/gui_rpc_auth.cfg"
+ elog "You should change this to something more memorable (can be blank)."
+ echo
+}
diff --git a/sci-misc/boinc-bin/files/boinc.conf b/sci-misc/boinc-bin/files/boinc.conf
new file mode 100644
index 000000000..223b160b4
--- /dev/null
+++ b/sci-misc/boinc-bin/files/boinc.conf
@@ -0,0 +1,28 @@
+# Config file for /etc/init.d/boinc
+
+# Owner of BOINC process (must be existing)
+USER="boinc"
+GROUP="boinc"
+
+# Directory with runtime data: Work units, project binaries, user info etc.
+RUNTIMEDIR="/var/lib/boinc"
+
+# Location of the boinc command line binary
+BOINCBIN="/usr/bin/boinc_client"
+
+# Logfile (/dev/null for nowhere)
+LOGFILE="/var/log/boinc.log"
+
+# Allow remote gui RPC yes or no
+ALLOW_REMOTE_RPC="no"
+
+# nice level
+NICELEVEL="19"
+
+# scheduling parameters, arguments to chrt(1)
+SCHED_PARAM="--batch 0"
+
+# Relative CPU allocation for boinc user, default is 1024,
+# requires CONFIG_FAIR_GROUP_SCHED and CONFIG_USER_SCHED,
+# see /usr/src/linux/Documentation/scheduler/sched-design-CFS.txt
+CPU_SHARE="128"
diff --git a/sci-misc/boinc-bin/files/boinc.init b/sci-misc/boinc-bin/files/boinc.init
new file mode 100644
index 000000000..0c769f955
--- /dev/null
+++ b/sci-misc/boinc-bin/files/boinc.init
@@ -0,0 +1,98 @@
+#!/sbin/runscript
+
+opts="${opts} attach"
+
+depend() {
+ use dns
+ need net
+}
+
+start() {
+ ebegin "Starting BOINC"
+ if [ ! -d ${RUNTIMEDIR} ]; then
+ einfo "Directory ${RUNTIMEDIR} not existing, creating now."
+ /bin/mkdir ${RUNTIMEDIR}
+ /bin/chown ${USER}:${GROUP} ${RUNTIMEDIR}
+ if [ ! -d ${RUNTIMEDIR} ]; then
+ eerror "Directory ${RUNTIMEDIR} could not be created!"
+ return 1
+ fi
+ fi
+
+ cd ${RUNTIMEDIR}
+
+ if [ ! -f lockfile ]; then
+ einfo "File ${RUNTIMEDIR}/lockfile does not exist, assuming first run."
+ einfo "You need to setup an account on the BOINC project homepage beforehand! Go to http://boinc.berkeley.edu/ and locate your project."
+ einfo "Then either run /etc/init.d/boinc attach or connect with a gui client and attach to a project with that."
+ fi
+
+ # if the log file doesn't exist, create it with root privs, then change ownership to boinc
+ if [ ! -f ${LOGFILE} ]; then
+ touch ${LOGFILE}
+ chown ${USER}:${GROUP} ${LOGFILE}
+ else
+ mv ${LOGFILE} ${LOGFILE}.old
+ touch ${LOGFILE}
+ chown ${USER}:${GROUP} ${LOGFILE}
+ fi
+
+ if [ ${ALLOW_REMOTE_RPC} = "yes" ]; then
+ ARGS="${ARGS} -allow_remote_gui_rpc"
+ fi
+
+ # sys-apps/util-linux
+ CHRT="/usr/bin/chrt ${SCHED_PARAM}"
+
+ ${CHRT} start-stop-daemon \
+ --quiet --start --chdir ${RUNTIMEDIR} \
+ --exec ${BOINCBIN} --chuid ${USER}:${GROUP} \
+ --background --stdout ${LOGFILE} --stderr ${LOGFILE} \
+ --nicelevel ${NICELEVEL} -- ${ARGS}
+
+ RESULT=$?
+
+ if [ "${CPU_SHARE}" -a -d /sys/kernel/uids ]; then
+ BUID=`id -u ${USER}`
+ # It might take a moment for start-stop-daemon to chuid
+ [ -d /sys/kernel/uids/${BUID} ] || sleep 1
+ [ -d /sys/kernel/uids/${BUID} ] || sleep 2
+ if [ -w /sys/kernel/uids/${BUID}/cpu_share ]; then
+ echo ${CPU_SHARE} > /sys/kernel/uids/${BUID}/cpu_share
+ fi
+ fi
+
+ eend ${RESULT}
+}
+
+attach() {
+ printf " Enter the Project URL: "
+ read url
+ printf " Enter your Account Key: "
+ read key
+
+ RC_QUIET_STDOUT="yes" svc_status
+ if [ $? == 1 ]; then
+ svc_start
+ fi
+ ebegin "Attaching to project"
+ # we have to work in runtime directory
+ cd ${RUNTIMEDIR}
+ # boinc cmd does not return 1 when it fails currently
+ boinc_cmd --project_attach ${url} ${key} &> /dev/null
+ eend $?
+
+ sleep 10
+ tail ${LOGFILE}
+}
+
+stop() {
+ ebegin "Stopping BOINC"
+ start-stop-daemon --stop --retry 3 --quiet --exec ${BOINCBIN}
+ eend $?
+}
+
+restart() {
+ svc_stop
+ svc_start
+}
diff --git a/sci-misc/boinc-bin/metadata.xml b/sci-misc/boinc-bin/metadata.xml
new file mode 100644
index 000000000..2b7806680
--- /dev/null
+++ b/sci-misc/boinc-bin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>scarabeus@gentoo.org</email>
+ <name>Tomas Chvatal</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/openmpi/Manifest b/sys-cluster/openmpi/Manifest
index 6dbccd366..742f7d35d 100644
--- a/sys-cluster/openmpi/Manifest
+++ b/sys-cluster/openmpi/Manifest
@@ -2,6 +2,6 @@ AUX eselect.mpi.openmpi 226 RMD160 39353fd5d350b26684f8e1258f689c95ec3b5011 SHA1
DIST openmpi-1.2.8.tar.bz2 3556787 RMD160 59f0d0397d499eb7b3a08ca68ca9778ef2cb61fc SHA1 140ae223263e20b7bde8ac59b966924ba4a454bb SHA256 75b286cb3b1bf6528a7e64ee019369e0601b8acb5c3c167a987f755d1e41c95c
DIST openmpi-1.3.tar.bz2 6430688 RMD160 3eb696d3f9d88f652849e80c385cf8594a29f20c SHA1 c16d1dfa825e70db1aaac0414a33bfa130eb8b78 SHA256 864706d88d28b586a045461a828962c108f5912671071bc3ef0ca187f115e47b
EBUILD openmpi-1.2.8.ebuild 2876 RMD160 9460153c15684010b1f40668a804789c0cc2e2e8 SHA1 b427829d42e1e607cf6b768b11e403e08f09deca SHA256 7cb6f198578e145027890fb1ebbbaafbdef9cad0d61132f4e4db9f5d917f4b9d
-EBUILD openmpi-1.3.ebuild 2913 RMD160 b23c9f6f9a612c6c17e95b45035b0358aabef31e SHA1 f2d17ef34e96ea7f4b5c6578f7d45a0de968968a SHA256 a3be52fd221662413fc4eb408d4ee5cdadf6e35ba8791d7af68e7fb517a6dafe
+EBUILD openmpi-1.3.ebuild 2877 RMD160 9d47a5a042031480187bd9e30a740666b30cb2ce SHA1 67ad89a417d5aae479a816434f1840e0e30d7b93 SHA256 9f49e8835dc2d17bdfe45667892d63a588c4515fea45ee6d83c7a34ab704e657
MISC ChangeLog 236 RMD160 7dc478b624dba9111b2ec8323ba075b7fb730c0b SHA1 f392893f088d861e47546a5d5aecf24413301118 SHA256 41a943141cb48b9227c156d92ef3dbf96ddd7336145cc286e0844250fe0363f0
MISC metadata.xml 714 RMD160 3a1b1cfafed8b2a9f674bbf03613a176a3c33894 SHA1 99ad99472912c4dd79eb9b1efd2439ff57f0becc SHA256 5139ae14e69e5edca9117ec6f4bb4f5c7654f41ef5050d5d777d47f0b1d05236
diff --git a/sys-cluster/openmpi/openmpi-1.3.ebuild b/sys-cluster/openmpi/openmpi-1.3.ebuild
index 164b49181..9b74ec985 100644
--- a/sys-cluster/openmpi/openmpi-1.3.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.3.ebuild
@@ -14,7 +14,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="mpi-threads? ( test )"
-IUSE="fortran heterogeneous ipv6 mpi-threads nocxx pbs romio smp threads"
+IUSE="fortran heterogeneous ipv6 mpi-threads nocxx pbs romio threads"
RDEPEND="pbs? ( sys-cluster/torque )
$(mpi_imp_deplist)"
DEPEND="${RDEPEND}"
@@ -92,7 +92,6 @@ src_compile() {
$(use_enable !nocxx mpi-cxx) \
$(use_enable romio io-romio) \
$(use_enable heterogeneous) \
- $(use_enable smp smp-locks) \
$(use_with pbs tm) \
$(use_enable ipv6) \
|| die