aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-03-31 23:10:09 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-03-31 23:10:09 +0200
commitb0176e52f19303e32d2797d6b41273a70dfb2b2c (patch)
tree2c873df83be55bdceb4a299bd9158e7feea1ec39
parentdev-python/pyBigWig: add python wrapper (diff)
downloadsci-b0176e52f19303e32d2797d6b41273a70dfb2b2c.tar.gz
sci-b0176e52f19303e32d2797d6b41273a70dfb2b2c.tar.bz2
sci-b0176e52f19303e32d2797d6b41273a70dfb2b2c.zip
sci-biology/deeptools: add new package
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--sci-biology/deeptools/Manifest1
-rw-r--r--sci-biology/deeptools/deeptools-2.5.0.ebuild32
-rw-r--r--sci-biology/deeptools/deeptools-9999.ebuild32
-rw-r--r--sci-biology/deeptools/metadata.xml12
4 files changed, 77 insertions, 0 deletions
diff --git a/sci-biology/deeptools/Manifest b/sci-biology/deeptools/Manifest
new file mode 100644
index 000000000..c0a50f45e
--- /dev/null
+++ b/sci-biology/deeptools/Manifest
@@ -0,0 +1 @@
+DIST deeptools-2.5.0.tar.gz 59620916 SHA256 2636f96b0781a05149949bebcc3634810c030c7b83187456a275619908bf8787 SHA512 5bd10d4c58cdd7b3318028eb28f6ca9252d42899dee8eb8ad6af1b372ad26fbcc605b712c3369ec45350600f2c822a17679062b9f536f454e5bfb0381715f98f WHIRLPOOL 422bd2a3d9ca2b7f697ae127c487d472c672fcef955b761cb5b5783dbf56ed14c3d05c3f01360fe02aeef01f427ecf45370dc8f0eb1c9e93080ac9938e2cc88e
diff --git a/sci-biology/deeptools/deeptools-2.5.0.ebuild b/sci-biology/deeptools/deeptools-2.5.0.ebuild
new file mode 100644
index 000000000..e69672942
--- /dev/null
+++ b/sci-biology/deeptools/deeptools-2.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 )
+
+inherit distutils-r1
+
+[ "$PV" == "9999" ] && inherit git-2
+
+DESCRIPTION="Extract reads from BAM files, normalize, draw figures, convert BAM to bigWig"
+HOMEPAGE="https://github.com/fidelram/deepTools"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="https://github.com/fidelram/deepTools"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/fidelram/deepTools/archive/2.5.0.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/numpy-1.8.0
+ >=sci-libs/scipy-0.17.0
+ >=dev-python/py2bit-0.1.0
+ >=dev-python/pyBigWig-0.2.1
+ >=sci-biology/pysam-0.8
+ >=dev-python/matplotlib-1.4.0"
+RDEPEND="${DEPEND}"
diff --git a/sci-biology/deeptools/deeptools-9999.ebuild b/sci-biology/deeptools/deeptools-9999.ebuild
new file mode 100644
index 000000000..a2c1fcfb9
--- /dev/null
+++ b/sci-biology/deeptools/deeptools-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_5 )
+
+inherit distutils-r1
+
+[ "$PV" == "9999" ] && inherit git-2
+
+DESCRIPTION="Extract reads from BAM files, normalize, draw figures, convert BAM to bigWig"
+HOMEPAGE="https://github.com/fidelram/deepTools"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="https://github.com/fidelram/deepTools"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/fidelram/deepTools/archive/2.5.0.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/numpy-1.8.0
+ >=sci-libs/scipy-0.17.0
+ >=dev-python/py2bit-0.1.0
+ >=dev-python/pyBigWig-0.2.1
+ >=sci-biology/pysam-0.8
+ >=dev-python/matplotlib-1.4.0"
+RDEPEND="${DEPEND}"
diff --git a/sci-biology/deeptools/metadata.xml b/sci-biology/deeptools/metadata.xml
new file mode 100644
index 000000000..f68a1b6fa
--- /dev/null
+++ b/sci-biology/deeptools/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>