aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2012-06-22 09:07:40 +0200
committerKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2012-06-22 09:07:40 +0200
commitb076e0e6b25f1d1fca99ac0832446e634f0cad0c (patch)
tree381831c2b4d6462c980c2aae4bd96ada0a6076ae
parentapp-doc/root-docs: backport htmldoc generation fixes (diff)
parentdev-java/hdf-java-2.8: fix hdfview script (quotes and sh-bang) (diff)
downloadsci-b076e0e6b25f1d1fca99ac0832446e634f0cad0c.tar.gz
sci-b076e0e6b25f1d1fca99ac0832446e634f0cad0c.tar.bz2
sci-b076e0e6b25f1d1fca99ac0832446e634f0cad0c.zip
Merge branch 'master' of https://github.com/wking/science into wking-hdfview
-rw-r--r--dev-java/hdf-java/hdf-java-2.8.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-java/hdf-java/hdf-java-2.8.ebuild b/dev-java/hdf-java/hdf-java-2.8.ebuild
index 06f71115a..98c9248f2 100644
--- a/dev-java/hdf-java/hdf-java-2.8.ebuild
+++ b/dev-java/hdf-java/hdf-java-2.8.ebuild
@@ -7,7 +7,7 @@ JAVA_PKG_IUSE="doc examples"
inherit eutils java-pkg-2 autotools fdo-mime
DESCRIPTION="Java interface to the HDF5 library"
-HOMEPAGE="http://www.hdfgroup.org/hdf-java-html/inxodex.html"
+HOMEPAGE="http://www.hdfgroup.org/hdf-java-html/index.html"
SRC_URI="http://www.hdfgroup.org/ftp/HDF5/hdf-java/src/${P}-src.tar"
LICENSE="NCSA-HDF"
@@ -75,7 +75,7 @@ src_compile() {
emake -j1 just-hdf4
fi
- use hdfview && emake -j1
+ use hdfview && emake -j1 packages
use examples && emake -j1 do-examples
use doc && emake -j1 javadocs
}
@@ -100,10 +100,11 @@ src_install() {
java-pkg_dojar lib/ext/fitsobj.jar
java-pkg_dojar lib/jhdfview.jar
cat <<-EOF > hdfview
+ #!/bin/sh
export CLASSPATH=\$(java-config --classpath hdf-java)
\$(java-config --java) \
-Xmx1000m \
- -Djava.library.path=\"\$(java-config --library hdf-java)\" \
+ -Djava.library.path=\$(java-config --library hdf-java) \
ncsa.hdf.view.HDFView \
-root "${EROOT}" \$*
EOF