aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormikko_laine <mikko.laine@gmail.com>2014-12-13 23:33:21 +0200
committermikko_laine <mikko.laine@gmail.com>2014-12-13 23:33:21 +0200
commitb0c6f58aeb6ea64523e7180df8ccb1e67ffbd4c1 (patch)
tree6f3085e8f81008d5553e654cade38945c321bdbc
parentMerge pull request #300 from marbre/mendeleydesktop (diff)
downloadsci-b0c6f58aeb6ea64523e7180df8ccb1e67ffbd4c1.tar.gz
sci-b0c6f58aeb6ea64523e7180df8ccb1e67ffbd4c1.tar.bz2
sci-b0c6f58aeb6ea64523e7180df8ccb1e67ffbd4c1.zip
sci-astronomy/mosstack: pyAstroStack renamed to Mosstack and version bumped to 0.6.1
Package-Manager: portage-2.2.14
-rw-r--r--sci-astronomy/mosstack/ChangeLog10
-rw-r--r--sci-astronomy/mosstack/Manifest1
-rw-r--r--sci-astronomy/mosstack/metadata.xml20
-rw-r--r--sci-astronomy/mosstack/mosstack-0.6.1.ebuild33
4 files changed, 64 insertions, 0 deletions
diff --git a/sci-astronomy/mosstack/ChangeLog b/sci-astronomy/mosstack/ChangeLog
new file mode 100644
index 000000000..91c775507
--- /dev/null
+++ b/sci-astronomy/mosstack/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-astronomy/mosstack
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*mosstack-0.6.1 (13 Dec 2014)
+
+ 13 Dec 2014; Mikko Laine <mikko.laine@gmail.com> +metadata.xml,
+ +mosstack-0.6.1.ebuild:
+ sci-astronomy/mosstack: pyAstroStack renamed to Mosstack and version bumped to
+ 0.6.1
diff --git a/sci-astronomy/mosstack/Manifest b/sci-astronomy/mosstack/Manifest
new file mode 100644
index 000000000..312d31a33
--- /dev/null
+++ b/sci-astronomy/mosstack/Manifest
@@ -0,0 +1 @@
+DIST mosstack-0.6.1.tar.gz 470478 SHA256 c3a0a5021d6f1f717fe5e27caf19ba501fafd66f925662496fd530a38e7b7ccd SHA512 66244086c476ca5743649ef7d4fe5ab6acee8d3a1c163e5008517fe3ad5779e2452cc717482fbad60912934f29b9627cad9851842d87546a33853a87a4ec0568 WHIRLPOOL f475b367e76c3930dc41b0d3114b6447966d7f3d814dd2b1ff5bcbdd464a1fac720737ad0c4f68094363a01eb852c92e1d10720062186f7d031410045a857ee3
diff --git a/sci-astronomy/mosstack/metadata.xml b/sci-astronomy/mosstack/metadata.xml
new file mode 100644
index 000000000..e425fd595
--- /dev/null
+++ b/sci-astronomy/mosstack/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mikko.laine@gmail.com</email>
+ <name>Mikko Laine</name>
+ </maintainer>
+ <longdescription>
+ An open source stacking software for astronomical images taken with a DSLR
+ camera. Mosstack can calibrate, debayer, register, align and stack photos
+ taken with modern DSLR's from Canon. It has a command line user interface
+ inspired by AstroSurf IRIS and a graphical user interface written with PyQt4
+ </longdescription>
+ <use>
+ <flag name="opencl">Enables OpenCL support and pulls in pyopencl. This makes
+ some operations much faster but requires specific hardware and drivers.</flag>
+ <flag name="qt4">Pulls in PyQt4. Program works on command line interface
+ without it but for GUI the library is required.</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-astronomy/mosstack/mosstack-0.6.1.ebuild b/sci-astronomy/mosstack/mosstack-0.6.1.ebuild
new file mode 100644
index 000000000..c589368b0
--- /dev/null
+++ b/sci-astronomy/mosstack/mosstack-0.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Stacking software for astronomical images"
+HOMEPAGE="https://sites.google.com/site/mosstack"
+SRC_URI="http://bitbucket.org/mikko_laine/pyastrostack/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="opencl qt4"
+
+DEPEND=">=dev-python/numpy-1.8.0[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+RDEPEND=">=dev-python/pillow-2.3.0[${PYTHON_USEDEP}]
+ sci-libs/scikits_image[${PYTHON_USEDEP}]
+ >media-gfx/imagemagick-6.8.0.0
+ sci-astronomy/sextractor
+ media-gfx/dcraw
+ media-libs/exiftool
+ dev-python/astropy[${PYTHON_USEDEP}]
+ opencl? ( >=dev-python/pyopencl-2013.1[${PYTHON_USEDEP}] )
+ qt4? ( dev-python/PyQt4[${PYTHON_USEDEP}] )"
+
+DOCS=( CHANGES.txt README.txt )