aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-02-11 21:21:18 -0700
committerChristoph Junghans <ottxor@gentoo.org>2013-02-11 21:21:18 -0700
commitb771bdf1df7e9b89773d419679fec77cdf9a9d3f (patch)
tree1f13cf7ca4c3e4e5dfccd210148a8d82d9ae7d1a
parentadded warning about petsc threads support (diff)
downloadsci-b771bdf1df7e9b89773d419679fec77cdf9a9d3f.tar.gz
sci-b771bdf1df7e9b89773d419679fec77cdf9a9d3f.tar.bz2
sci-b771bdf1df7e9b89773d419679fec77cdf9a9d3f.zip
sse41 -> sse4_1 (bug #456886) + ninja has missing keywords
Package-Manager: portage-2.2.0_alpha161
-rw-r--r--sci-chemistry/gromacs/ChangeLog4
-rw-r--r--sci-chemistry/gromacs/gromacs-4.6.9999.ebuild6
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild4
-rw-r--r--sci-chemistry/gromacs/metadata.xml2
4 files changed, 9 insertions, 7 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index af4912d5d..7672a1eec 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 12 Feb 2013; Christoph Junghans <ottxor@gentoo.org> gromacs-4.6.9999.ebuild,
+ gromacs-9999.ebuild, metadata.xml:
+ sse41 -> sse4_1 (bug #456886) + ninja has missing keywords
+
30 Jan 2013; Christoph Junghans <ottxor@gentoo.org> gromacs-4.6.9999.ebuild,
gromacs-9999.ebuild:
added subslot, removed gromacs-manual blocker
diff --git a/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild b/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
index 5a4f57386..5e52c9f20 100644
--- a/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
@@ -7,8 +7,6 @@ EAPI=5
TEST_PV="4.6"
MANUAL_PV="4.6"
-CMAKE_MAKEFILE_GENERATOR="ninja"
-
inherit bash-completion-r1 cmake-utils cuda eutils multilib toolchain-funcs
if [[ $PV = *9999* ]]; then
@@ -24,7 +22,7 @@ else
test? ( http://${PN}.googlecode.com/files/regressiontests-${TEST_PV}.tar.gz )"
fi
-ACCE_IUSE="sse2 sse41 avx128fma avx256"
+ACCE_IUSE="sse2 sse4_1 avx128fma avx256"
DESCRIPTION="The ultimate molecular dynamics simulation package"
HOMEPAGE="http://www.gromacs.org/"
@@ -130,7 +128,7 @@ src_configure() {
#go from slowest to fastest acceleration
local acce="None"
use sse2 && acce="SSE2"
- use sse41 && acce="SSE4.1"
+ use sse4_1 && acce="SSE4.1"
use avx128fma && acce="AVX_128_FMA"
use avx256 && acce="AVX_256"
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index fdfa0152d..b9af3c0fe 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -9,7 +9,7 @@ TEST_PV="4.0.4"
EGIT_REPO_URI="git://git.gromacs.org/gromacs http://repo.or.cz/r/gromacs.git"
EGIT_BRANCH="master"
-ACCE_IUSE="sse2 sse41 avx128fma avx256"
+ACCE_IUSE="sse2 sse4_1 avx128fma avx256"
#to find external blas/lapack
CMAKE_MIN_VERSION="2.8.5-r2"
@@ -112,7 +112,7 @@ src_configure() {
#go from slowest to fasterest acceleration
local acce="None"
use sse2 && acce="SSE2"
- use sse41 && acce="SSE4.1"
+ use sse4_1 && acce="SSE4.1"
use avx128fma && acce="AVX_128_FMA"
use avx256 && acce="AVX_256"
diff --git a/sci-chemistry/gromacs/metadata.xml b/sci-chemistry/gromacs/metadata.xml
index 1360fcbfd..8a88d53da 100644
--- a/sci-chemistry/gromacs/metadata.xml
+++ b/sci-chemistry/gromacs/metadata.xml
@@ -12,7 +12,7 @@
<flag name="single-precision">Single precision version of gromacs (default)</flag>
<!-- acceleration optimization flags -->
<flag name="fkernels">Enable building of Fortran Kernels for platforms that dont have assembly loops</flag>
- <flag name="sse41">Enable sse4.1 acceleration</flag>
+ <flag name="sse4_1">Enable sse4.1 acceleration</flag>
<flag name="avx128fma">Enable 128bit avx with fma (e.g. AMD BullDozer)</flag>
<flag name="avx256">Enable 256bit avx (e.g. Intel Sandy Bridge)</flag>
<flag name="offensive">Enable gromacs partly offensive quotes</flag>