aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2014-07-12 15:49:49 -0400
committerGuillaume Horel <guillaume.horel@gmail.com>2014-07-12 15:49:49 -0400
commitb82d9befa586187dc593a3706f805c747c0078fc (patch)
tree52e39182b0c2f9d5a57d86114a8e01eb0b5c42bf
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-b82d9befa586187dc593a3706f805c747c0078fc.tar.gz
sci-b82d9befa586187dc593a3706f805c747c0078fc.tar.bz2
sci-b82d9befa586187dc593a3706f805c747c0078fc.zip
sci-mathematics/scilab fix access violation issue
-rw-r--r--sci-mathematics/scilab/files/scilab-5.5.0-accessviolation.patch32
-rw-r--r--sci-mathematics/scilab/scilab-5.5.0.ebuild4
2 files changed, 20 insertions, 16 deletions
diff --git a/sci-mathematics/scilab/files/scilab-5.5.0-accessviolation.patch b/sci-mathematics/scilab/files/scilab-5.5.0-accessviolation.patch
index 39b4302a8..a84de9a2b 100644
--- a/sci-mathematics/scilab/files/scilab-5.5.0-accessviolation.patch
+++ b/sci-mathematics/scilab/files/scilab-5.5.0-accessviolation.patch
@@ -1,21 +1,21 @@
---- bin/scilab.orig 2013-10-28 01:08:06.623143085 -0400
-+++ bin/scilab 2013-10-30 22:57:00.781289235 -0400
-@@ -650,11 +650,13 @@
- # libEGL may be partially supported by the closed-source NVIDIA driver.
- # Until they release an EGL driver, we force the egl_glx driver.
- # http://bugzilla.scilab.org/show_bug.cgi?id=12940
+diff -urN scilab-5.5.0-orig/bin/scilab scilab-5.5.0/bin/scilab
+--- scilab-5.5.0-orig/bin/scilab 2014-07-12 15:24:17.105686656 -0400
++++ scilab-5.5.0/bin/scilab 2014-07-12 15:25:29.307725409 -0400
+@@ -647,17 +647,6 @@
+ GTK_MODULES=$(echo $GTK_MODULES | sed s/gnomebreakpad//g)
+ export GTK_MODULES
+
+-# libEGL may be partially supported by the closed-source NVIDIA driver.
+-# Until they release an EGL driver, we force the egl_glx driver.
+-# http://bugzilla.scilab.org/show_bug.cgi?id=12940
-if test -x /usr/bin/glxinfo; then
- NVIDIA_GLX_VENDOR=$(/usr/bin/glxinfo |grep "NVIDIA Corporation")
- if test ! -z "$NVIDIA_GLX_VENDOR"; then
- EGL_DRIVER=egl_glx
- export EGL_DRIVER
-+if test $SCILAB_MODE != "nw"; then
-+ if test -x /usr/bin/glxinfo; then
-+ NVIDIA_GLX_VENDOR=$(/usr/bin/glxinfo |grep "NVIDIA Corporation")
-+ if test ! -z "$NVIDIA_GLX_VENDOR"; then
-+ EGL_DRIVER=egl_glx
-+ export EGL_DRIVER
-+ fi
- fi
- fi
-
+- fi
+-fi
+-
+ if test $SCIVERBOSE -ne 0; then
+ echo "SCI : $SCI"
+ echo "SCIBIN : $SCIBIN"
diff --git a/sci-mathematics/scilab/scilab-5.5.0.ebuild b/sci-mathematics/scilab/scilab-5.5.0.ebuild
index 38ad3e4f3..3fe7558b5 100644
--- a/sci-mathematics/scilab/scilab-5.5.0.ebuild
+++ b/sci-mathematics/scilab/scilab-5.5.0.ebuild
@@ -241,6 +241,10 @@ src_install() {
pkg_postinst() {
fdo-mime_mime_database_update
+ einfo "If you are using the NVIDIA binary drivers, and run into graphics"
+ einfo "crashes, you may try to run scilab as follows:"
+ einfo "EGL_DRIVER=egl_glx scilab"
+ einfo "See upstream http://bugzilla.scilab.org/show_bug.cgi?id=12940"
}
pkg_postrm() {