aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2021-03-13 20:33:46 -0500
committerHorea Christian <chr@chymera.eu>2021-03-13 20:33:46 -0500
commitbad99a991dd41e119987f5bb058f1a268d82dd58 (patch)
treee139bceb42d5f49b7df732d2674d4f25c3fe3fc9
parentdev-cpp/castxml: fixed broken source dir specification (diff)
downloadsci-bad99a991dd41e119987f5bb058f1a268d82dd58.tar.gz
sci-bad99a991dd41e119987f5bb058f1a268d82dd58.tar.bz2
sci-bad99a991dd41e119987f5bb058f1a268d82dd58.zip
dev-cpp/castxml: version bump 0.4.3
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-cpp/castxml/Manifest1
-rw-r--r--dev-cpp/castxml/castxml-0.4.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/castxml/Manifest b/dev-cpp/castxml/Manifest
index 3e63ee249..a7d756e8b 100644
--- a/dev-cpp/castxml/Manifest
+++ b/dev-cpp/castxml/Manifest
@@ -1 +1,2 @@
DIST castxml-0.3.6.tar.gz 95844 BLAKE2B c0ab3c7ba29b2abb4755320d97c36ee850135fff6fd5bb7a9436d68f50e9c6a80108ac95958fe9b51afaf6b4ebdde7db825a9cdf047c5e8f47f4f57fba77dcc1 SHA512 c850ce9ce0ef716cf64139d4311955deb8373db691e3cb7348932bbd3945056366838187603e5850a088911a8be6b0e5b53e2c700c0b5c8fed71008de7ab2350
+DIST castxml-0.4.3.tar.gz 103188 BLAKE2B ceaeaa0e228865847fc9627e93366c9dc2d33f89c97621af25ce84746ffe79b0db7cf52a93aed3ac297ce116e1f63f4bcc636dc21419aabf3ba737f545b240c1 SHA512 af2c03e148d42615a9ad0366a224ebeb06ca0348c0b5fcc0a93cba4871710dd8901874e5e30968532cdb1254e63a7ab596403bf2f3c836eed57be287203ddbed
diff --git a/dev-cpp/castxml/castxml-0.4.3.ebuild b/dev-cpp/castxml/castxml-0.4.3.ebuild
new file mode 100644
index 000000000..6fb7ac720
--- /dev/null
+++ b/dev-cpp/castxml/castxml-0.4.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake llvm
+
+MY_PN="CastXML"
+
+DESCRIPTION="CastXML is a C-family abstract syntax tree XML output tool."
+HOMEPAGE="https://github.com/CastXML/CastXML"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/CastXML/CastXML"
+else
+ SRC_URI="https://github.com/CastXML/CastXML/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="${RDEPEND}"
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ sys-devel/llvm:=
+ sys-devel/clang:=
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.3.6-install-paths.patch )