aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-04 12:52:39 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-04 12:52:39 +0100
commitbd7ac0e244a891713e3dea57ca737b4dfd980175 (patch)
tree55472eabc59873fb80a32cd12fc16d029d446723
parentsci-mathematics/libsfmt: EAPI bump (diff)
downloadsci-bd7ac0e244a891713e3dea57ca737b4dfd980175.tar.gz
sci-bd7ac0e244a891713e3dea57ca737b4dfd980175.tar.bz2
sci-bd7ac0e244a891713e3dea57ca737b4dfd980175.zip
sci-mathematics/why3: version bump 1.3.3, EAPI bump
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-mathematics/why3/Manifest1
-rw-r--r--sci-mathematics/why3/why3-1.3.3.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sci-mathematics/why3/Manifest b/sci-mathematics/why3/Manifest
index 6ba945696..3cfcb7567 100644
--- a/sci-mathematics/why3/Manifest
+++ b/sci-mathematics/why3/Manifest
@@ -1 +1,2 @@
DIST why3-0.83.tar.gz 5347628 BLAKE2B d405eec88a66312f6f39ab64e121650256395c01396d47b1b18d68cb5a501cc60698d5498df3a25ccd780f6ff592ffb5a5f9f1fd2ac6fe252213b1df42480b0f SHA512 e1c4d462986835aa0e9a1ca117e4c3bbaf307b45b6de03da6ea8dd706770b8d9894031ea22ec732dfa7340d613b023ab499837203a132db5f138e51596e64177
+DIST why3-1.3.3.tar.gz 5807572 BLAKE2B b1a04e78010f841e217b9a81c096cadfa0cddabadbe81ef55c310a104668feb1e46cd50576a965a58c74658903d6d08f9fd348bd2064a79ac3b176548927bcbe SHA512 a2dc95691cea29bbd20843a05add3985f777085086b654b53566ecdb752ba892366da703e232c85d5e0237d0e59564527aed55f6ccae9118d49e5f2cf93a53ce
diff --git a/sci-mathematics/why3/why3-1.3.3.ebuild b/sci-mathematics/why3/why3-1.3.3.ebuild
new file mode 100644
index 000000000..41c1f9b9f
--- /dev/null
+++ b/sci-mathematics/why3/why3-1.3.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DOCS_BUILDER="sphinx"
+DOCS_DIR="doc"
+DOCS_DEPEND="
+ dev-python/sphinxcontrib-bibtex
+ dev-python/graphviz
+"
+
+inherit python-any-r1 docs
+
+DESCRIPTION="Why3 is a platform for deductive program verification"
+HOMEPAGE="http://why3.lri.fr/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/38367/why3-1.3.3.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="float frama-c examples"
+
+DEPEND="
+ >=dev-lang/ocaml-3.12.1
+ dev-ml/zarith
+ dev-ml/menhir
+ dev-ml/num
+ sci-mathematics/coq
+ frama-c? ( >=sci-mathematics/frama-c-20140301 )
+ float? ( sci-mathematics/flocq )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ mv doc/why.1 doc/why3.1 || die
+ sed -i configure.in -e "s/\"pvs\"/\"sri-pvs\"/g" || die
+ sed -i configure -e "s/\"pvs\"/\"sri-pvs\"/g" || die
+ # fix dev-ml/num path
+ sed -i configure.in -e "s/nums.cma/num.cma/g" -e "s/num.cmi/core\/num.cmi/g" || die
+ sed -i configure -e "s/nums.cma/num.cma/g" -e "s/num.cmi/core\/num.cmi/g" || die
+ sed -i Makefile.in -e "s:DESTDIR =::g" \
+ -e "s:\$(RUBBER) --warn all --pdf manual.tex:makeindex manual.tex; \$(RUBBER) --warn all --pdf manual.tex; cd ..:g" || die
+ # add autodoc to sphinx
+ sed -i -e "/^extensions = \[/a \ \ \ \ \'sphinx.ext.autodoc\'," doc/conf.py || die
+}
+
+src_configure() {
+ econf $(use_enable frama-c)
+}
+
+src_compile() {
+ docs_compile
+ default
+}
+
+src_install(){
+ default
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}