aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-29 11:11:09 +0100
committerJustin Lecher <jlec@gentoo.org>2013-12-29 11:11:09 +0100
commitc058b90b7bbe833bcdc363af12bdf4d585871e0e (patch)
tree0ce90601d2a9f0fa0f5dd90cea4a534e69118919
parentimport into tree (diff)
parentsci-mathematics/open-axiom: Drop src_install in favour of default and use DOCS (diff)
downloadsci-c058b90b7bbe833bcdc363af12bdf4d585871e0e.tar.gz
sci-c058b90b7bbe833bcdc363af12bdf4d585871e0e.tar.bz2
sci-c058b90b7bbe833bcdc363af12bdf4d585871e0e.zip
Merge branch 'ustcscgy-openaxiom'
* ustcscgy-openaxiom: sci-mathematics/open-axiom: Drop src_install in favour of default and use DOCS sci-mathematics/open-axiom: version bump to 1.4.2
-rw-r--r--sci-mathematics/open-axiom/ChangeLog6
-rw-r--r--sci-mathematics/open-axiom/Manifest1
-rw-r--r--sci-mathematics/open-axiom/metadata.xml4
-rw-r--r--sci-mathematics/open-axiom/open-axiom-1.4.2.ebuild37
4 files changed, 45 insertions, 3 deletions
diff --git a/sci-mathematics/open-axiom/ChangeLog b/sci-mathematics/open-axiom/ChangeLog
index f8d9884d2..ad2fb6847 100644
--- a/sci-mathematics/open-axiom/ChangeLog
+++ b/sci-mathematics/open-axiom/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-mathematics/open-axiom
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 29 Dec 2013; Justin Lecher <jlec@gentoo.org> open-axiom-1.4.2.ebuild,
+ metadata.xml:
+ Drop src_install in favour of default and use DOCS
+
*open-axiom-1.3.0 (22 Jan 2010)
22 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
diff --git a/sci-mathematics/open-axiom/Manifest b/sci-mathematics/open-axiom/Manifest
index b77753948..15dcde960 100644
--- a/sci-mathematics/open-axiom/Manifest
+++ b/sci-mathematics/open-axiom/Manifest
@@ -1 +1,2 @@
DIST open-axiom-1.3.0.tar.bz2 11821857 SHA256 5c35d0c8b6da17ff2254d833c5f6694d3f5d49064e312e61719cdeb386f888c4
+DIST open-axiom-1.4.2.tar.bz2 9862899 SHA256 745024aadb4fefdd09980e3076141e1a4646ea8588b4d9b0ece486d581b8a119
diff --git a/sci-mathematics/open-axiom/metadata.xml b/sci-mathematics/open-axiom/metadata.xml
index be6988b49..7485722c6 100644
--- a/sci-mathematics/open-axiom/metadata.xml
+++ b/sci-mathematics/open-axiom/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
OpenAxiom is an open source platform for symbolic, algebraic, and
numerical computations. It offers an interactive environment, an expressive
programming language, a compiler, a large set of mathematical libraries of
diff --git a/sci-mathematics/open-axiom/open-axiom-1.4.2.ebuild b/sci-mathematics/open-axiom/open-axiom-1.4.2.ebuild
new file mode 100644
index 000000000..972339a92
--- /dev/null
+++ b/sci-mathematics/open-axiom/open-axiom-1.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Symbolic and algebraic computations system"
+HOMEPAGE="http://www.open-axiom.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="X"
+
+RDEPEND="X? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ app-text/noweb
+ >=dev-lisp/sbcl-1.0.22"
+
+DOCS="MAINTAINERS TODO STYLES"
+
+src_configure() {
+ # There is an option to compile with other lisps. However:
+ # - gcl is getting obsolete and unmaintained and is hard masked
+ # - could not make it work with ecls
+ econf \
+ --with-lisp=sbcl \
+ $(use_with X x)
+}
+
+src_compile() {
+ # unfortunately could not track down the broken parallel build
+ # -j5 ok but -j30 sbcl stalled
+ emake -j1
+}