aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-04-03 17:45:26 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-04-03 17:45:26 +0200
commitc2d81203011805abd24ae7adb6c8afc14ea02949 (patch)
treef13741e66a09e2c6adfa2f4a366f7f914366fa2e
parentdev-python/matplotlib2tikz: Adopt changes from main tree (diff)
downloadsci-c2d81203011805abd24ae7adb6c8afc14ea02949.tar.gz
sci-c2d81203011805abd24ae7adb6c8afc14ea02949.tar.bz2
sci-c2d81203011805abd24ae7adb6c8afc14ea02949.zip
sci-biology/igv: version bump, cannot compile FlowSignalDistributionPanel.java:222
It seem this is related to Gentoo ebuild unbundling some of the bundled libs. I can compile vanilla sources using ant without this issue. [javac] Compiling 889 source files to /scratch/var/tmp/portage/sci-biology/igv-2.3.88/work/igv-2.3.88/tmp [javac] /scratch/var/tmp/portage/sci-biology/igv-2.3.88/work/igv-2.3.88/src/org/broad/igv/tools/sort/BAMSorter.java:33: warning: NotImplementedException is internal proprietary API and may be removed in a future release [javac] import sun.reflect.generics.reflectiveObjects.NotImplementedException; [javac] ^ [javac] /scratch/var/tmp/portage/sci-biology/igv-2.3.88/work/igv-2.3.88/src/com/iontorrent/views/FlowSignalDistributionPanel.java:222: error: cannot access PublicCloneable [javac] dataset.addValue(data[j], seriename, cat); [javac] ^ [javac] class file for org.jfree.util.PublicCloneable not found [javac] /scratch/var/tmp/portage/sci-biology/igv-2.3.88/work/igv-2.3.88/src/com/iontorrent/views/FlowSignalDistributionPanel.java:266: error: cannot access Drawable [javac] CategoryPlot plot = freechart.getCategoryPlot(); [javac] ^ [javac] class file for org.jfree.ui.Drawable not found [javac] /scratch/var/tmp/portage/sci-biology/igv-2.3.88/work/igv-2.3.88/src/org/broad/igv/tools/sort/BAMSorter.java:102: warning: NotImplementedException is internal proprietary API and may be removed in a future release [javac] throw new NotImplementedException(); Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--sci-biology/igv/Manifest1
-rw-r--r--sci-biology/igv/igv-2.3.92.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/sci-biology/igv/Manifest b/sci-biology/igv/Manifest
index 42c2ecb8c..291b2f00f 100644
--- a/sci-biology/igv/Manifest
+++ b/sci-biology/igv/Manifest
@@ -1,3 +1,4 @@
DIST igv-2.3.47.zip 146891756 SHA256 1a9e0f56c1dfde2bdcd3823ad196ac4e4deb983500152667e761560c34d9b91d SHA512 24eea8215db8eaa92d4562f5867d3d5cf4cdde5f0e65cd2dae63493c02a47fa27bd30765c7ce87ef4d5106dfb92106f3abca2471d077311bc1bb6de2a71d2d2c WHIRLPOOL 0dd2b6a542832d9f769ca47c7e969fd8cc7b7fdbebd57d63b4e3e8c9e80a175840255c2a7a8496415117ee58a65fa4a7f7aebfec18168223ac0232d7bd428e89
DIST igv-2.3.81.zip 148743869 SHA256 c0c079fac0df8cd357a6564aec3dbcde98b6fb46e7c22e3eac1a51a08f4bfaba SHA512 5f6fb29ac73ff87deb7987a535666bb7cd1c3c40144cd92185d2e81403cddee2aa66cbfa1e43bf4a4167f1884c42ab670598dfd1a5e680690953dc5831143bb7 WHIRLPOOL 96d3ed000af28740a2176083869c342690a9f6e77abcd61c338cc53ff98c5d9cc478822e0d6cb5d9bcefcaddd463f76d5334b24b3445256befd11d082e6aecee
DIST igv-2.3.88.zip 150339120 SHA256 8cd669224ab0ab38f2ecceb9487805305bee78d45b04857a2da682a9bd221e4e SHA512 f647f7c115dfbd24303744319ab7d4ab7e25624d82a664fb1aa9df2840a1246a833919d79747b793db466380c1e6091079992d7702295029b6abce924ce6782b WHIRLPOOL c1cb29c4d94cc83f5a3d2109de1960f47fd607aa44ad54cccb9836dd9d9783e260c7cff7a8f331ac05a11bda1d9eae8d9a05befacfacbf44954ba2bacc360ccb
+DIST igv-2.3.92.zip 150354074 SHA256 46ba23804e14914f73b446c719934183214bcf53601298ed0aedd833d2148f4e SHA512 a10b7ec75bcb044929fcaf1ace9088436691a131af332f1dcf9a9ebb6349a78b06800cbeb2c1fc290a9db6308cde623f44a928d7c0a75a2d55e153bcad056a4a WHIRLPOOL 1139871646504c4246d4be7bf7e8ba551e17bfe91e099223060af5338371331a303b2e2fb78a4145a5ed3963438257ad4b5ad0f8233dbbb31dd8acaa1738c62b
diff --git a/sci-biology/igv/igv-2.3.92.ebuild b/sci-biology/igv/igv-2.3.92.ebuild
new file mode 100644
index 000000000..72b0dcff1
--- /dev/null
+++ b/sci-biology/igv/igv-2.3.92.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit java-pkg-2 java-ant-2
+
+[ "$PV" == "9999" ] && inherit git-r3
+
+if [ "$PV" == "9999" ]; then
+ #ESVN_REPO_URI="http://igv.googlecode.com/svn/trunk"
+ #ESVN_REPO_URI="http://igv.googlecode.com/svn/tags/Version_${PV}"
+ EGIT_REPO_URI="https://github.com/broadinstitute/IGV.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/broadinstitute/IGV/archive/v${PV}.zip -> ${P}.zip"
+ KEYWORDS=""
+ # binaries
+ # http://www.broadinstitute.org/igv/projects/downloads/IGV_2.3.40.zip
+ # http://www.broadinstitute.org/igv/projects/downloads/igvtools_2.3.40.zip
+fi
+
+DESCRIPTION="Integrative Genomics Viewer"
+HOMEPAGE="http://www.broadinstitute.org/igv/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+KEYWORDS="" # see upstream issue #332
+
+# actually more exactly the COMMON_DEPS should contain:
+# >=dev-java/commons-compress-1.11 # use bundled library until dev-java/commons-compress is bumped, see bug #591696
+COMMON_DEPS="
+ dev-java/absolutelayout:0
+ dev-java/jama:0
+ dev-java/commons-compress
+ dev-java/commons-logging:0
+ >=dev-java/commons-io-2.1:1
+ >=dev-java/commons-math-2:*
+ >=dev-java/commons-jexl-2:*
+ dev-java/jcommon:*
+ >=dev-java/jfreechart-1.0:*
+ dev-java/jlfgr:0
+ dev-java/log4j:0
+ >=dev-java/gson-2.2.2:*
+ =dev-java/guava-17:*
+ >=dev-java/swing-layout-1
+ dev-java/jgrapht:0
+ >=dev-java/junit-4"
+
+DEPEND=">=virtual/jdk-1.7
+ app-arch/unzip
+ ${COMMON_DEPS}"
+RDEPEND=">=virtual/jre-1.7
+ ${COMMON_DEPS}"
+
+S="${WORKDIR}/igv-${PV}" # if the file unpacks into IGV_"${PV}" then you fetched wrong file with the precompiled jar
+
+EANT_BUILD_TARGET="all"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_NEEDS_TOOLS="true"
+EANT_EXTRA_ARGS="-Dnotests=true"
+
+EANT_GENTOO_CLASSPATH="absolutelayout,jama,commons-logging,commons-math-2,commons-jexl-2,jfreechart-1.0,jlfgr,log4j,commons-io-1,"
+EANT_GENTOO_CLASSPATH+="gson-2.2.2,guava-20,swing-layout-1,jgrapht,junit-4"
+
+java_prepare() {
+ mv lib oldlib || die
+ mkdir lib || die
+
+ mv -v oldlib/{htsjdk-1.139-patched.jar,jide-oss-3.5.5.jar,goby-io-igv__V1.0.jar,jargs.jar,mongo-java-driver-2.11.3.jar,na12878kb-utils.jar,picard-lib.jar,mysql-connector-java-3.1.14-bin.jar} lib || die
+ mv -v oldlib/batik* lib || die
+
+ rm -rvf oldlib/* || die
+}
+
+src_install() {
+ java-pkg_newjar igv.jar
+
+ for i in lib/*.jar; do java-pkg_dojar $i; done
+
+ java-pkg_dolauncher igv --jar igv.jar --main org.broad.igv.ui.Main
+}
+
+pkg_postinst(){
+ einfo "You may want to install sci-biology/blat for easy sequence searches inside igv"
+}