aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2019-12-03 23:53:04 +0800
committerBenda Xu <heroxbd@gentoo.org>2019-12-03 23:53:04 +0800
commitc3b2f0798bd0ee86baaad62567f54b256dbbb6dd (patch)
tree2a44415511428eff634731188f97842a6c8e7145
parentmedia-libs/yocto-gl: initial commit of 0_p20191111. (diff)
downloadsci-c3b2f0798bd0ee86baaad62567f54b256dbbb6dd.tar.gz
sci-c3b2f0798bd0ee86baaad62567f54b256dbbb6dd.tar.bz2
sci-c3b2f0798bd0ee86baaad62567f54b256dbbb6dd.zip
media-libs/imgui: initial commit.
This is included as a dependency of sci-physics/opticks. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--media-libs/imgui/files/imgui-1.48-pkgconfig.patch65
-rw-r--r--media-libs/imgui/imgui-1.48_p20191119.ebuild21
-rw-r--r--media-libs/imgui/metadata.xml7
3 files changed, 93 insertions, 0 deletions
diff --git a/media-libs/imgui/files/imgui-1.48-pkgconfig.patch b/media-libs/imgui/files/imgui-1.48-pkgconfig.patch
new file mode 100644
index 000000000..14744138e
--- /dev/null
+++ b/media-libs/imgui/files/imgui-1.48-pkgconfig.patch
@@ -0,0 +1,65 @@
+Index: imgui-1.73/CMakeLists.txt
+===================================================================
+--- imgui-1.73.orig/CMakeLists.txt
++++ imgui-1.73/CMakeLists.txt
+@@ -7,24 +7,18 @@ but has now been moved into my ImGui for
+
+ set(name ImGui)
+ project(${name} VERSION 0.1.0)
+-include(OpticksBuildOptions)
++include(FindPkgConfig)
++pkg_check_modules(OpticksGLEW REQUIRED glew)
++message(STATUS "ImGui.OpticksGLEW_INCLUDE_DIRS : ${OpticksGLEW_INCLUDE_DIRS}")
++message(STATUS "ImGui.OpticksGLEW_LIBRARIES : ${OpticksGLEW_LIBRARIES}")
+
+-set(OpticksGLEW_VERBOSE ON)
+-find_package(OpticksGLEW REQUIRED MODULE)
+-message(STATUS "ImGui.OpticksGLEW_INCLUDE_DIR : ${OpticksGLEW_INCLUDE_DIR}")
+-message(STATUS "ImGui.OpticksGLEW_LIBRARY : ${OpticksGLEW_LIBRARY}")
++find_package(glfw3 REQUIRED Config)
+
+-find_package(OpticksGLFW REQUIRED MODULE)
+-message(STATUS "ImGui.OpticksGLFW_INCLUDE_DIR : ${OpticksGLFW_INCLUDE_DIR}")
+-message(STATUS "ImGui.OpticksGLFW_LIBRARY : ${OpticksGLFW_LIBRARY}")
+-
+-
+-set(IMGUI_DEFINITIONS
+-)
++set(IMGUI_DEFINITIONS)
+
+ set(LIBRARIES
+- ${OpticksGLEW_LIBRARY}
+- ${OpticksGLFW_LIBRARY}
++ ${OpticksGLEW_LIBRARIES}
++ glfw
+ )
+
+ if(APPLE)
+@@ -92,13 +86,13 @@ set(INCLUDE_DIRS
+ ${CMAKE_CURRENT_BINARY_DIR}
+
+ ${ImGui_SOURCE_DIR}/examples/opengl3_example
+- ${OpticksGLEW_INCLUDE_DIR}
+- ${OpticksGLFW_INCLUDE_DIR}
++ ${OpticksGLEW_INCLUDE_DIRS}
++ ${GLFW_INCLUDE_DIR}
+ )
+
+ set(DEFINITIONS
+ ${OpticksGLEW_DEFINITIONS}
+- ${OpticksGLFW_DEFINITIONS}
++ ${GLFW_DEFINITIONS}
+ ${IMGUI_DEFINITIONS}
+ )
+
+@@ -139,8 +133,8 @@ endif(WIN32)
+
+ target_link_libraries(${name} ${LIBRARIES})
+
+-install(TARGETS ${name} DESTINATION externals/lib)
+-install(FILES ${HEADERS} DESTINATION externals/include/${name})
++install(TARGETS ${name} DESTINATION ${LIBDIR})
++install(FILES ${HEADERS} DESTINATION include/${name})
+
+
+ #[=[
diff --git a/media-libs/imgui/imgui-1.48_p20191119.ebuild b/media-libs/imgui/imgui-1.48_p20191119.ebuild
new file mode 100644
index 000000000..dc521b489
--- /dev/null
+++ b/media-libs/imgui/imgui-1.48_p20191119.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="Bloat-free graphical user interface library for C++"
+HOMEPAGE="https://github.com/simoncblyth/imgui"
+
+EGIT_REPO_URI="https://github.com/simoncblyth/imgui.git"
+EGIT_COMMIT="5df810970fcbd9d96982801745b6340c31b68478"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="media-libs/glew:0"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.48-pkgconfig.patch )
diff --git a/media-libs/imgui/metadata.xml b/media-libs/imgui/metadata.xml
new file mode 100644
index 000000000..7203fb853
--- /dev/null
+++ b/media-libs/imgui/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>heroxbd@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>