aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-10-10 01:12:23 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2012-10-10 01:13:40 +0400
commitc73e1056a82e833291e46dc22e3a92d868389b17 (patch)
tree155bcd49ec5b483e1bf5b8de532746cdc97b70bf
parent[sci-chemistry/xdrfile] actualy allow optional fortran (diff)
downloadsci-c73e1056a82e833291e46dc22e3a92d868389b17.tar.gz
sci-c73e1056a82e833291e46dc22e3a92d868389b17.tar.bz2
sci-c73e1056a82e833291e46dc22e3a92d868389b17.zip
[sci-chemistry/trajng] Add to repo
(Portage version: 2.2.0_alpha135/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--sci-chemistry/trajng/ChangeLog9
-rw-r--r--sci-chemistry/trajng/Manifest1
-rw-r--r--sci-chemistry/trajng/metadata.xml9
-rw-r--r--sci-chemistry/trajng/trajng-0.6.1.ebuild32
4 files changed, 51 insertions, 0 deletions
diff --git a/sci-chemistry/trajng/ChangeLog b/sci-chemistry/trajng/ChangeLog
new file mode 100644
index 000000000..7a23570be
--- /dev/null
+++ b/sci-chemistry/trajng/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-chemistry/trajng
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*trajng-0.6.1 (09 Oct 2012)
+
+ 09 Oct 2012; Alexey Shvetsov <alexxy@gentoo.org> +metadata.xml,
+ +trajng-0.6.1.ebuild:
+ [sci-chemistry/trajng] Add to repo
diff --git a/sci-chemistry/trajng/Manifest b/sci-chemistry/trajng/Manifest
new file mode 100644
index 000000000..513f1086c
--- /dev/null
+++ b/sci-chemistry/trajng/Manifest
@@ -0,0 +1 @@
+DIST trajng-0.6.1.tar.gz 391388 SHA256 32f3fab1c11d5d0957b7d04a85421240dd6ec7bc1d8278a52363d784a6becb4b SHA512 def39733e45763aa919c58ab56206c067996ac557b6a9bdcd81a2c7080c505aabba42ee1aa0ab9cb4086fcf01ad6dfc46aa5645534e366d38f085e5e7216e489 WHIRLPOOL 062f87bad7e9e3f24cf6ce0f38794f004dd441abb6eeae35b43c80a87d29ebb55d764a20fe43f0ee0828e53a885bbc908538b68fe7c05c3486404b3520106e48
diff --git a/sci-chemistry/trajng/metadata.xml b/sci-chemistry/trajng/metadata.xml
new file mode 100644
index 000000000..b2558d8c6
--- /dev/null
+++ b/sci-chemistry/trajng/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/trajng/trajng-0.6.1.ebuild b/sci-chemistry/trajng/trajng-0.6.1.ebuild
new file mode 100644
index 000000000..48fc4cc68
--- /dev/null
+++ b/sci-chemistry/trajng/trajng-0.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="TrajNG - Trajectory compression library"
+HOMEPAGE="http://www.uppmax.uu.se/Members/daniels/trajng-trajectory-compression-library"
+SRC_URI="http://www.uppmax.uu.se/Members/daniels/trajng-trajectory-compression-library/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="fortran mpi"
+
+DEPEND="
+ sci-chemistry/xdrfile
+ fortran? ( virtual/fortran )
+ mpi? ( virtual/mpi )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm -rf "${S}/xdrfile" || die
+}
+
+src_configure() {
+ econf \
+ --with-xdrlib="${EPREFIX}/usr" \
+ $(use_enable fortran) \
+ $(use_enable mpi)
+}