aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-02-08 11:04:11 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-02-08 11:04:11 +0100
commitc901a3e918a37be894738ac50ba0b12752916903 (patch)
tree4ddfa20b42d83e782a749eff421ee13fa659a1de
parentsci-mathematics/why-2.34: Cleanup ebuild (diff)
downloadsci-c901a3e918a37be894738ac50ba0b12752916903.tar.gz
sci-c901a3e918a37be894738ac50ba0b12752916903.tar.bz2
sci-c901a3e918a37be894738ac50ba0b12752916903.zip
sci-mathematics/why3-0.83: Cleanup ebuild
-rw-r--r--sci-mathematics/why3/ChangeLog6
-rw-r--r--sci-mathematics/why3/why3-0.83.ebuild28
2 files changed, 21 insertions, 13 deletions
diff --git a/sci-mathematics/why3/ChangeLog b/sci-mathematics/why3/ChangeLog
index 5fa385ddf..e50e10d4b 100644
--- a/sci-mathematics/why3/ChangeLog
+++ b/sci-mathematics/why3/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-mathematics/why3
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 08 Feb 2015; Marius Brehler <marbre@linux.sungazer.de>
+ why3-0.83.ebuild:
+ Cleanup ebuild
+
16 Sep 2014; Christoph Junghans <ottxor@gentoo.org> why3-0.83.ebuild:
drop autotools.eclass
diff --git a/sci-mathematics/why3/why3-0.83.ebuild b/sci-mathematics/why3/why3-0.83.ebuild
index 61ceaedcf..1abb3d537 100644
--- a/sci-mathematics/why3/why3-0.83.ebuild
+++ b/sci-mathematics/why3/why3-0.83.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="5"
+EAPI=5
inherit eutils
@@ -23,28 +23,32 @@ DEPEND=">=dev-lang/ocaml-3.12.1
doc? ( dev-tex/rubber )"
RDEPEND="${DEPEND}"
+DOCS=( CHANGES README Version )
+
src_prepare() {
- mv doc/why.1 doc/why3.1
- sed -i configure.in -e "s/\"pvs\"/\"sri-pvs\"/g"
- sed -i configure -e "s/\"pvs\"/\"sri-pvs\"/g"
+ mv doc/why.1 doc/why3.1 || die
+ sed -i configure.in -e "s/\"pvs\"/\"sri-pvs\"/g" || die
+ sed -i configure -e "s/\"pvs\"/\"sri-pvs\"/g" || die
sed -i Makefile.in -e "s:DESTDIR =::g" \
- -e "s:\$(RUBBER) --warn all --pdf manual.tex:makeindex manual.tex; \$(RUBBER) --warn all --pdf manual.tex; cd ..:g"
+ -e "s:\$(RUBBER) --warn all --pdf manual.tex:makeindex manual.tex; \$(RUBBER) --warn all --pdf manual.tex; cd ..:g" || die
}
src_configure() {
- econf $(use_enable frama-c) || die "econf failed"
+ econf $(use_enable frama-c)
}
src_compile() {
- emake -j1 || die "emake failed"
+ MAKEOPTS+=" -j1"
+
+ emake
if use doc; then
- emake -j1 doc/manual.pdf || die "emake doc failed"
+ emake doc/manual.pdf
fi
}
src_install(){
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc CHANGES README Version
+ default
+
doman doc/why3.1
if use doc; then
dodoc doc/manual.pdf
@@ -53,4 +57,4 @@ src_install(){
insinto /usr/share/doc/${PF}
doins -r examples
fi
- }
+}