aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-09-22 16:38:40 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-09-22 16:38:40 +0200
commitcf8718a9f41790362a7c756ecce5f12148e23e34 (patch)
treea9fb0035aae4661b899ab3a47332b969e90564ad
parentsci-biology/signalp: Add Manifest back (diff)
parentdev-python/ipywidgets: Add javascript tests (diff)
downloadsci-cf8718a9f41790362a7c756ecce5f12148e23e34.tar.gz
sci-cf8718a9f41790362a7c756ecce5f12148e23e34.tar.bz2
sci-cf8718a9f41790362a7c756ecce5f12148e23e34.zip
Merge branch 'flacjacket-jupyter_js_tests_master'
-rw-r--r--dev-python/ipywidgets/ChangeLog4
-rw-r--r--dev-python/ipywidgets/ipywidgets-4.0.3.ebuild3
-rw-r--r--dev-python/ipywidgets/ipywidgets-9999.ebuild3
-rw-r--r--dev-python/notebook/ChangeLog4
-rw-r--r--dev-python/notebook/notebook-4.0.5.ebuild6
-rw-r--r--dev-python/notebook/notebook-9999.ebuild6
-rw-r--r--www-client/casperjs/ChangeLog9
-rw-r--r--www-client/casperjs/Manifest1
-rw-r--r--www-client/casperjs/casperjs-1.1_beta3.ebuild41
-rw-r--r--www-client/casperjs/metadata.xml8
10 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/ChangeLog b/dev-python/ipywidgets/ChangeLog
index 747b0b3cc..7b0819da0 100644
--- a/dev-python/ipywidgets/ChangeLog
+++ b/dev-python/ipywidgets/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 03 Sep 2015; Sean Vig <sean.v.775@gmail.com> ipywidgets-4.0.3,
+ ipywidgets-9999.ebuild:
+ dev-python/ipywidgets: Add javascript tests
+
22 Sep 2015; Marius Brehler <marbre@linux.sungazer.de>
ipywidgets-4.0.3.ebuild:
dev-python/ipywidgets: Add ~x86 to KEYWORDS
diff --git a/dev-python/ipywidgets/ipywidgets-4.0.3.ebuild b/dev-python/ipywidgets/ipywidgets-4.0.3.ebuild
index a295a6959..3c3d2165a 100644
--- a/dev-python/ipywidgets/ipywidgets-4.0.3.ebuild
+++ b/dev-python/ipywidgets/ipywidgets-4.0.3.ebuild
@@ -31,9 +31,12 @@ DEPEND="${RDEPEND}
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
+ www-client/casperjs
)
"
python_test() {
nosetests --with-coverage --cover-package=ipywidgets ipywidgets || die
+
+ "${PYTHON}" -m ipywidgets.jstest || die
}
diff --git a/dev-python/ipywidgets/ipywidgets-9999.ebuild b/dev-python/ipywidgets/ipywidgets-9999.ebuild
index a295a6959..3c3d2165a 100644
--- a/dev-python/ipywidgets/ipywidgets-9999.ebuild
+++ b/dev-python/ipywidgets/ipywidgets-9999.ebuild
@@ -31,9 +31,12 @@ DEPEND="${RDEPEND}
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
+ www-client/casperjs
)
"
python_test() {
nosetests --with-coverage --cover-package=ipywidgets ipywidgets || die
+
+ "${PYTHON}" -m ipywidgets.jstest || die
}
diff --git a/dev-python/notebook/ChangeLog b/dev-python/notebook/ChangeLog
index 2d7e2ea93..215864292 100644
--- a/dev-python/notebook/ChangeLog
+++ b/dev-python/notebook/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 03 Sep 2015; Sean Vig <sean.v.775@gmail.com> notebook-4.0.5.ebuild,
+ notebook-9999.ebuild:
+ dev-python/notebook: Add javascript tests
+
*notebook-4.0.5 (22 Sep 2015)
22 Sep 2015; Marius Brehler <marbre@linux.sungazer.de> +notebook-4.0.5.ebuild:
diff --git a/dev-python/notebook/notebook-4.0.5.ebuild b/dev-python/notebook/notebook-4.0.5.ebuild
index 1989a1a0e..80fa9fc1f 100644
--- a/dev-python/notebook/notebook-4.0.5.ebuild
+++ b/dev-python/notebook/notebook-4.0.5.ebuild
@@ -35,6 +35,7 @@ DEPEND="${RDEPEND}
>=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
+ www-client/casperjs
)
doc? (
app-text/pandoc
@@ -66,6 +67,11 @@ python_compile_all() {
python_test() {
nosetests --with-coverage --cover-package=notebook notebook || die
+
+ "${PYTHON}" -m notebook.jstest base || die
+ "${PYTHON}" -m notebook.jstest notebook || die
+ "${PYTHON}" -m notebook.jstest services || die
+ "${PYTHON}" -m notebook.jstest tree || die
}
python_install() {
diff --git a/dev-python/notebook/notebook-9999.ebuild b/dev-python/notebook/notebook-9999.ebuild
index 0d2e0f910..d5ab6df53 100644
--- a/dev-python/notebook/notebook-9999.ebuild
+++ b/dev-python/notebook/notebook-9999.ebuild
@@ -34,6 +34,7 @@ DEPEND="${RDEPEND}
>=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
+ www-client/casperjs
)
doc? (
app-text/pandoc
@@ -65,6 +66,11 @@ python_compile_all() {
python_test() {
nosetests --with-coverage --cover-package=notebook notebook || die
+
+ "${PYTHON}" -m notebook.jstest base || die
+ "${PYTHON}" -m notebook.jstest notebook || die
+ "${PYTHON}" -m notebook.jstest services || die
+ "${PYTHON}" -m notebook.jstest tree || die
}
python_install() {
diff --git a/www-client/casperjs/ChangeLog b/www-client/casperjs/ChangeLog
new file mode 100644
index 000000000..eb4d1f336
--- /dev/null
+++ b/www-client/casperjs/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for www-client/casperjs
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Id$
+
+*casperjs-1.1_beta3 (02 Sep 2015)
+
+ 02 Sep 2015; Sean Vig <sean.v.775@gmail.com> +casperjs-1.1_beta3.ebuild,
+ +metadata.xml:
+ www-client/casperjs: Initial ebuild
diff --git a/www-client/casperjs/Manifest b/www-client/casperjs/Manifest
new file mode 100644
index 000000000..d3943fbcd
--- /dev/null
+++ b/www-client/casperjs/Manifest
@@ -0,0 +1 @@
+DIST casperjs-1.1_beta3.tar.gz 652836 SHA256 bc286424fb52df6cf16cb9b8ef6534ee830bb8ab0b87d2625910d8c1824152dc SHA512 8965ff7edc2728fed6ce18f43cc82f27330134d6442ef1e91e484b472a259461f6c841cbec1c86c773a7ccf0d3cb08be68a5287a868cb88f40ef114fab92b35e WHIRLPOOL bd4e8423c2fb52d30ac381d0ec67650a63edb3df703136a9b3093804d7883fb8510af071ff2ec7071ec88b7a12942f9cdf3193cfa772ef449b1213759adead62
diff --git a/www-client/casperjs/casperjs-1.1_beta3.ebuild b/www-client/casperjs/casperjs-1.1_beta3.ebuild
new file mode 100644
index 000000000..b4145b8df
--- /dev/null
+++ b/www-client/casperjs/casperjs-1.1_beta3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v3
+# $Id$
+
+EAPI=5
+
+MY_PV=${PV/_beta/-beta}
+
+DESCRIPTION="Navigation scripting & testing utility for PhantomJS and SlimerJS"
+HOMEPAGE="http://casperjs.org/"
+SRC_URI="https://github.com/n1k0/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="<www-client/phantomjs-2.0.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ return
+}
+
+src_install() {
+ insinto /usr/share/${P}/
+ doins -r modules/
+ doins -r tests/
+ doins package.json
+
+ insinto /usr/share/${P}/bin
+ doins bin/bootstrap.js
+ doins bin/usage.txt
+
+ dobin bin/casperjs
+ dosym /usr/bin/casperjs ../share/${P}/bin/casperjs
+
+ dodoc CHANGELOG.md CONTRIBUTORS.md README.md
+}
diff --git a/www-client/casperjs/metadata.xml b/www-client/casperjs/metadata.xml
new file mode 100644
index 000000000..acad08b5a
--- /dev/null
+++ b/www-client/casperjs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <upstream>
+ <remote-id type="github">n1k0/casperjs</remote-id>
+ </upstream>
+</pkgmetadata>