aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-28 18:49:58 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-28 18:49:58 +0100
commitd0bb74dd3ecea6635b4b088d00fa1c3c7cbb8a90 (patch)
treeb240f7b5d8f5b7eaf8488f9ce89dbe58be37ea7e
parentLarge fix of numeric code (diff)
downloadsci-d0bb74dd3ecea6635b4b088d00fa1c3c7cbb8a90.tar.gz
sci-d0bb74dd3ecea6635b4b088d00fa1c3c7cbb8a90.tar.bz2
sci-d0bb74dd3ecea6635b4b088d00fa1c3c7cbb8a90.zip
sci-libs/clblas: QA: Style fixes and add missing PYTHON_REQUIRED_USE
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-libs/clblas/Manifest1
-rw-r--r--sci-libs/clblas/clblas-2.4-r1.ebuild63
-rw-r--r--sci-libs/clblas/clblas-2.6.ebuild10
-rw-r--r--sci-libs/clblas/clblas-9999.ebuild11
-rw-r--r--sci-libs/clblas/files/clblas-2.4-Install-cmake-configuration-to-lib-cmake-clBLAS.patch25
-rw-r--r--sci-libs/clblas/files/clblas-2.4-samples_CMakeLists.patch20
-rw-r--r--sci-libs/clblas/files/clblas-2.4-scripts_perf_CMakeLists.patch11
7 files changed, 13 insertions, 128 deletions
diff --git a/sci-libs/clblas/Manifest b/sci-libs/clblas/Manifest
index e2810c287..9036f563f 100644
--- a/sci-libs/clblas/Manifest
+++ b/sci-libs/clblas/Manifest
@@ -1,2 +1 @@
-DIST clblas-2.4.tar.gz 800848 SHA256 3e9b8e138c465df1daff0235d9c93b0005986a7257a3739aea2d4c8b60b7ed37 SHA512 ae8c1fc1bef7573b12279977fc32f9e97c9b81b9167994ca6f352587a670dcee0f486ab2b7d5191092324f5e8fc00f9a2ea29303a026a0c1201be31d384cafe7 WHIRLPOOL a97537d7390055ad608eeac66679362956db7acfa96cf1165581ff8f9adfe309b8ff8231225bd8ca6247c8f588bff24d6f648e131cec52f8e3093168a3f26f82
DIST clblas-2.6.tar.gz 954586 SHA256 4607561a648949709bc7c368be4aaf7346174406e678454b643e31cfe861830c SHA512 76756707c8a217b926dff4c288ce48700e21a80650e14b25f81615b25bb81c47e328900e94712ba9bcd5690f29647b4782157df85623cfe1c696f3698fcd62d6 WHIRLPOOL e1a8f596a187216b69a339919601dec978ad43728f9a5965454139d53391a2ac25314d6be28eef52cfdff43551d72f07b0bf6145a931d643731f5969b7f13379
diff --git a/sci-libs/clblas/clblas-2.4-r1.ebuild b/sci-libs/clblas/clblas-2.4-r1.ebuild
deleted file mode 100644
index 140cd9b39..000000000
--- a/sci-libs/clblas/clblas-2.4-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-single-r1
-
-MY_PN="clBLAS"
-
-DESCRIPTION="A software library containing BLAS routines for OpenCL"
-HOMEPAGE="https://github.com/clMathLibraries/clBLAS"
-SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-S="${WORKDIR}/${MY_PN}-${PV}/src"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+client examples +ktest performance test"
-
-RDEPEND="
- >=sys-devel/gcc-4.6:*
- virtual/opencl
- || ( >=dev-util/amdapp-2.9 dev-util/intel-ocl-sdk )
- dev-libs/boost
- performance? ( ${PYTHON_DEPS} )
- "
-DEPEND="${RDEPEND}"
-# test? (
-# >=dev-cpp/gtest-1.6.0
-# >=sci-libs/acml-6.1.0.3
-# )"
-
-# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
-# Therefore src_test() won't execute any test.
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${P}"-samples_CMakeLists.patch
- "${FILESDIR}/${P}"-scripts_perf_CMakeLists.patch
- "${FILESDIR}/${P}"-Install-cmake-configuration-to-lib-cmake-clBLAS.patch
-)
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
- die "Compilation with gcc older than 4.6 is not supported."
- fi
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_build client CLIENT)
- $(cmake-utils_use_build examples SAMPLE)
- $(cmake-utils_use_build ktest KTEST)
- $(cmake-utils_use_build performance PERFORMANCE)
- $(cmake-utils_use_build test TEST)
- )
- cmake-utils_src_configure
-}
diff --git a/sci-libs/clblas/clblas-2.6.ebuild b/sci-libs/clblas/clblas-2.6.ebuild
index 2a7b07bd8..d060857f0 100644
--- a/sci-libs/clblas/clblas-2.6.ebuild
+++ b/sci-libs/clblas/clblas-2.6.ebuild
@@ -13,18 +13,18 @@ MY_PN="clBLAS"
DESCRIPTION="A software library containing BLAS routines for OpenCL"
HOMEPAGE="https://github.com/clMathLibraries/clBLAS"
SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-S="${WORKDIR}/${MY_PN}-${PV}/src"
LICENSE="Apache-2.0"
SLOT="0"
+KEYWORDS="~amd64"
IUSE="+client examples +ktest performance test"
+REQUIRED_USE="performance? ( ${PYTHON_REQUIRED_USE} )"
+
RDEPEND="
- >=sys-devel/gcc-4.6:*
+ dev-libs/boost
virtual/opencl
|| ( >=dev-util/amdapp-2.9 dev-util/intel-ocl-sdk )
- dev-libs/boost
performance? ( ${PYTHON_DEPS} )
"
DEPEND="${RDEPEND}"
@@ -37,6 +37,8 @@ DEPEND="${RDEPEND}"
# Therefore src_test() won't execute any test.
RESTRICT="test"
+S="${WORKDIR}/${MY_PN}-${PV}/src"
+
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
diff --git a/sci-libs/clblas/clblas-9999.ebuild b/sci-libs/clblas/clblas-9999.ebuild
index 8df3ef80d..4a25302c7 100644
--- a/sci-libs/clblas/clblas-9999.ebuild
+++ b/sci-libs/clblas/clblas-9999.ebuild
@@ -12,18 +12,19 @@ MY_PN="clBLAS"
DESCRIPTION="A software library containing BLAS routines for OpenCL"
HOMEPAGE="https://github.com/clMathLibraries/clBLAS"
-EGIT_REPO_URI="https://github.com/clMathLibraries/${MY_PN}.git git://github.com/clMathLibraries/${MY_PN}.git"
-S="${WORKDIR}/${P}/src"
+EGIT_REPO_URI="https://github.com/clMathLibraries/${MY_PN}.git"
LICENSE="Apache-2.0"
SLOT="0"
+KEYWORDS=""
IUSE="+client examples +ktest performance test"
+REQUIRED_USE="performance? ( ${PYTHON_REQUIRED_USE} )"
+
RDEPEND="
- >=sys-devel/gcc-4.6:*
+ dev-libs/boost
virtual/opencl
|| ( >=dev-util/amdapp-2.9 dev-util/intel-ocl-sdk )
- dev-libs/boost
performance? ( ${PYTHON_DEPS} )
"
DEPEND="${RDEPEND}"
@@ -36,6 +37,8 @@ DEPEND="${RDEPEND}"
# Therefore src_test() won't execute any test.
RESTRICT="test"
+S="${WORKDIR}/${P}/src"
+
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
diff --git a/sci-libs/clblas/files/clblas-2.4-Install-cmake-configuration-to-lib-cmake-clBLAS.patch b/sci-libs/clblas/files/clblas-2.4-Install-cmake-configuration-to-lib-cmake-clBLAS.patch
deleted file mode 100644
index 32cb7b553..000000000
--- a/sci-libs/clblas/files/clblas-2.4-Install-cmake-configuration-to-lib-cmake-clBLAS.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From b83750ab917b12500f9755dc4c81f99eb55bb67e Mon Sep 17 00:00:00 2001
-From: Marius Brehler <marius.brehler@tu-dortmund.de>
-Date: Sat, 6 Jun 2015 10:35:32 +0200
-Subject: [PATCH] Install cmake configuration to lib/cmake/clBLAS
-
----
- src/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index a23cd37..5c378dc 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -300,7 +300,7 @@ endif( )
- if(WIN32)
- set(destdir CMake)
- else()
-- set(destdir share/clBLAS)
-+ set(destdir lib${SUFFIX_LIB}/cmake/clBLAS)
- endif()
- string(REGEX REPLACE "[^/]+" ".." reldir "${destdir}")
- configure_file(
---
-2.3.6
-
diff --git a/sci-libs/clblas/files/clblas-2.4-samples_CMakeLists.patch b/sci-libs/clblas/files/clblas-2.4-samples_CMakeLists.patch
deleted file mode 100644
index 8b5a762b1..000000000
--- a/sci-libs/clblas/files/clblas-2.4-samples_CMakeLists.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Install samples to /usr/share/clBLAS/samples.
-
-Patch by Marius Brehler.
---- samples/CMakeLists.txt
-+++ samples/CMakeLists.txt
-@@ -274,7 +274,7 @@ install( TARGETS example_sgemm example_s
- example_snrm2 example_sasum example_isamax
-
- version
-- RUNTIME DESTINATION bin${SUFFIX_BIN}
-+ RUNTIME DESTINATION share/clBLAS/samples
- LIBRARY DESTINATION lib${SUFFIX_LIB}
- ARCHIVE DESTINATION lib${SUFFIX_LIB}/import
- )
-@@ -333,4 +333,4 @@ install(FILES
- ${PROJECT_BINARY_DIR}/samples/CMakeLists.txt
-
- DESTINATION
-- samples )
-+ share/clBLAS/samples/src )
diff --git a/sci-libs/clblas/files/clblas-2.4-scripts_perf_CMakeLists.patch b/sci-libs/clblas/files/clblas-2.4-scripts_perf_CMakeLists.patch
deleted file mode 100644
index 7b9b58d97..000000000
--- a/sci-libs/clblas/files/clblas-2.4-scripts_perf_CMakeLists.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-Install Python scripts to /usr/share/clBLAS and not to /usr/bin.
-
-Patch by Marius Brehler.
---- scripts/perf/CMakeLists.txt
-+++ scripts/perf/CMakeLists.txt
-@@ -21,4 +21,4 @@ set(GRAPHING_SCRIPTS measurePerformance
- performanceUtility.py
- )
-
--install( FILES ${GRAPHING_SCRIPTS} DESTINATION bin${SUFFIX_BIN} )
-+install( FILES ${GRAPHING_SCRIPTS} DESTINATION share/clBLAS )