aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-12-24 11:55:09 -0700
committerChristoph Junghans <ottxor@gentoo.org>2014-12-24 11:55:09 -0700
commitd17596dfb35794436e9a10247efec06eb269de41 (patch)
tree65d73ce3f132411ba4c0bb2e4959276722f4b1b4
parentMerge branch 'master' of ssh://github.com/gentoo-science/sci (diff)
downloadsci-d17596dfb35794436e9a10247efec06eb269de41.tar.gz
sci-d17596dfb35794436e9a10247efec06eb269de41.tar.bz2
sci-d17596dfb35794436e9a10247efec06eb269de41.zip
remove old
Package-Manager: portage-2.2.14
-rw-r--r--sys-cluster/hpx/ChangeLog4
-rw-r--r--sys-cluster/hpx/Manifest2
-rw-r--r--sys-cluster/hpx/hpx-0.9.7.ebuild93
-rw-r--r--sys-cluster/hpx/hpx-0.9.8.ebuild93
4 files changed, 4 insertions, 188 deletions
diff --git a/sys-cluster/hpx/ChangeLog b/sys-cluster/hpx/ChangeLog
index a13a6bec9..a5e7b9b76 100644
--- a/sys-cluster/hpx/ChangeLog
+++ b/sys-cluster/hpx/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 24 Dec 2014; Christoph Junghans <ottxor@gentoo.org> -Manifest,
+ -hpx-0.9.7.ebuild, -hpx-0.9.8.ebuild:
+ remove old
+
24 Dec 2014; Christoph Junghans <ottxor@gentoo.org> hpx-9999.ebuild:
fixed deps (bug #529066)
diff --git a/sys-cluster/hpx/Manifest b/sys-cluster/hpx/Manifest
deleted file mode 100644
index af0dedf44..000000000
--- a/sys-cluster/hpx/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST hpx_0.9.7.7z 2416122 SHA256 95fa108a6ba6cd3a3afc117d508936d1c070cc7e83a592f62815a6a11378882a SHA512 eb258e94facaaba29729ebca63640ab5feda156ee860153848ca1143266b8365bc9cc772eb6d6f56f884af43531efb1b77fa84ca4c6e185882cbf031ac794a7b WHIRLPOOL c5432a608a90a732ed7ec08f980d3d2f7f99a3bd5b83867db26190877120b76f0b46f6fd3e9bbc97bfb9637e6c951c9dd449c0f6c767bb11eca1e0212f488d88
-DIST hpx_0.9.8.7z 2089649 SHA256 9e04685b07e4155e6d3e00c944e5fe91c0c815a2b3bc7bc345eb59d8708bac91 SHA512 1789582ee776173d4aa67b512d2df225c734b98ffe59a8f1eee38b5112ac7c02e0c7c478f72062e5b6a5d5053ce1848729c374093378f63200acf51a208fb3c7 WHIRLPOOL b4b5a8a83aa4d07466ee0570b9fdadd906281e626eed2ce82e3a8e03681de1591a46af2254cbd387eb2d0bfac22c6796537fbbb37764be7dd424b97dd0d433c7
diff --git a/sys-cluster/hpx/hpx-0.9.7.ebuild b/sys-cluster/hpx/hpx-0.9.7.ebuild
deleted file mode 100644
index 738ed1679..000000000
--- a/sys-cluster/hpx/hpx-0.9.7.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-if [ ${PV} == "9999" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
- SRC_URI=""
- KEYWORDS=""
- S="${WORKDIR}/${PN}"
- CMAKE_USE_DIR="${S}"
-else
- SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.7z"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${PN}_${PV}"
-fi
-
-inherit cmake-utils fortran-2 python-single-r1
-
-DESCRIPTION="C++ runtime system for parallel and distributed applications"
-HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
-
-SLOT="0"
-LICENSE="Boost-1.0"
-IUSE="doc examples jemalloc papi +perftools tbb test"
-
-# TODO: some of the forced deps are may be optional
-# it would need to work the automagic
-RDEPEND="
- >=dev-libs/boost-1.51
- dev-libs/libxml2
- sci-libs/hdf5
- >=sys-apps/hwloc-1.8
- >=sys-libs/libunwind-1
- sys-libs/zlib
- jemalloc? ( dev-libs/jemalloc )
- papi? ( dev-libs/papi )
- perftools? ( >=dev-util/google-perftools-1.7.1 )
- tbb? ( dev-cpp/tbb )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-lang/python )
-"
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=(
- "${FILESDIR}"/hpx-0.9.5-install-path.patch
- "${FILESDIR}"/hpx-0.9.7-move-boost-include.patch
-)
-
-pkg_setup() {
- use test && python-single-r1_pkg_setup
-}
-
-src_configure() {
- CMAKE_BUILD_TYPE=Release
- local mycmakeargs=(
- -DHPX_BUILD_EXAMPLES=OFF
- $(cmake-utils_use doc HPX_BUILD_DOCUMENTATION)
- $(cmake-utils_use jemalloc HPX_JEMALLOC)
- $(cmake-utils_use test BUILD_TESTING)
- $(cmake-utils_use perftools HPX_GOOGLE_PERFTOOLS)
- $(cmake-utils_use papi HPX_PAPI)
- )
- if use perftools; then
- mycmakeargs+=( -DHPX_MALLOC=tcmalloc )
- elif use jemalloc; then
- mycmakeargs+=( -DHPX_MALLOC=jemalloc )
- elif use tbb; then
- mycmakeargs+=( -DHPX_MALLOC=tbbmalloc )
- else
- mycmakeargs+=( -DHPX_MALLOC=system )
- fi
- cmake-utils_src_configure
-}
-
-src_test() {
- # avoid over-suscribing
- cmake-utils_src_make -j1 tests
-}
-
-src_install() {
- cmake-utils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/sys-cluster/hpx/hpx-0.9.8.ebuild b/sys-cluster/hpx/hpx-0.9.8.ebuild
deleted file mode 100644
index ac3aad76f..000000000
--- a/sys-cluster/hpx/hpx-0.9.8.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-if [ ${PV} == "9999" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
- KEYWORDS=""
- S="${WORKDIR}/${PN}"
-else
- SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.7z"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${PN}_${PV}"
- PATCHES=(
- "${FILESDIR}"/${P}-install-path.patch
- "${FILESDIR}"/${P}-multilib.patch
- "${FILESDIR}"/${P}-cmake_dir.patch
- )
-fi
-
-inherit cmake-utils fortran-2 multilib python-single-r1
-
-DESCRIPTION="C++ runtime system for parallel and distributed applications"
-HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
-
-SLOT="0"
-LICENSE="Boost-1.0"
-IUSE="doc examples jemalloc papi +perftools tbb test"
-
-# TODO: some of the forced deps are may be optional
-# it would need to work the automagic
-RDEPEND="
- >=dev-libs/boost-1.51
- dev-libs/libxml2
- sci-libs/hdf5
- >=sys-apps/hwloc-1.8
- >=sys-libs/libunwind-1
- sys-libs/zlib
- papi? ( dev-libs/papi )
- perftools? ( >=dev-util/google-perftools-1.7.1 )
- tbb? ( dev-cpp/tbb )
-"
-DEPEND="${RDEPEND}
- app-arch/p7zip
- virtual/pkgconfig
- test? ( dev-lang/python )
-"
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_setup() {
- use test && python-single-r1_pkg_setup
-}
-
-src_configure() {
- CMAKE_BUILD_TYPE=Release
- local mycmakeargs=(
- -DHPX_BUILD_EXAMPLES=OFF
- -DLIB=$(get_libdir)
- -Dcmake_dir=cmake
- $(cmake-utils_use doc HPX_BUILD_DOCUMENTATION)
- $(cmake-utils_use jemalloc HPX_JEMALLOC)
- $(cmake-utils_use test BUILD_TESTING)
- $(cmake-utils_use perftools HPX_GOOGLE_PERFTOOLS)
- $(cmake-utils_use papi HPX_PAPI)
- )
- if use perftools; then
- mycmakeargs+=( -DHPX_MALLOC=tcmalloc )
- elif use jemalloc; then
- mycmakeargs+=( -DHPX_MALLOC=jemalloc )
- elif use tbb; then
- mycmakeargs+=( -DHPX_MALLOC=tbbmalloc )
- else
- mycmakeargs+=( -DHPX_MALLOC=system )
- fi
- cmake-utils_src_configure
-}
-
-src_test() {
- # avoid over-suscribing
- cmake-utils_src_make -j1 tests
-}
-
-src_install() {
- cmake-utils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}