aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-07 11:06:54 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-07 11:06:54 +0200
commitd2f198644a8ad262dc36fc03e4076f44a4303a31 (patch)
treeb075b461b3eb3292d7a3b09fe3a5845427167018
parentprofiles: unmask dev-python/{numba,llvmlite} (diff)
downloadsci-d2f198644a8ad262dc36fc03e4076f44a4303a31.tar.gz
sci-d2f198644a8ad262dc36fc03e4076f44a4303a31.tar.bz2
sci-d2f198644a8ad262dc36fc03e4076f44a4303a31.zip
dev-python/llvmlite: drop 0.37.0-r1, 0.38.0-r1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/llvmlite/Manifest2
-rw-r--r--dev-python/llvmlite/files/llvmlite-0.37.0-llvm12.patch91
-rw-r--r--dev-python/llvmlite/files/llvmlite-0.38.0-llvm12.patch92
-rw-r--r--dev-python/llvmlite/llvmlite-0.37.0-r1.ebuild62
-rw-r--r--dev-python/llvmlite/llvmlite-0.38.0-r1.ebuild62
5 files changed, 0 insertions, 309 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index febabbdca..1749985b0 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -1,3 +1 @@
-DIST llvmlite-0.37.0.gh.tar.gz 223602 BLAKE2B 74f975d5ac1782528f60f1c0d5c6230a02953e0d494d8323e4caa6651f642ad791ad51df44f6593da41edc5c34bd883f144e95b16f9b8962393d16de013fdbc5 SHA512 665f486fd38c9cc4ee91b15fc75f33451ada6391fc9f1b371091ece844693e0cd8e23766400bf76d9879e8f10f53f4e21f8bb19f3ff1e01c4a95ce9004b0884a
-DIST llvmlite-0.38.0.gh.tar.gz 230044 BLAKE2B b027f34a6ba4c6d8a4fe8963501a49b1f87cc86976c131c94c597383ab47aef1faf6bb05f27f148f03b2d6673e12b04fdfbdab20658de32b18c257bb1cd16fee SHA512 014e2ba08a451ff8bb76ea4b25d2d6605bc048cae560ad367a3bb3afd13421aaf151862116e73e7606d800638d2a2df713cc0e187a6acc483b80df1290c81743
DIST llvmlite-0.39.0.gh.tar.gz 237009 BLAKE2B 41e485c636d285d039cd559c6386f79d05d51c266b31e24c68a30a921e9131d422e5782befdbdac7407b61fd44cab4b14863fdefa1c76ced235dd89eb0328110 SHA512 3493afc14c08b06bfb26230409d678b9a72d3957e412a4a6a6367aea0bc743fc46191ba050aa70e403424567038ab9fc2721c839df8035e4511dbf9ee4caddfa
diff --git a/dev-python/llvmlite/files/llvmlite-0.37.0-llvm12.patch b/dev-python/llvmlite/files/llvmlite-0.37.0-llvm12.patch
deleted file mode 100644
index ed104ab99..000000000
--- a/dev-python/llvmlite/files/llvmlite-0.37.0-llvm12.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From 1d928ebcd59b23b5050234a2bf71f9be7f5f6bd1 Mon Sep 17 00:00:00 2001
-From: Richard Barnes <rbarnes@umn.edu>
-Date: Wed, 1 Dec 2021 10:29:08 -0700
-Subject: [PATCH] Enable LLVM-12 and LLVM-13
-
----
- ffi/build.py | 5 ++---
- ffi/targets.cpp | 2 ++
- llvmlite/tests/test_binding.py | 19 ++++++++++++++++---
- 3 files changed, 20 insertions(+), 6 deletions(-)
-
-diff --git a/ffi/build.py b/ffi/build.py
-index 6408bf5f..95e33c64 100755
---- a/ffi/build.py
-+++ b/ffi/build.py
-@@ -162,9 +162,8 @@ def main_posix(kind, library_ext):
- print(msg)
- print(warning + '\n')
- else:
--
-- if not out.startswith('11'):
-- msg = ("Building llvmlite requires LLVM 11.x.x, got "
-+ if not (out.startswith('11') or out.startswith('12') or out.startswith('13')):
-+ msg = ("Building llvmlite requires LLVM 11-13.x.x, got "
- "{!r}. Be sure to set LLVM_CONFIG to the right executable "
- "path.\nRead the documentation at "
- "http://llvmlite.pydata.org/ for more information about "
-diff --git a/ffi/targets.cpp b/ffi/targets.cpp
-index 1ce472c2..4ba33e79 100644
---- a/ffi/targets.cpp
-+++ b/ffi/targets.cpp
-@@ -233,6 +233,8 @@ LLVMPY_CreateTargetMachine(LLVMTargetRef T,
- rm = Reloc::DynamicNoPIC;
-
- TargetOptions opt;
-+#if LLVM_VERSION_MAJOR < 12
- opt.PrintMachineCode = PrintMC;
-+#endif
-
- bool jit = JIT;
-diff --git a/llvmlite/tests/test_binding.py b/llvmlite/tests/test_binding.py
-index 80495787..fee2372a 100644
---- a/llvmlite/tests/test_binding.py
-+++ b/llvmlite/tests/test_binding.py
-@@ -18,6 +18,16 @@
- from llvmlite.tests import TestCase
-
-
-+def clean_string_whitespace(x: str) -> str:
-+ # Remove trailing whitespace from the end of each line
-+ x = re.sub(r"\s+$", "", x, flags=re.MULTILINE)
-+ # Remove intermediate blank lines
-+ x = re.sub(r"\n\s*\n", r"\n", x, flags=re.MULTILINE)
-+ # Remove extraneous whitespace from the beginning and end of the string
-+ x = x.strip()
-+ return x
-+
-+
- # arvm7l needs extra ABI symbols to link successfully
- if platform.machine() == 'armv7l':
- llvm.load_library_permanently('libgcc_s.so.1')
-@@ -158,7 +168,7 @@ def no_de_locale():
- target triple = "unknown-unknown-unknown"
- target datalayout = ""
-
--define i32 @"foo"()
-+define i32 @"foo"()
- {
- "<>!*''#":
- ret i32 12345
-@@ -424,7 +434,10 @@ def test_nonalphanum_block_name(self):
- bd = ir.IRBuilder(fn.append_basic_block(name="<>!*''#"))
- bd.ret(ir.Constant(ir.IntType(32), 12345))
- asm = str(mod)
-- self.assertEqual(asm, asm_nonalphanum_blocklabel)
-+ self.assertEqual(
-+ clean_string_whitespace(asm),
-+ clean_string_whitespace(asm_nonalphanum_blocklabel)
-+ )
-
- def test_global_context(self):
- gcontext1 = llvm.context.get_global_context()
-@@ -509,7 +522,7 @@ def test_set_option(self):
- def test_version(self):
- major, minor, patch = llvm.llvm_version_info
- # one of these can be valid
-- valid = [(11,)]
-+ valid = [(11,), (12,), (13,)]
- self.assertIn((major,), valid)
- self.assertIn(patch, range(10))
-
diff --git a/dev-python/llvmlite/files/llvmlite-0.38.0-llvm12.patch b/dev-python/llvmlite/files/llvmlite-0.38.0-llvm12.patch
deleted file mode 100644
index 6630652c2..000000000
--- a/dev-python/llvmlite/files/llvmlite-0.38.0-llvm12.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-From 1d928ebcd59b23b5050234a2bf71f9be7f5f6bd1 Mon Sep 17 00:00:00 2001
-From: Richard Barnes <rbarnes@umn.edu>
-Date: Wed, 1 Dec 2021 10:29:08 -0700
-Subject: [PATCH] Enable LLVM-12 and LLVM-13
-
----
- ffi/build.py | 5 ++---
- ffi/targets.cpp | 2 ++
- llvmlite/tests/test_binding.py | 19 ++++++++++++++++---
- 3 files changed, 20 insertions(+), 6 deletions(-)
-
-diff --git a/ffi/build.py b/ffi/build.py
-index 6408bf5f..95e33c64 100755
---- a/ffi/build.py
-+++ b/ffi/build.py
-@@ -162,9 +162,8 @@ def main_posix(kind, library_ext):
- print(msg)
- print(warning + '\n')
- else:
--
-- if not out.startswith('11'):
-- msg = ("Building llvmlite requires LLVM 11.x.x, got "
-+ if not (out.startswith('11') or out.startswith('12') or out.startswith('13')):
-+ msg = ("Building llvmlite requires LLVM 11-13.x.x, got "
- "{!r}. Be sure to set LLVM_CONFIG to the right executable "
- "path.\nRead the documentation at "
- "http://llvmlite.pydata.org/ for more information about "
-diff --git a/ffi/targets.cpp b/ffi/targets.cpp
-index 1ce472c2..4ba33e79 100644
---- a/ffi/targets.cpp
-+++ b/ffi/targets.cpp
-@@ -233,7 +233,9 @@ LLVMPY_CreateTargetMachine(LLVMTargetRef T,
- rm = Reloc::DynamicNoPIC;
-
- TargetOptions opt;
-+#if LLVM_VERSION_MAJOR < 12
- opt.PrintMachineCode = PrintMC;
-+#endif
- opt.MCOptions.ABIName = ABIName;
-
- bool jit = JIT;
-diff --git a/llvmlite/tests/test_binding.py b/llvmlite/tests/test_binding.py
-index 80495787..fee2372a 100644
---- a/llvmlite/tests/test_binding.py
-+++ b/llvmlite/tests/test_binding.py
-@@ -18,6 +18,16 @@
- from llvmlite.tests import TestCase
-
-
-+def clean_string_whitespace(x: str) -> str:
-+ # Remove trailing whitespace from the end of each line
-+ x = re.sub(r"\s+$", "", x, flags=re.MULTILINE)
-+ # Remove intermediate blank lines
-+ x = re.sub(r"\n\s*\n", r"\n", x, flags=re.MULTILINE)
-+ # Remove extraneous whitespace from the beginning and end of the string
-+ x = x.strip()
-+ return x
-+
-+
- # arvm7l needs extra ABI symbols to link successfully
- if platform.machine() == 'armv7l':
- llvm.load_library_permanently('libgcc_s.so.1')
-@@ -158,7 +168,7 @@ def no_de_locale():
- target triple = "unknown-unknown-unknown"
- target datalayout = ""
-
--define i32 @"foo"()
-+define i32 @"foo"()
- {
- "<>!*''#":
- ret i32 12345
-@@ -424,7 +434,10 @@ def test_nonalphanum_block_name(self):
- bd = ir.IRBuilder(fn.append_basic_block(name="<>!*''#"))
- bd.ret(ir.Constant(ir.IntType(32), 12345))
- asm = str(mod)
-- self.assertEqual(asm, asm_nonalphanum_blocklabel)
-+ self.assertEqual(
-+ clean_string_whitespace(asm),
-+ clean_string_whitespace(asm_nonalphanum_blocklabel)
-+ )
-
- def test_global_context(self):
- gcontext1 = llvm.context.get_global_context()
-@@ -509,7 +522,7 @@ def test_set_option(self):
- def test_version(self):
- major, minor, patch = llvm.llvm_version_info
- # one of these can be valid
-- valid = [(11,)]
-+ valid = [(11,), (12,), (13,)]
- self.assertIn((major,), valid)
- self.assertIn(patch, range(10))
-
diff --git a/dev-python/llvmlite/llvmlite-0.37.0-r1.ebuild b/dev-python/llvmlite/llvmlite-0.37.0-r1.ebuild
deleted file mode 100644
index 607c1bb0b..000000000
--- a/dev-python/llvmlite/llvmlite-0.37.0-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 llvm
-
-DESCRIPTION="Python wrapper around the llvm C++ library"
-HOMEPAGE="https://llvmlite.pydata.org/"
-SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
-S="${WORKDIR}/${P/_/}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="examples"
-
-LLVM_MAX_SLOT=12
-
-RDEPEND="
- sys-devel/llvm:${LLVM_MAX_SLOT}
- sys-libs/zlib:0=
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-llvm12.patch" )
-
-src_prepare() {
- sed -i -e '/max_python/s:3\.10:3.11:' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_configure_all() {
- # upstream's build system is just horrible, and they ignored the PR
- # fixing it, so let's build the shared lib properly using implicit
- # make rules
-
- export LDLIBS=$(llvm-config --libs all)
- export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
- export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
-
- local files=( ffi/*.cpp )
- emake -f - <<EOF
-ffi/libllvmlite.so: ${files[*]/.cpp/.o}
- \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
-EOF
-
- export LLVMLITE_SKIP_LLVM_VERSION_CHECK=1
-}
-
-python_test() {
- "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/llvmlite/llvmlite-0.38.0-r1.ebuild b/dev-python/llvmlite/llvmlite-0.38.0-r1.ebuild
deleted file mode 100644
index 607c1bb0b..000000000
--- a/dev-python/llvmlite/llvmlite-0.38.0-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 llvm
-
-DESCRIPTION="Python wrapper around the llvm C++ library"
-HOMEPAGE="https://llvmlite.pydata.org/"
-SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
-S="${WORKDIR}/${P/_/}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="examples"
-
-LLVM_MAX_SLOT=12
-
-RDEPEND="
- sys-devel/llvm:${LLVM_MAX_SLOT}
- sys-libs/zlib:0=
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-llvm12.patch" )
-
-src_prepare() {
- sed -i -e '/max_python/s:3\.10:3.11:' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_configure_all() {
- # upstream's build system is just horrible, and they ignored the PR
- # fixing it, so let's build the shared lib properly using implicit
- # make rules
-
- export LDLIBS=$(llvm-config --libs all)
- export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
- export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
-
- local files=( ffi/*.cpp )
- emake -f - <<EOF
-ffi/libllvmlite.so: ${files[*]/.cpp/.o}
- \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
-EOF
-
- export LLVMLITE_SKIP_LLVM_VERSION_CHECK=1
-}
-
-python_test() {
- "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}