aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-05-25 19:06:02 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-05-25 19:06:02 +0200
commitd805524ebec05ff72441b62abc653ba037e2087a (patch)
treeaff62f4b96bf08d56db9f6fa80d9eb00cfce11ce
parentsci-biology/verifyBamID: work around compile error with g++-7.1.0 (diff)
downloadsci-d805524ebec05ff72441b62abc653ba037e2087a.tar.gz
sci-d805524ebec05ff72441b62abc653ba037e2087a.tar.bz2
sci-d805524ebec05ff72441b62abc653ba037e2087a.zip
sci-biology/verifyBamID: another attempt at removing the -Werror
Somehow the sed calls do not work, disable -Werror append by defining the variable non-empty Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--sci-biology/verifyBamID/verifyBamID-1.1.3.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/sci-biology/verifyBamID/verifyBamID-1.1.3.ebuild b/sci-biology/verifyBamID/verifyBamID-1.1.3.ebuild
index d51fd4821..040816a76 100644
--- a/sci-biology/verifyBamID/verifyBamID-1.1.3.ebuild
+++ b/sci-biology/verifyBamID/verifyBamID-1.1.3.ebuild
@@ -20,20 +20,19 @@ DEPEND=""
RDEPEND="${DEPEND}"
src_prepare(){
- default
# unpack ./libStatGen-1.0.13/ contents
gzip -dc "${DISTDIR}"/libStatGen-1.0.13.tar.gz | tar xf - || die
ln -s libStatGen-1.0.13 libStatGen || die
cd "${WORKDIR}" || die
ln -s libStatGen-1.0.13 libStatGen || die
- cd "${WORKDIR}" || die
sed -e 's/-Werror//' -i verifyBamID-1.1.3/src/Makefile || die
- sed -e 's/-Werror//' -i libStatGen-1.0.13/general/Makefile || die
+ sed -e 's/-Werror//' -i verifyBamID-1.1.3/libStatGen-1.0.13/general/Makefile || die
+ eapply_user
}
src_compile(){
# LIB_PATH_GENERAL="${EPREFIX}"/usr/"$(get_libdir)" emake
- LIB_PATH_GENERAL="../libStatGen-1.0.13" emake
+ LIB_PATH_GENERAL="../libStatGen-1.0.13" emake USER_WARNINGS=' '
}
src_install(){