aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-04-08 13:32:34 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-04-09 15:05:35 +0200
commitd92a65a7066fd6bc6467e88a26c33e9e5a152a8e (patch)
tree245e4dd5b19797e6347335d1c18b0670a0a4ae9f
parentsci-physics/formcalc: fix chmod cannot access (diff)
downloadsci-d92a65a7066fd6bc6467e88a26c33e9e5a152a8e.tar.gz
sci-d92a65a7066fd6bc6467e88a26c33e9e5a152a8e.tar.bz2
sci-d92a65a7066fd6bc6467e88a26c33e9e5a152a8e.zip
sci-physics/cernlib: split free and non-free
Closes: https://github.com/gentoo/sci/pull/1265 Co-authored-by: Andrew Nowa Ammerlaan <andrewammerlaan@gentoo.org> Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--sci-physics/cernlib/Manifest1
-rw-r--r--sci-physics/cernlib/cernlib-2023.10.31.0-r1.ebuild (renamed from sci-physics/cernlib/cernlib-2023.10.31.0.ebuild)28
-rw-r--r--sci-physics/cernlib/metadata.xml3
3 files changed, 26 insertions, 6 deletions
diff --git a/sci-physics/cernlib/Manifest b/sci-physics/cernlib/Manifest
index 36a5a1f78..d8be46729 100644
--- a/sci-physics/cernlib/Manifest
+++ b/sci-physics/cernlib/Manifest
@@ -1 +1,2 @@
DIST cernlib-2023.10.31.0-free.tar.gz 39191038 BLAKE2B 941592a65f0c8d7d0c6c3907c96d8209568579dac455ed28657a5635677d73e6580f48667a641a6ca9dd296bf82a40f6a75c5fc801fcefb7f8e9101b4dcd3202 SHA512 d015f89942bab695444d37847a8138c3a8736ceeb6f4826c659553bf1ae5eab2a77b2871645a125ea189e62520856955070fbb3ed2d208d35f82ee8b8559d089
+DIST cernlib-2023.10.31.0.tar.gz 39547453 BLAKE2B f37686e4a43b969a8cb604874b6181adf8529b9fc383ccd2e42fc369f92d4693ca8db682bc58638cb58e9941cf22551cfec26b33075e15fc6a0b3fab3dcf7d82 SHA512 9bc866d08e3bce2f571f9f4e21e34ca6c99467088d4dce4cbc9b6c62d8ee2b9018668fd66795996a5f6abb1082ac9559cf08bc7f5201421dbffcdd0db9459008
diff --git a/sci-physics/cernlib/cernlib-2023.10.31.0.ebuild b/sci-physics/cernlib/cernlib-2023.10.31.0-r1.ebuild
index 697a25ef0..326fadde3 100644
--- a/sci-physics/cernlib/cernlib-2023.10.31.0.ebuild
+++ b/sci-physics/cernlib/cernlib-2023.10.31.0-r1.ebuild
@@ -3,14 +3,22 @@ EAPI=8
CMAKE_MAKEFILE_GENERATOR="emake"
inherit cmake fortran-2
+MY_P="${P}"
DESCRIPTION="CERN program library for High Energy Physics"
HOMEPAGE="https://cernlib.web.cern.ch/cernlib/"
-SRC_URI="https://cernlib.web.cern.ch/download/2023_source/tar/${P}-free.tar.gz"
-S="${WORKDIR}/${P}-free"
+SRC_URI="
+ free? ( https://cernlib.web.cern.ch/download/2023_source/tar/${P}-free.tar.gz )
+ !free? ( https://cernlib.web.cern.ch/download/2023_source/tar/${P}.tar.gz )
+"
-LICENSE="GPL-3"
+LICENSE="
+ free? ( BSD LGPL-2+ GPL-1+ )
+ !free? ( all-rights-reserved )
+"
SLOT="0"
KEYWORDS="~amd64"
+IUSE="+free"
+RESTRICT="mirror"
RDEPEND="
x11-libs/motif:0
@@ -28,10 +36,18 @@ BDEPEND="
"
PATCHES=(
- "${FILESDIR}"/$P-cfortran.patch
- "${FILESDIR}"/$P-ctest.patch
- "${FILESDIR}"/$P-man.patch
+ "${FILESDIR}"/${P}-cfortran.patch
+ "${FILESDIR}"/${P}-ctest.patch
+ "${FILESDIR}"/${P}-man.patch
)
+
+src_unpack() {
+ default
+ if use free; then
+ mv ${P}-free ${P} || die
+ fi
+}
+
src_prepare() {
cmake_src_prepare
# cfortran.patch
diff --git a/sci-physics/cernlib/metadata.xml b/sci-physics/cernlib/metadata.xml
index 887c950bc..dcbfb9b47 100644
--- a/sci-physics/cernlib/metadata.xml
+++ b/sci-physics/cernlib/metadata.xml
@@ -18,4 +18,7 @@
mathematics, data analysis, detectors simulation, data-handling
etc... applicable to a wide range of problems.
</longdescription>
+ <use>
+ <flag name="free"> Use free sources </flag>
+ </use>
</pkgmetadata>