aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2011-02-25 06:20:23 +0100
committerHonza Macháček <Hloupy.Honza@centrum.cz>2011-02-25 06:20:23 +0100
commitdcb3e14bb9188a1ee00c3ed0fea612bc8f6abaec (patch)
tree82fe7a2c6e38c2775b23c3b2aa9c1ad354c79e42
parentA program to generate atomic data for the Projector Augmented Wave method of ... (diff)
downloadsci-dcb3e14bb9188a1ee00c3ed0fea612bc8f6abaec.tar.gz
sci-dcb3e14bb9188a1ee00c3ed0fea612bc8f6abaec.tar.bz2
sci-dcb3e14bb9188a1ee00c3ed0fea612bc8f6abaec.zip
A supporting utility of sci-physics/abinit to convert the data generated by sci-physics/atompaw for the use with abinit
-rw-r--r--sci-physics/atompaw2abinit/ChangeLog11
-rw-r--r--sci-physics/atompaw2abinit/atompaw2abinit-3.3.0.ebuild52
2 files changed, 63 insertions, 0 deletions
diff --git a/sci-physics/atompaw2abinit/ChangeLog b/sci-physics/atompaw2abinit/ChangeLog
new file mode 100644
index 000000000..7b94567d3
--- /dev/null
+++ b/sci-physics/atompaw2abinit/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-physics/atompaw2abinit
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*atompaw2abinit-3.3.0 (25 Feb 2011)
+
+ 25 Feb 2011; Honza Macháček <Hloupy.Honza@centrum.cz>
+ +atompaw2abinit-3.3.0.ebuild:
+ A supporting utility of sci-physics/abinit to convert the data generated by
+ sci-physics/atompaw for the use with abinit
+
diff --git a/sci-physics/atompaw2abinit/atompaw2abinit-3.3.0.ebuild b/sci-physics/atompaw2abinit/atompaw2abinit-3.3.0.ebuild
new file mode 100644
index 000000000..37c6dc648
--- /dev/null
+++ b/sci-physics/atompaw2abinit/atompaw2abinit-3.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Abinit AtomPAW atomic data convertor"
+HOMEPAGE="http://www.abinit.org/downloads/PAW/AtomPAW2Abinit-Manual-html/AtomPAW2Abinit2.htm"
+IUSE=""
+SRC_URI="http://www.abinit.org/downloads/PAW/AtomPAW2Abinit-Manual-html/Atompaw2Abinit.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="virtual/lapack
+ virtual/blas
+ sci-physics/atompaw"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/Atompaw2Abinit.v${PV}
+
+pkg_nofetch() {
+ elog "If there is a digest mismatch, please file a bug"
+ elog "at https://bugs.gentoo.org/ -- a version bump"
+ elog "is probably required."
+}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_configure() {
+ head -n 6 Makefile >Makefile.1
+ tail -n +6 Makefile >Makefile.2
+ cp Makefile.1 Makefile
+ echo FC = $(tc-getFC) >>Makefile
+ echo FFLAGS = ${FCFLAGS:- ${FFLAGS:- -O2}} >>Makefile
+ echo -n FFLAGS_LIBS= >>Makefile
+ pkg-config --libs lapack >>Makefile
+ echo >>Makefile
+ sed -e's/^\(FC *=\)/#\1/' -e's/^\(FFLAGS *=\)/#\1/' \
+ -e's/^\(FFLAGS_LIBS *=\)/#\1/' Makefile.2 >>Makefile
+}
+
+src_compile() {
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ dobin atompaw2abinit
+} \ No newline at end of file