aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-04-15 02:11:55 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-04-15 02:11:55 +0200
commitdd7e564441676f8fbce36c262cb15aa865f5b545 (patch)
tree6e7a28c912c5ab2a5e6ade7f89c4f55e499962c8
parentsci-libs/io_lib: version bump, support for alternative zlib implementations (diff)
downloadsci-dd7e564441676f8fbce36c262cb15aa865f5b545.tar.gz
sci-dd7e564441676f8fbce36c262cb15aa865f5b545.tar.bz2
sci-dd7e564441676f8fbce36c262cb15aa865f5b545.zip
sci-biology/flexbar: version bump, added KEYWORDS
We still could filter away '-Wl,-O1' from CXXFLAGS. Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--sci-biology/flexbar/Manifest1
-rw-r--r--sci-biology/flexbar/flexbar-3.0.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sci-biology/flexbar/Manifest b/sci-biology/flexbar/Manifest
index 4493b8c57..9711db441 100644
--- a/sci-biology/flexbar/Manifest
+++ b/sci-biology/flexbar/Manifest
@@ -1 +1,2 @@
DIST flexbar-2.7.0.tar.gz 30033 SHA256 8b44a16594e8a2f68d33acbcfdbfb0a017d2a6dc69cc65259b199ad94ea0f0e6 SHA512 38dc40476dadd769977dd2428941928e839e107e719e9b595c2ba57e1d8764fb394c5960b809da99dc939a66cae9350ea607e393b9467e98d464d0e49bcdac47 WHIRLPOOL da45d9bb8080ef7913324875dd0f8ac4a6f182337da1c217eaf9894ced407f78ff10637b62981466ad0cc2c4dde25d6d1d5235480112ebe67e7a21053b699247
+DIST flexbar-3.0.0.tar.gz 31292 SHA256 60226d62d9617a7026bdae4b6f5f695ac2bc839b7d19e1d7d9ab63f85aa31a74 SHA512 ccefb4d1342ce5353a64510f79f8b15c409eb68853eb98ed7c9b23cb53d926e5b6965b1a9d3d8a5b3699da2f18cf8a627d5ca3ed172e25693a80d878547d6d38 WHIRLPOOL fa341bad342e87edd697049b84ee368a895bef2ccc445b2d730d70a720ea3ce0c5170a3d9b793760c9a6e3762c451b971f8e28a4ba006335d6c4354d83cead3a
diff --git a/sci-biology/flexbar/flexbar-3.0.0.ebuild b/sci-biology/flexbar/flexbar-3.0.0.ebuild
new file mode 100644
index 000000000..65f5dd077
--- /dev/null
+++ b/sci-biology/flexbar/flexbar-3.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Barcode, MID tag and adapter sequence removal"
+HOMEPAGE="https://github.com/seqan/flexbar"
+SRC_URI="https://github.com/seqan/flexbar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+ dev-cpp/tbb
+ >=sci-biology/seqan-2.1.1:0
+ sys-libs/zlib
+ app-arch/bzip2"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+# TODO: need to call 'pkg-config --cflags seqan-2.2' and pass it down
+src_configure() {
+ local CPPFLAGS=${CPPFLAGS}
+ append-cppflags `pkg-config --cflags seqan-2.2`
+ local CXXFLAGS="${CXXFLAGS}"
+ append-cxxflags "-std=c++14"
+ cmake-utils_src_configure
+}
+
+# SeqAn requires C++14! You must compile your application with -std=c++14, -std=gnu++14 or -std=c++1y
+# https://github.com/seqan/flexbar/issues/8
+
+src_install(){
+ elog `pwd`
+ dobin ../"${P}"_build/flexbar
+ dodoc ../"${P}"/README.md
+}