aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-09-29 15:12:24 +0200
committerJustin Lecher <jlec@gentoo.org>2014-09-29 15:12:24 +0200
commitdf5e38cf351735f4822dd8706a8739368269bf6b (patch)
treee25dbcf26dc6c772fad53d74323d1b1115f0ba53
parentdev-util/smartgit: Enhance description; fix local variable (diff)
downloadsci-df5e38cf351735f4822dd8706a8739368269bf6b.tar.gz
sci-df5e38cf351735f4822dd8706a8739368269bf6b.tar.bz2
sci-df5e38cf351735f4822dd8706a8739368269bf6b.zip
sci-physics/root: Backport fix for build failure
Package-Manager: portage-2.2.14_rc1
-rw-r--r--sci-physics/root/ChangeLog4
-rw-r--r--sci-physics/root/files/root-6.00.02-tm_zone.patch22
-rw-r--r--sci-physics/root/metadata.xml38
-rw-r--r--sci-physics/root/root-6.00.02.ebuild3
4 files changed, 47 insertions, 20 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index e2b9be70f..9b455b6c3 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.96 2012/03/29 18:21:49 bicatali Exp $
+ 29 Sep 2014; Justin Lecher <jlec@gentoo.org> root-6.00.02.ebuild,
+ +files/root-6.00.02-tm_zone.patch, metadata.xml:
+ Backport fix for build failure
+
*root-5.34.18-r2 (06 Jul 2014)
06 Jul 2014; Andrew Savchenko <bircoph@gmail.com> +root-5.34.18-r2.ebuild,
diff --git a/sci-physics/root/files/root-6.00.02-tm_zone.patch b/sci-physics/root/files/root-6.00.02-tm_zone.patch
new file mode 100644
index 000000000..cdd1b13e4
--- /dev/null
+++ b/sci-physics/root/files/root-6.00.02-tm_zone.patch
@@ -0,0 +1,22 @@
+From 08b08412bafc24fa635b0fdb832097a3aa2fa1d2 Mon Sep 17 00:00:00 2001
+From: Pere Mato <pere.mato@cern.ch>
+Date: Sun, 21 Sep 2014 19:27:30 +0200
+Subject: [PATCH] Fix for ROOT-6728 - Compilation error in TTimeStamp
+
+---
+ core/base/src/TTimeStamp.cxx | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/core/base/src/TTimeStamp.cxx b/core/base/src/TTimeStamp.cxx
+index 8709220..f0ff12d 100644
+--- a/core/base/src/TTimeStamp.cxx
++++ b/core/base/src/TTimeStamp.cxx
+@@ -813,7 +813,7 @@ void TTimeStamp::DumpTMStruct(const tm_t &tmstruct)
+ tmstruct.tm_isdst);
+ #if (defined(linux) && !defined(R__WINGCC)) || defined(R__MACOSX)
+ printf(",\n tm_gmtoff %6ld, tm_zone \"%s\"",
+-#if defined(__USE_BSD) || defined(R__MACOSX)
++#if defined(__USE_BSD) || defined(R__MACOSX) || defined(__USE_MISC)
+ tmstruct.tm_gmtoff, tmstruct.tm_zone);
+ #else
+ tmstruct.__tm_gmtoff, tmstruct.__tm_zone);
diff --git a/sci-physics/root/metadata.xml b/sci-physics/root/metadata.xml
index 622d99ad4..abe803e9e 100644
--- a/sci-physics/root/metadata.xml
+++ b/sci-physics/root/metadata.xml
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>bircoph@gmail.com</email>
- <name>Andrew Savchenko</name>
- <description>Maintainer. Assign bugs to him</description>
-</maintainer>
-<herd>sci-physics</herd>
-<herd>proxy-maintainers</herd>
-<longdescription lang="en">
+ <maintainer>
+ <email>bircoph@gmail.com</email>
+ <name>Andrew Savchenko</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <herd>sci-physics</herd>
+ <herd>proxy-maintainers</herd>
+ <longdescription lang="en">
ROOT Object Oriented Technologies is an object oriented data
analysis framework written in C++ by the CERN. Widely used in
high energy physics, but also in other data analysis applications. It
@@ -16,15 +16,15 @@
statistics, serialization, optimization, linear algebra, graphics,
GUI toolkit, and a complete visualization framework.
</longdescription>
-<use>
- <flag name="c++0x"> Build ROOT using the C++11 standard. Not supported, requires <pkg>sys-devel/gcc</pkg>&gt;=4.7.0</flag>
- <flag name="fits">Support for images and data from FITS files with <pkg>sci-libs/cfitsio</pkg></flag>
- <flag name="geocad">Enable ROOT-CAD interface using <pkg>sci-libs/opencascade</pkg></flag>
- <flag name="http">Enable http server support including but not limited to fastcgi support</flag>
- <flag name="math">Build all math related libraries plugins, needs <pkg>sci-libs/gsl</pkg> </flag>
- <flag name="pythia6">Build the interface for <pkg>sci-physics/pythia</pkg> version 6.x </flag>
- <flag name="pythia8">Build the interface for <pkg>sci-physics/pythia</pkg> version 8.x </flag>
- <flag name="reflex">Build the reflection database for the C++ interpreter</flag>
- <flag name="xrootd">Build the interface for <pkg>net-libs/xrootd</pkg> </flag>
-</use>
+ <use>
+ <flag name="c++0x"> Build ROOT using the C++11 standard. Not supported, requires <pkg>sys-devel/gcc</pkg>&gt;=4.7.0</flag>
+ <flag name="fits">Support for images and data from FITS files with <pkg>sci-libs/cfitsio</pkg></flag>
+ <flag name="geocad">Enable ROOT-CAD interface using <pkg>sci-libs/opencascade</pkg></flag>
+ <flag name="http">Enable http server support including but not limited to fastcgi support</flag>
+ <flag name="math">Build all math related libraries plugins, needs <pkg>sci-libs/gsl</pkg> </flag>
+ <flag name="pythia6">Build the interface for <pkg>sci-physics/pythia</pkg> version 6.x </flag>
+ <flag name="pythia8">Build the interface for <pkg>sci-physics/pythia</pkg> version 8.x </flag>
+ <flag name="reflex">Build the reflection database for the C++ interpreter</flag>
+ <flag name="xrootd">Build the interface for <pkg>net-libs/xrootd</pkg> </flag>
+ </use>
</pkgmetadata>
diff --git a/sci-physics/root/root-6.00.02.ebuild b/sci-physics/root/root-6.00.02.ebuild
index 01d4eda5a..5208cc9f3 100644
--- a/sci-physics/root/root-6.00.02.ebuild
+++ b/sci-physics/root/root-6.00.02.ebuild
@@ -201,7 +201,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-6.00.01-prop-flags.patch \
"${FILESDIR}"/${PN}-6.00.01-llvm.patch \
"${FILESDIR}"/${PN}-6.00.01-geocad.patch \
- "${FILESDIR}"/${PN}-6.00.01-tutorials-path.patch
+ "${FILESDIR}"/${PN}-6.00.01-tutorials-path.patch \
+ "${FILESDIR}"/${PN}-6.00.02-tm_zone.patch
# make sure we use system libs and headers
rm montecarlo/eg/inc/cfortran.h README/cfortran.doc || die